aboutsummaryrefslogtreecommitdiff
path: root/textproc/gdict
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-07-14 21:02:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-07-14 21:02:36 +0000
commita75bdd6fb9e1582d61f74bec72b07d0e9d86a978 (patch)
tree880ae4beb929c15ebd4406a103ed39653684303e /textproc/gdict
parentf689b045f035b9bebad4c442d1a65f92556e5596 (diff)
downloadports-a75bdd6fb9e1582d61f74bec72b07d0e9d86a978.tar.gz
ports-a75bdd6fb9e1582d61f74bec72b07d0e9d86a978.zip
Notes
Diffstat (limited to 'textproc/gdict')
-rw-r--r--textproc/gdict/Makefile19
-rw-r--r--textproc/gdict/distinfo2
-rw-r--r--textproc/gdict/files/patch-Makefile14
-rw-r--r--textproc/gdict/files/patch-dict.c25
-rw-r--r--textproc/gdict/files/patch-gdict.c26
-rw-r--r--textproc/gdict/pkg-descr4
-rw-r--r--textproc/gdict/pkg-plist2
7 files changed, 0 insertions, 92 deletions
diff --git a/textproc/gdict/Makefile b/textproc/gdict/Makefile
deleted file mode 100644
index f2b3217bbc3c..000000000000
--- a/textproc/gdict/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# Created by: domi@saargate.de
-# $FreeBSD$
-
-PORTNAME= gdict
-PORTVERSION= 0.7
-PORTREVISION= 5
-CATEGORIES= textproc
-MASTER_SITES= http://www.brettnacher.org/users/dominik/FreeBSD/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Small program that finds definitions of arbitrary (English) words
-
-USE_GNOME= gtk12
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gdict ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/dict ${STAGEDIR}${PREFIX}/bin/cdict
-
-.include <bsd.port.mk>
diff --git a/textproc/gdict/distinfo b/textproc/gdict/distinfo
deleted file mode 100644
index d333f9dcaf88..000000000000
--- a/textproc/gdict/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gdict-0.7.tar.gz) = 68236355bba09feb2ae6896cb6d3341ac6bb79cec9c8123ca498846874ab8035
-SIZE (gdict-0.7.tar.gz) = 12053
diff --git a/textproc/gdict/files/patch-Makefile b/textproc/gdict/files/patch-Makefile
deleted file mode 100644
index 73d891eaf6a8..000000000000
--- a/textproc/gdict/files/patch-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile Mon Mar 29 08:02:27 1999
-+++ Makefile~ Thu Jul 22 22:25:09 1999
-@@ -1,8 +1,8 @@
- # Makefile for gdict
-
--CC = gcc
--CFLAGS = -O6 -Wall
--CFL_GTK = $(CFLAGS) `gtk-config --cflags` `gtk-config --libs`
-+CC ?= gcc
-+CFLAGS ?= -O6 -Wall
-+CFL_GTK = $(CFLAGS) `$(GTK_CONFIG) --cflags` `$(GTK_CONFIG) --libs`
- CFL = $(CFLAGS)
- OBJECTS_GDICT = gdict.c
- OBJECTS_DICT = dict.c
diff --git a/textproc/gdict/files/patch-dict.c b/textproc/gdict/files/patch-dict.c
deleted file mode 100644
index 3dca82fad976..000000000000
--- a/textproc/gdict/files/patch-dict.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- dict.c Mon Mar 29 08:10:35 1999
-+++ dict.c~ Thu Jul 22 22:25:16 1999
-@@ -4,11 +4,12 @@
- * Thanks goes out to #linuxos also. :)
- */
-
-+#include <sys/types.h>
- #include <stdio.h>
- #include <sys/socket.h>
- #include <unistd.h>
--#include <arpa/inet.h>
- #include <netinet/in.h>
-+#include <arpa/inet.h>
- #include <string.h>
-
- int main (int argc, char *argv[]) {
-@@ -40,7 +41,7 @@
- Sockaddr.sin_port = htons(2627);
- Sockaddr.sin_addr.s_addr = inet_addr("128.52.39.7");
-
-- err = connect (sd, &Sockaddr, sizeof(Sockaddr) );
-+ err = connect (sd, (struct sockaddr *) &Sockaddr, sizeof(Sockaddr) );
-
- if (err != 0) {
- printf("Could not connect to dictionary server!\n");
diff --git a/textproc/gdict/files/patch-gdict.c b/textproc/gdict/files/patch-gdict.c
deleted file mode 100644
index fe5706794164..000000000000
--- a/textproc/gdict/files/patch-gdict.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- gdict.c Mon Mar 29 17:35:54 1999
-+++ gdict.c~ Thu Jul 22 22:25:19 1999
-@@ -13,12 +13,13 @@
- * Window resizing and cleanup by Iain (Nodatadj, EFNet) 23-Mar-1999
- */
-
-+#include <sys/types.h>
- #include <gtk/gtk.h>
- #include <stdio.h>
- #include <sys/socket.h>
- #include <unistd.h>
--#include <arpa/inet.h>
- #include <netinet/in.h>
-+#include <arpa/inet.h>
- #include <string.h>
-
- /* globals */
-@@ -154,7 +155,7 @@
- Sockaddr.sin_port = htons(2627);
- Sockaddr.sin_addr.s_addr = inet_addr ("128.52.39.7");
-
-- err = connect (sd, &Sockaddr, sizeof(Sockaddr));
-+ err = connect (sd, (struct sockaddr *) &Sockaddr, sizeof(Sockaddr));
-
- if (err != 0) {
- sprintf (buffer, "Could not connect to dictionary server!");
diff --git a/textproc/gdict/pkg-descr b/textproc/gdict/pkg-descr
deleted file mode 100644
index 0dfd7566c81f..000000000000
--- a/textproc/gdict/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-gdict is a small C/GTK+ program written to find definitions of arbitrary
-words. It contacts the MIT dictionary server and returns a definition.
-
-Additionally, there is a CLI version named "cdict".
diff --git a/textproc/gdict/pkg-plist b/textproc/gdict/pkg-plist
deleted file mode 100644
index 0f3f730eb719..000000000000
--- a/textproc/gdict/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/cdict
-bin/gdict