aboutsummaryrefslogtreecommitdiff
path: root/textproc/gdome2/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-09 14:23:34 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-09 14:23:34 +0000
commit8b7ec1afe81734275f7746664a702496a155c818 (patch)
tree6c1e882b3f2df8e19ed3d641cdacd86a7afc59f6 /textproc/gdome2/Makefile
parent4ac5e38865c5956af021f23d064b8f992b805137 (diff)
Notes
Diffstat (limited to 'textproc/gdome2/Makefile')
-rw-r--r--textproc/gdome2/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/textproc/gdome2/Makefile b/textproc/gdome2/Makefile
index b5098c36bd96..f59013785428 100644
--- a/textproc/gdome2/Makefile
+++ b/textproc/gdome2/Makefile
@@ -6,24 +6,32 @@
#
PORTNAME= gdome2
-PORTVERSION= 0.6.8
+PORTVERSION= 0.7.2
CATEGORIES= textproc
-MASTER_SITES= http://www.cs.unibo.it/~casarini/gdome2/tarball/
+MASTER_SITES= http://phd.cs.unibo.it/gdome2/tarball/
MAINTAINER= knu@FreeBSD.org
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_GLIB= yes
-
USE_LIBTOOL= yes
CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include"
PLIST_SUB= DOCSDIR="share/doc/${DISTNAME}"
-
INSTALLS_SHLIB= yes
+MAN1= gdome-config.1
+
post-patch:
- ${PERL} -i -pe 's,^(HTML_DIR *= *).*,$$1\$$(prefix)/share/doc,' ${WRKSRC}/gtk-doc/Makefile.in
- @${FIND} ${WRKSRC} -type f | xargs ${PERL} -i -pe 's,<parser.h>,<libxml/parser.h>,;s,<hash.h>,<libxml/hash.h>,;s,<xmlmemory.h>,<libxml/xmlmemory.h>,;s,<tree.h>,<libxml/tree.h>,;s,<xmlerror.h>,<libxml/xmlerror.h>,;s,<xmlIO.h>,<libxml/xmlIO.h>,;s,<parserInternals.h>,<libxml/parserInternals.h>,;s,<entities.h>,<libxml/entities.h>,'
+ @${PERL} -i -pe 's,^(HTML_DIR *= *).*,$$1\$$(prefix)/share/doc,' ${WRKSRC}/gtk-doc/Makefile.in
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -i -pe \
+ 's,<parser.h>,<libxml/parser.h>,; \
+ s,<hash.h>,<libxml/hash.h>,; \
+ s,<xmlmemory.h>,<libxml/xmlmemory.h>,; \
+ s,<tree.h>,<libxml/tree.h>,; \
+ s,<xmlerror.h>,<libxml/xmlerror.h>,; \
+ s,<xmlIO.h>,<libxml/xmlIO.h>,; \
+ s,<parserInternals.h>,<libxml/parserInternals.h>,; \
+ s,<entities.h>,<libxml/entities.h>,'
.include <bsd.port.mk>