aboutsummaryrefslogtreecommitdiff
path: root/textproc/gdome2/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-12 06:10:39 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-12 06:10:39 +0000
commit40fe7e9ee70e89ea91b299a36ada45bb055319a3 (patch)
treef28ef54fed172ce1f7e8df97e1b0e1b539fe9cbb /textproc/gdome2/Makefile
parentf1d894e40c67154caab7a4110476d9f43a8f836a (diff)
Notes
Diffstat (limited to 'textproc/gdome2/Makefile')
-rw-r--r--textproc/gdome2/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/gdome2/Makefile b/textproc/gdome2/Makefile
new file mode 100644
index 000000000000..47649ced406c
--- /dev/null
+++ b/textproc/gdome2/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gdome2
+# Date created: 7 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdome2
+PORTVERSION= 0.6.8
+CATEGORIES= textproc
+MASTER_SITES= http://www.cs.unibo.it/~casarini/gdome2/tarball/
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+WANT_GLIB= yes
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include"
+PLIST_SUB= DOCSDIR="share/doc/${DISTNAME}"
+
+INSTALLS_SHLIB= yes
+
+post-patch:
+ ${PERL} -i -pe 's,^(HTML_DIR *= *).*,$$1\$$(prefix)/share/doc,' ${WRKSRC}/gtk-doc/Makefile.in
+
+.include <bsd.port.mk>