aboutsummaryrefslogtreecommitdiff
path: root/textproc/gladtex
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-05-01 20:29:46 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-05-01 20:29:46 +0000
commit3bde10fa5c45c7d17d0b8dfa3434c3f0ff397798 (patch)
tree9b94fc1e818d97cec1195e62bb808ceedd4baa0b /textproc/gladtex
parente492e231b99d8db0928d857fe6c7b6d4d3f56692 (diff)
downloadports-3bde10fa5c45c7d17d0b8dfa3434c3f0ff397798.tar.gz
ports-3bde10fa5c45c7d17d0b8dfa3434c3f0ff397798.zip
Notes
Diffstat (limited to 'textproc/gladtex')
-rw-r--r--textproc/gladtex/Makefile31
-rw-r--r--textproc/gladtex/distinfo4
-rw-r--r--textproc/gladtex/files/patch-Makefile24
-rw-r--r--textproc/gladtex/files/patch-eqn2img.c9
-rw-r--r--textproc/gladtex/pkg-descr2
-rw-r--r--textproc/gladtex/pkg-plist4
6 files changed, 37 insertions, 37 deletions
diff --git a/textproc/gladtex/Makefile b/textproc/gladtex/Makefile
index df7cfa0aa908..e2c89281d459 100644
--- a/textproc/gladtex/Makefile
+++ b/textproc/gladtex/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= gladtex
-PORTVERSION= 1.1
-PORTREVISION= 3
+PORTVERSION= 1.2
+#PORTREVISION= 0
CATEGORIES= textproc math www
-MASTER_SITES= http://www.math.uio.no/~martingu/gladtex/dl/ \
- http://nivi.interfree.it/distfiles/${PORTNAME}/
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= nivit@FreeBSD.org
COMMENT= A program to replace LaTeX formulas in HTML files with images
-LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
+LICENSE= GPLv2
+
+LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
png.6:${PORTSDIR}/graphics/png
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
dvips:${PORTSDIR}/print/dvipsk-tetex
-USE_PERL5_RUN= yes
+USE_PERL5= yes
BINPATH= ${PREFIX}/bin
INCPATH= -I${LOCALBASE}/include
@@ -28,17 +30,16 @@ LIBPATH= -L${LOCALBASE}/lib
MAKE_ENV+= BINPATH=${BINPATH} INCPATH=${INCPATH} LIBPATH=${LIBPATH}
-DOCSFILES= README
-
-post-extract:
- @@cd ${WRKSRC};
- ${RM} -f eqn2img
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= ${PORTNAME}.1
+.endif
-post-install:
-.if !defined(NOPORTDOCS)
+do-install:
@cd ${WRKSRC}; \
- ${MKDIR} ${DOCSDIR}; \
- ${INSTALL_DATA} ${DOCSFILES} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${PORTNAME} ${BINPATH}; \
+ ${INSTALL_PROGRAM} eqn2img ${BINPATH}
+.if !defined(NO_INSTALL_MANPAGES)
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/
.endif
.include <bsd.port.mk>
diff --git a/textproc/gladtex/distinfo b/textproc/gladtex/distinfo
index 456b568548f5..284e06e11aef 100644
--- a/textproc/gladtex/distinfo
+++ b/textproc/gladtex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gladtex-1.1.tar.gz) = d299419c46822df1b0b5dc63d780a7d546264be985cb738ee0a7a64280a210fc
-SIZE (gladtex-1.1.tar.gz) = 19762
+SHA256 (gladtex-1.2.tar.gz) = ecb9a524e0fbbaeecff2c66f59a5ad7dbaea45fc3d554af15dbd12b041a45a61
+SIZE (gladtex-1.2.tar.gz) = 20210
diff --git a/textproc/gladtex/files/patch-Makefile b/textproc/gladtex/files/patch-Makefile
index af539c45f66f..62033e295e74 100644
--- a/textproc/gladtex/files/patch-Makefile
+++ b/textproc/gladtex/files/patch-Makefile
@@ -1,20 +1,22 @@
-$FreeBSD$
---- Makefile Wed Oct 30 13:24:34 2002
-+++ Makefile.port Sat Feb 4 21:43:23 2006
-@@ -1,14 +1,17 @@
+--- ./Makefile.orig 2012-05-01 18:11:56.000000000 +0200
++++ ./Makefile 2012-05-01 18:15:04.000000000 +0200
+@@ -1,18 +1,19 @@
+ # Makefile for gladtex
+
-BINPATH = /usr/local/bin
+-MANPATH = /usr/local/share/man/man1
+BINPATH?= /usr/local/bin
-+LIBPATH?= /usr/local/lib
-+INCPATH?= /usr/local/include
++MANPATH?= /usr/local/share/man/man1
-CC = gcc -O2 -DGIF
--LIB = -lm -lz -lungif -lpng
+-LIB = -lm -lz -lgif -lpng
+CC = gcc
+CFLAGS+= -DGIF ${INCPATH}
-+LIB = -lm -lz ${LIBPATH} -lungif -lpng
++LIB = -lm -lz ${LIBPATH} -lgif -lpng
OBJ = eqn2img.o
+ POD2MAN = pod2man
- all: ${OBJ}
+ all: ${OBJ} gladtex.1
- ${CC} -o eqn2img ${LIB} ${OBJ}
+ ${CC} ${CFLAGS} -o eqn2img ${LIB} ${OBJ}
@@ -22,5 +24,5 @@ $FreeBSD$
- ${CC} -c eqn2img.c
+ ${CC} ${CFLAGS} -c eqn2img.c
- install: all
- install -m 755 -s eqn2img ${BINPATH}
+ gladtex.1: gladtex.pod
+ ${POD2MAN} -c "User Commands" -r "gladtex 1.2" gladtex.pod > gladtex.1
diff --git a/textproc/gladtex/files/patch-eqn2img.c b/textproc/gladtex/files/patch-eqn2img.c
index cb48cd7ba0ca..8ce0099711e6 100644
--- a/textproc/gladtex/files/patch-eqn2img.c
+++ b/textproc/gladtex/files/patch-eqn2img.c
@@ -1,10 +1,9 @@
-$FreeBSD$
---- eqn2img.c 2007-10-05 17:51:48.000000000 +0200
-+++ eqn2img.c.port 2007-12-19 14:08:52.000000000 +0100
-@@ -691,7 +691,7 @@
+--- ./eqn2img.c.orig 2012-05-01 18:17:08.000000000 +0200
++++ ./eqn2img.c 2012-05-01 18:18:00.000000000 +0200
+@@ -715,7 +715,7 @@
fprintf(stderr, " -> ps");
- cmd = NEW(char, 2*strlen(basename) + 35);
+ cmd = NEW(char, 2*strlen(basename) + 38);
- sprintf(cmd, "dvips -E -o %s.ps %s.dvi > /dev/null 2>&1", basename, basename);
+ sprintf(cmd, "dvips -q -E -o %s.ps %s.dvi > /dev/null 2>&1", basename, basename);
if(system(cmd)) {
diff --git a/textproc/gladtex/pkg-descr b/textproc/gladtex/pkg-descr
index 6ffc3ff09311..3f117b447682 100644
--- a/textproc/gladtex/pkg-descr
+++ b/textproc/gladtex/pkg-descr
@@ -2,4 +2,4 @@ Gladtex reads a 'htex' file (html with LaTeX maths embedded in <EQ></EQ>)
and produces html with equations substituted by images.
Author: Martin G. Gulbrandsen
-WWW: http://www.math.uio.no/~martingu/gladtex/
+WWW: http://ans.hsh.no/home/mgg/gladtex/index.html
diff --git a/textproc/gladtex/pkg-plist b/textproc/gladtex/pkg-plist
index 3605fcd1d29d..d3d1b48bb55d 100644
--- a/textproc/gladtex/pkg-plist
+++ b/textproc/gladtex/pkg-plist
@@ -1,5 +1,3 @@
@comment $FreeBSD$
-bin/gladtex
bin/eqn2img
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+bin/gladtex