aboutsummaryrefslogtreecommitdiff
path: root/textproc/gmetadom/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-15 12:06:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-15 12:06:20 +0000
commit9103303804ac8d380411200aa1406a95f9dbdd16 (patch)
tree3cf1269721b2b16a19a6663d259c79ade8b02443 /textproc/gmetadom/Makefile
parent1bdd845e2e8db02ebcb58c84b08f7eb298de327c (diff)
downloadports-9103303804ac8d380411200aa1406a95f9dbdd16.tar.gz
ports-9103303804ac8d380411200aa1406a95f9dbdd16.zip
Notes
Diffstat (limited to 'textproc/gmetadom/Makefile')
-rw-r--r--textproc/gmetadom/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/gmetadom/Makefile b/textproc/gmetadom/Makefile
new file mode 100644
index 000000000000..dd3c22e7667e
--- /dev/null
+++ b/textproc/gmetadom/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: gmetadom
+# Date created: Jul 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmetadom
+PORTVERSION= 0.0.3c
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-0.0.3
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
+ xslt:${PORTSDIR}/textproc/libxslt \
+ gdome:${PORTSDIR}/textproc/gdome2 \
+ iconv:${PORTSDIR}/converters/libiconv
+
+USE_GNOMENG= yes
+USE_GNOME= glib12
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>