aboutsummaryrefslogtreecommitdiff
path: root/textproc/gmetadom
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-11 18:02:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-11 18:02:46 +0000
commitd7c82651f668e022a5677c2109b2a1465d412293 (patch)
treef930cd1c489d53b57c1e8e45753a343ce6f94584 /textproc/gmetadom
parentc4484191b4ea6b55ef1ac7ca763b55bc3e770d45 (diff)
downloadports-d7c82651f668e022a5677c2109b2a1465d412293.tar.gz
ports-d7c82651f668e022a5677c2109b2a1465d412293.zip
Notes
Diffstat (limited to 'textproc/gmetadom')
-rw-r--r--textproc/gmetadom/Makefile11
-rw-r--r--textproc/gmetadom/distinfo2
-rw-r--r--textproc/gmetadom/files/patch-GdomeSmartDOMDOMString.cc11
-rw-r--r--textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.cc11
-rw-r--r--textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.hh11
-rw-r--r--textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc11
-rw-r--r--textproc/gmetadom/files/patch-ltmain.sh15
-rw-r--r--textproc/gmetadom/pkg-plist34
8 files changed, 42 insertions, 64 deletions
diff --git a/textproc/gmetadom/Makefile b/textproc/gmetadom/Makefile
index 760dbef61492..4a05b656b45c 100644
--- a/textproc/gmetadom/Makefile
+++ b/textproc/gmetadom/Makefile
@@ -7,21 +7,20 @@
#
PORTNAME= gmetadom
-PORTVERSION= 0.0.3c
+PORTVERSION= 0.1.7
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-0.0.3
MAINTAINER= ports@FreeBSD.org
COMMENT= A Collection of DOM Implementations
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- xslt:${PORTSDIR}/textproc/libxslt \
- gdome:${PORTSDIR}/textproc/gdome2 \
- iconv:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.1:${PORTSDIR}/textproc/libxslt \
+ gdome.7:${PORTSDIR}/textproc/gdome2 \
+ iconv.3:${PORTSDIR}/converters/libiconv
USE_GNOME= glib12
USE_LIBTOOL= yes
diff --git a/textproc/gmetadom/distinfo b/textproc/gmetadom/distinfo
index a3c970582d20..ea4e4e907045 100644
--- a/textproc/gmetadom/distinfo
+++ b/textproc/gmetadom/distinfo
@@ -1 +1 @@
-MD5 (gmetadom-0.0.3.tar.gz) = ad692f245eda39e2dc4d909a5e246b57
+MD5 (gmetadom-0.1.7.tar.gz) = 52571bb9e0490c8b67369381c9cf7a1e
diff --git a/textproc/gmetadom/files/patch-GdomeSmartDOMDOMString.cc b/textproc/gmetadom/files/patch-GdomeSmartDOMDOMString.cc
deleted file mode 100644
index 90a8b6eedbcc..000000000000
--- a/textproc/gmetadom/files/patch-GdomeSmartDOMDOMString.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gdome_cpp_smart/basic/GdomeSmartDOMDOMString.cc.orig Wed Jul 10 13:37:44 2002
-+++ src/gdome_cpp_smart/basic/GdomeSmartDOMDOMString.cc Wed Jul 10 13:38:17 2002
-@@ -83,7 +83,7 @@
-
- while (inBytesLeft > 0) {
- //cout << "before: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
-- size_t iconv_res = iconv(cd, &inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
-+ size_t iconv_res = iconv(cd, (const char**)&inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
- //cout << "after: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
-
- unsigned n = outbuf - outbuf0;
diff --git a/textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.cc b/textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.cc
deleted file mode 100644
index 8ddf9dade77b..000000000000
--- a/textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gdome_cpp_smart/basic/GdomeSmartDOMDOMStringAux.cc.orig Wed Jul 10 13:54:33 2002
-+++ src/gdome_cpp_smart/basic/GdomeSmartDOMDOMStringAux.cc Wed Jul 10 13:55:19 2002
-@@ -47,7 +47,7 @@
- int save_width = o.width(4);
- o << ch;
- o.fill(save_fill);
-- o.setf(save_flags);
-+ o.setf((std::_Ios_Fmtflags)save_flags);
- o.width(save_width);
- }
- }
diff --git a/textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.hh b/textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.hh
deleted file mode 100644
index 29823cd1966d..000000000000
--- a/textproc/gmetadom/files/patch-GdomeSmartDOMDOMStringAux.hh
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gdome_cpp_smart/include/GdomeSmartDOMDOMStringAux.hh.orig Tue Oct 15 19:18:15 2002
-+++ src/gdome_cpp_smart/include/GdomeSmartDOMDOMStringAux.hh Tue Oct 15 19:32:13 2002
-@@ -35,7 +35,7 @@
-
- }
-
--namespace std {
-+namespace __gnu_cxx {
-
- struct hash<GdomeSmartDOM::DOMString> {
- size_t operator()(const GdomeSmartDOM::DOMString& key) const;
diff --git a/textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc b/textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc
new file mode 100644
index 000000000000..ea4e3b550e41
--- /dev/null
+++ b/textproc/gmetadom/files/patch-GdomeSmartDOMGdomeString.cc
@@ -0,0 +1,11 @@
+--- src/gdome_cpp_smart/basic/GdomeSmartDOMGdomeString.cc.orig Wed Apr 2 12:36:39 2003
++++ src/gdome_cpp_smart/basic/GdomeSmartDOMGdomeString.cc Wed Apr 2 12:37:21 2003
+@@ -95,7 +95,7 @@
+
+ while (inBytesLeft > 0) {
+ //cout << "before: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
+- size_t iconv_res = iconv(cd, &inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
++ size_t iconv_res = iconv(cd, (const char**)&inbuf, &inBytesLeft, &outbuf, &outBytesLeft);
+ //cout << "after: " << (void*) inbuf << " " << inBytesLeft << " " << (void*) outbuf << " " << outBytesLeft << endl;
+
+ unsigned n = outbuf - outbuf0;
diff --git a/textproc/gmetadom/files/patch-ltmain.sh b/textproc/gmetadom/files/patch-ltmain.sh
new file mode 100644
index 000000000000..e638fd52020d
--- /dev/null
+++ b/textproc/gmetadom/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Sun May 11 23:50:20 2003
++++ ltmain.sh Sun May 11 23:50:40 2003
+@@ -4247,10 +4247,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/textproc/gmetadom/pkg-plist b/textproc/gmetadom/pkg-plist
index 9a083853e974..4635e1606397 100644
--- a/textproc/gmetadom/pkg-plist
+++ b/textproc/gmetadom/pkg-plist
@@ -1,4 +1,3 @@
-bin/gmetadom-config
include/gmetadom/gdome_cpp_smart/GdomeSmartDOM.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMAttr.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMBasic.hh
@@ -10,7 +9,6 @@ include/gmetadom/gdome_cpp_smart/GdomeSmartDOMCore.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMException.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMImplementation.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMString.hh
-include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMStringAux.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDOMTimeStamp.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDocument.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMDocumentFragment.hh
@@ -22,7 +20,7 @@ include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEvent.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEventListener.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEventTarget.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMEvents.hh
-include/gmetadom/gdome_cpp_smart/GdomeSmartDOMGdomeStringAux.hh
+include/gmetadom/gdome_cpp_smart/GdomeSmartDOMGdomeString.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMHelper.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMMutationEvent.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMNamedNodeMap.hh
@@ -31,12 +29,15 @@ include/gmetadom/gdome_cpp_smart/GdomeSmartDOMNodeList.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMNotation.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMProcessingInstruction.hh
include/gmetadom/gdome_cpp_smart/GdomeSmartDOMText.hh
+include/gmetadom/gdome_cpp_smart/GdomeSmartDOMTraits.hh
+include/gmetadom/gdome_cpp_smart/GdomeSmartDOMUCS4String.hh
+include/gmetadom/gdome_cpp_smart/GdomeSmartDOMUTF16String.hh
+include/gmetadom/gdome_cpp_smart/GdomeSmartDOMUTF8String.hh
lib/libgmetadom_gdome_cpp_smart.a
lib/libgmetadom_gdome_cpp_smart.so
-lib/libgmetadom_gdome_cpp_smart.so.0
+lib/libgmetadom_gdome_cpp_smart.so.1
lib/ocaml/gdome2/META
lib/ocaml/gdome2/gdome.cmi
-lib/ocaml/gdome2/gdome.ml
lib/ocaml/gdome2/gdome.mli
lib/ocaml/gdome2/gdomeDOMExceptionT.cmi
lib/ocaml/gdome2/gdomeDOMExceptionT.mli
@@ -93,18 +94,6 @@ lib/ocaml/gdome2/iProcessingInstruction.cmi
lib/ocaml/gdome2/iProcessingInstruction.ml
lib/ocaml/gdome2/iText.cmi
lib/ocaml/gdome2/iText.ml
-lib/ocaml/gdome2/libmlgdome.a
-lib/ocaml/gdome2/libmlgdome.so
-lib/ocaml/gdome2/libmlgdome.so.0
-lib/ocaml/gdome2/mlbasic.a
-lib/ocaml/gdome2/mlbasic.cma
-lib/ocaml/gdome2/mlbasic.cmxa
-lib/ocaml/gdome2/mlcore.a
-lib/ocaml/gdome2/mlcore.cma
-lib/ocaml/gdome2/mlcore.cmxa
-lib/ocaml/gdome2/mlevents.a
-lib/ocaml/gdome2/mlevents.cma
-lib/ocaml/gdome2/mlevents.cmxa
lib/ocaml/gdome2/mlgdome.a
lib/ocaml/gdome2/mlgdome.cma
lib/ocaml/gdome2/mlgdome.cmxa
@@ -158,13 +147,10 @@ lib/ocaml/gdome2/tProcessingInstruction.cmi
lib/ocaml/gdome2/tProcessingInstruction.mli
lib/ocaml/gdome2/tText.cmi
lib/ocaml/gdome2/tText.mli
-lib/ocaml/site-lib/gdome2/META
-lib/ocaml/site-lib/gdome2/libmlgdome.so
-share/gmetadom/gdome_cpp_smart.conf
+lib/ocaml/stublibs/dllmlgdome.so.owner
+lib/ocaml/stublibs/dllmlgdome.so
+lib/ocaml/stublibs/libmlgdome.so
+lib/pkgconfig/gdome2-cpp-smart.pc
@dirrm include/gmetadom/gdome_cpp_smart
@dirrm include/gmetadom
@dirrm lib/ocaml/gdome2
-@dirrm lib/ocaml/site-lib/gdome2
-@dirrm share/gmetadom
-@exec echo "Updating %D/lib/ocaml/ld.conf"; echo "%D/lib/ocaml/site-lib/gdome2" >> %D/lib/ocaml/ld.conf
-@unexec echo "Updating %D/lib/ocaml/ld.conf"; cp %D/lib/ocaml/ld.conf %D/lib/ocaml/ld.conf.tmp; grep -v "lib/ocaml/site-lib/gdome2" %D/lib/ocaml/ld.conf.tmp > %D/lib/ocaml/ld.conf; rm %D/lib/ocaml/ld.conf.tmp