aboutsummaryrefslogtreecommitdiff
path: root/textproc/gnome-spell/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-12-29 21:39:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-12-29 21:39:05 +0000
commiteee834d63ac4a9f250aedcf9391ad3fe170b2110 (patch)
tree8693e7d611cf97adbac7360507d7eb70ba6edb85 /textproc/gnome-spell/Makefile
parent5511ca3862d886c61e191f183c1a40a13d26e086 (diff)
Notes
Diffstat (limited to 'textproc/gnome-spell/Makefile')
-rw-r--r--textproc/gnome-spell/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/textproc/gnome-spell/Makefile b/textproc/gnome-spell/Makefile
new file mode 100644
index 000000000000..d05493adbb3a
--- /dev/null
+++ b/textproc/gnome-spell/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gnomespell
+# Date created: 29 December 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomespell
+PORTVERSION= 0.4
+CATEGORIES= textproc gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gnome-spell
+DISTNAME= gnome-spell-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/share/xml-i18n-tools/xml-i18n-extract.in:${PORTSDIR}/textproc/xml-i18n-tools
+LIB_DEPENDS= aspell.11:${PORTSDIR}/textproc/aspell
+
+USE_X_PREFIX= yes
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-extract:
+.for file in xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in
+ @${LN} -sf ${LOCALBASE}/share/xml-i18n-tools/${file} ${WRKSRC}/${file}
+.endfor
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>