aboutsummaryrefslogtreecommitdiff
path: root/textproc/gnome-translate
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-01 18:07:57 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-01 18:07:57 +0000
commited7929c91e2a2a2fe0c9f5dac259af09c8545613 (patch)
tree7836beaec8ebcd3260906ebd1e54872d948bcdf9 /textproc/gnome-translate
parenteffdfbd005608183e24fe619a6ef9e44601c7f0e (diff)
downloadports-ed7929c91e2a2a2fe0c9f5dac259af09c8545613.tar.gz
ports-ed7929c91e2a2a2fe0c9f5dac259af09c8545613.zip
Notes
Diffstat (limited to 'textproc/gnome-translate')
-rw-r--r--textproc/gnome-translate/Makefile4
-rw-r--r--textproc/gnome-translate/files/patch-src_gt-app.c12
-rw-r--r--textproc/gnome-translate/files/patch-src_gt-util.c12
3 files changed, 26 insertions, 2 deletions
diff --git a/textproc/gnome-translate/Makefile b/textproc/gnome-translate/Makefile
index 2eeef3714d3e..925535f19e8c 100644
--- a/textproc/gnome-translate/Makefile
+++ b/textproc/gnome-translate/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnome-translate
PORTVERSION= 0.99
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= libtranslate
@@ -24,7 +24,7 @@ USE_GNOME= gnomehack gnomeprefix eel2 intlhack
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib -Wl,-export-dynamic"
OPTIONS= LANGUAGE_DETECTION "language detection" on
diff --git a/textproc/gnome-translate/files/patch-src_gt-app.c b/textproc/gnome-translate/files/patch-src_gt-app.c
new file mode 100644
index 000000000000..e58db910bec5
--- /dev/null
+++ b/textproc/gnome-translate/files/patch-src_gt-app.c
@@ -0,0 +1,12 @@
+--- src/gt-app.c.orig Fri Jan 28 13:31:53 2005
++++ src/gt-app.c Mon May 1 19:58:44 2006
+@@ -1168,8 +1168,7 @@
+ GTK_MESSAGE_WARNING,
+ GTK_BUTTONS_YES_NO,
+ _("Overwrite file?"),
+- secondary,
+- NULL);
++ secondary);
+ g_free(secondary);
+
+ gtk_dialog_set_default_response(GTK_DIALOG(confirmation_dialog), GTK_RESPONSE_NO); /* safe default */
diff --git a/textproc/gnome-translate/files/patch-src_gt-util.c b/textproc/gnome-translate/files/patch-src_gt-util.c
new file mode 100644
index 000000000000..018bc25af631
--- /dev/null
+++ b/textproc/gnome-translate/files/patch-src_gt-util.c
@@ -0,0 +1,12 @@
+--- src/gt-util.c.orig Mon May 1 20:00:48 2006
++++ src/gt-util.c Mon May 1 20:01:35 2006
+@@ -53,8 +53,7 @@
+ GTK_MESSAGE_ERROR,
+ GTK_BUTTONS_OK,
+ primary,
+- secondary,
+- NULL);
++ secondary);
+
+ if (blocking)
+ {