aboutsummaryrefslogtreecommitdiff
path: root/textproc/gnugrep
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2010-08-15 00:51:33 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2010-08-15 00:51:33 +0000
commit03a3c6ca54f343d3df13b7bd20025b3e0ea4cda0 (patch)
tree386641f3d307846c214e73ef14071c336d883cf7 /textproc/gnugrep
parentb7e72904e0e5a8baa5fca226a47c1091361cd5bb (diff)
downloadports-03a3c6ca54f343d3df13b7bd20025b3e0ea4cda0.tar.gz
ports-03a3c6ca54f343d3df13b7bd20025b3e0ea4cda0.zip
Notes
Diffstat (limited to 'textproc/gnugrep')
-rw-r--r--textproc/gnugrep/Makefile28
-rw-r--r--textproc/gnugrep/pkg-plist47
2 files changed, 65 insertions, 10 deletions
diff --git a/textproc/gnugrep/Makefile b/textproc/gnugrep/Makefile
index b83a38d36674..12730ea080c3 100644
--- a/textproc/gnugrep/Makefile
+++ b/textproc/gnugrep/Makefile
@@ -7,8 +7,8 @@
PORTNAME= grep
PORTVERSION= 2.6.3
-PORTREVISION= 2
-CATEGORIES= textproc
+PORTREVISION= 3
+CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= gnu
@@ -16,25 +16,29 @@ PKGNAMEPREFIX= gnu
MAINTAINER= gabor@FreeBSD.org
COMMENT= GNU grep
-USE_GETTEXT= yes
+CONFLICTS= bsd-grep-*
+
+USE_XZ= yes
GNU_CONFIGURE= yes
+
MAN1= egrep.1 \
fgrep.1 \
grep.1
INFO= grep
-PLIST_FILES= bin/egrep \
- bin/fgrep \
- bin/grep
OPTIONS= PCRE "Compile with Perl-compatible regex support" off
-CONFLICTS= bsd-grep-*
-
-USE_XZ= yes
-
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS+= -lintl -L${LOCALBASE}/lib
+PLIST_SUB+= NLS=
+.else
CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
.if defined(WITH_PCRE)
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
@@ -43,6 +47,10 @@ CONFIGURE_ARGS+= --disable-perl-regexp
.endif
post-patch:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} '/install-exec-local:/s/install-exec-localcharset//' \
+ ${WRKSRC}/lib/Makefile.in
+.endif
@${REINPLACE_CMD} 's|mkinstalldirs = .*|mkinstalldirs = mkdir -p|g' \
${WRKSRC}/po/Makefile.in.in
diff --git a/textproc/gnugrep/pkg-plist b/textproc/gnugrep/pkg-plist
new file mode 100644
index 000000000000..d0a711aab924
--- /dev/null
+++ b/textproc/gnugrep/pkg-plist
@@ -0,0 +1,47 @@
+bin/egrep
+bin/fgrep
+bin/grep
+%%NLS%%share/locale/af/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/be/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/da/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/de/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/el/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/es/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/et/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/he/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/id/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/it/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/ky/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/th/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/grep.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/grep.mo
+%%NLS%%@dirrmtry share/locale/ky/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ky