aboutsummaryrefslogtreecommitdiff
path: root/textproc/goldendict
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-11-13 14:07:49 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-11-13 14:07:49 +0000
commit8410624681fe2366ba2f723815ada593e471a24d (patch)
tree4f7ffc3d4b189e0fef4af6a8c948ad887fc21803 /textproc/goldendict
parentc3da7cc13a04902ae035afc93c7743fb5892691e (diff)
downloadports-8410624681fe2366ba2f723815ada593e471a24d.tar.gz
ports-8410624681fe2366ba2f723815ada593e471a24d.zip
Notes
Diffstat (limited to 'textproc/goldendict')
-rw-r--r--textproc/goldendict/Makefile48
-rw-r--r--textproc/goldendict/distinfo3
-rw-r--r--textproc/goldendict/files/patch-bgl_babylon.cc16
-rw-r--r--textproc/goldendict/files/patch-dictzip.c10
-rw-r--r--textproc/goldendict/files/patch-goldendict.pro44
-rw-r--r--textproc/goldendict/files/patch-iconv.cc14
-rw-r--r--textproc/goldendict/pkg-descr14
-rw-r--r--textproc/goldendict/pkg-plist6
8 files changed, 155 insertions, 0 deletions
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
new file mode 100644
index 000000000000..29a28f58349d
--- /dev/null
+++ b/textproc/goldendict/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: textproc/goldendict
+# Date created: 2009-11-09
+# Whom: bsam
+#
+# $FreeBSD$
+#
+
+PORTNAME= goldendict
+PORTVERSION= 0.9.0
+CATEGORIES= textproc
+MASTER_SITES= BERLIOS
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src-x11
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= A feature-rich dictionary lookup program (with QT lib)
+
+LIB_DEPENDS= hunspell-1.2.0:${PORTSDIR}/hungarian/hunspell \
+ vorbis:${PORTSDIR}/audio/libvorbis
+
+USE_BZIP2= yes
+HAS_CONFIGURE= yes
+USE_GNOME= pkgconfig
+USE_QT_VER= 4
+USE_QT4= linguist
+QT_COMPONENTS= corelib gui \
+ qmake_build linguist_build moc_build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
+
+post-patch:
+ @${SED} -I.bak -e "s:/usr:${PREFIX}:" ${WRKSRC}/redist/goldendict.desktop
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} INCLUDEPATH+=${LOCALBASE}/include \
+ LIBS+=-L${LOCALBASE}/lib ${PORTNAME}.pro
+
+post-install:
+ @${MKDIR} ${DATADIR}/locale
+ @${INSTALL_DATA} ${WRKSRC}/locale/ru.qm ${DATADIR}/locale/
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION}<800067
+IGNORE= wcscasecmp() id not implemented
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/goldendict/distinfo b/textproc/goldendict/distinfo
new file mode 100644
index 000000000000..79e83858049a
--- /dev/null
+++ b/textproc/goldendict/distinfo
@@ -0,0 +1,3 @@
+MD5 (goldendict-0.9.0-src-x11.tar.bz2) = 89303abcac6c86c4635b264414f02ccc
+SHA256 (goldendict-0.9.0-src-x11.tar.bz2) = 30bf5e4ac6abf56067ee8d8750c545726509bcea591825de88ba44071769c946
+SIZE (goldendict-0.9.0-src-x11.tar.bz2) = 450332
diff --git a/textproc/goldendict/files/patch-bgl_babylon.cc b/textproc/goldendict/files/patch-bgl_babylon.cc
new file mode 100644
index 000000000000..0e68a6b935f9
--- /dev/null
+++ b/textproc/goldendict/files/patch-bgl_babylon.cc
@@ -0,0 +1,16 @@
+--- bgl_babylon.cc.orig 2009-05-07 14:59:58.000000000 +0400
++++ bgl_babylon.cc 2009-11-08 23:52:53.000000000 +0300
+@@ -545,13 +545,8 @@
+
+ inbufbytes = s.size();
+ outbufbytes = s.size() * 6;
+-#ifdef _WIN32
+ const char *inbuf;
+ inbuf = s.data();
+-#else
+- char *inbuf;
+- inbuf = (char *)s.data();
+-#endif
+ outbuf = (char*)malloc( outbufbytes + 1 );
+ memset( outbuf, '\0', outbufbytes + 1 );
+ defbuf = outbuf;
diff --git a/textproc/goldendict/files/patch-dictzip.c b/textproc/goldendict/files/patch-dictzip.c
new file mode 100644
index 000000000000..ca9c8f762a50
--- /dev/null
+++ b/textproc/goldendict/files/patch-dictzip.c
@@ -0,0 +1,10 @@
+--- dictzip.c.orig 2009-11-09 01:12:06.000000000 +0300
++++ dictzip.c 2009-11-09 01:12:21.000000000 +0300
+@@ -23,6 +23,7 @@
+ */
+
+ #include <stdlib.h>
++#include <time.h>
+ #include "dictzip.h"
+ #include <limits.h>
+ #include <stdarg.h>
diff --git a/textproc/goldendict/files/patch-goldendict.pro b/textproc/goldendict/files/patch-goldendict.pro
new file mode 100644
index 000000000000..0a70ac9c6852
--- /dev/null
+++ b/textproc/goldendict/files/patch-goldendict.pro
@@ -0,0 +1,44 @@
+--- goldendict.pro.orig 2009-05-24 23:28:51.000000000 +0400
++++ goldendict.pro 2009-11-12 18:57:44.000000000 +0300
+@@ -35,24 +35,20 @@
+ LIBS += -lXtst
+ PREFIX = $$(PREFIX)
+ isEmpty( PREFIX ):PREFIX = /usr/local
+- DEFINES += PROGRAM_DATA_DIR=\\\"$$PREFIX/share/apps/goldendict/\\\"
++ isEmpty( DESKTOPDIR ):DESKTOPDIR = $$PREFIX/share/applications
++ isEmpty( ICONDIR ):ICONDIR = $$PREFIX/share/pixmaps
++ DEFINES += PROGRAM_DATA_DIR=\\\"$$PREFIX/share/goldendict/\\\"
+ target.path = $$PREFIX/bin/
+- locale.path = $$PREFIX/share/apps/goldendict/locale/
++ locale.path = $$PREFIX/share/goldendict
+ locale.files = locale/*.qm
+ INSTALLS += target \
+ locale
+- icons.path = /usr/share/pixmaps
+- icons.files = redist/icons/*.*
++ icons.path = $$ICONDIR
++ icons.files = redist/icons/goldendict.png
+ INSTALLS += icons
+- icons2.path = /usr/share/app-install/icons
+- icons2.files = redist/icons/*.*
+- INSTALLS += icons2
+- desktops.path = /usr/share/applications
+- desktops.files = redist/*.desktop
++ desktops.path = $$DESKTOPDIR
++ desktops.files = redist/goldendict.desktop
+ INSTALLS += desktops
+- desktops2.path = /usr/share/app-install/desktop
+- desktops2.files = redist/*.desktop
+- INSTALLS += desktops2
+ }
+ DEFINES += PROGRAM_VERSION=\\\"$$VERSION\\\"
+
+@@ -196,7 +192,7 @@
+ TRANSLATIONS += locale/ru.ts
+
+ # This makes qmake generate translations
+-isEmpty(QMAKE_LRELEASE):QMAKE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease
++isEmpty(QMAKE_LRELEASE):QMAKE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease-qt4
+ TS_OUT = $$TRANSLATIONS
+ TS_OUT ~= s/.ts/.qm
+ TSQM.name = lrelease \
diff --git a/textproc/goldendict/files/patch-iconv.cc b/textproc/goldendict/files/patch-iconv.cc
new file mode 100644
index 000000000000..e167ff53bfd2
--- /dev/null
+++ b/textproc/goldendict/files/patch-iconv.cc
@@ -0,0 +1,14 @@
+--- iconv.cc.orig 2009-04-18 21:20:12.000000000 +0400
++++ iconv.cc 2009-11-09 01:15:24.000000000 +0300
+@@ -44,11 +44,7 @@
+ throw( exIncorrectSeq, exOther )
+ {
+ size_t result = iconv( state,
+- #ifdef __WIN32
+ (char const **)&inBuf,
+- #else
+- (char **)&inBuf,
+- #endif
+ &inBytesLeft,
+ (char **)&outBuf, &outBytesLeft );
+
diff --git a/textproc/goldendict/pkg-descr b/textproc/goldendict/pkg-descr
new file mode 100644
index 000000000000..8e2793890262
--- /dev/null
+++ b/textproc/goldendict/pkg-descr
@@ -0,0 +1,14 @@
+The project aims to create a feature-rich dictionary lookup program.
+It supports:
+ * Babylon .BGL files, complete with images and resources;
+ * StarDict .ifo/.dict./.idx/.syn dictionaries;
+ * Dictd .index/.dict(.dz) dictionary files;
+ * ABBYY Lingvo .dsl source files, together with abbreviations.
+ The files can be optionally compressed with dictzip. Dictionary
+ resources can be packed together into a .zip file;
+ * ABBYY Lingvo .lsa/.dat audio archives. Those can be indexed
+ separately, or be referred to from .dsl files.
+
+LICENSE: GPL3 or later
+
+WWW: http://goldendict.berlios.de/
diff --git a/textproc/goldendict/pkg-plist b/textproc/goldendict/pkg-plist
new file mode 100644
index 000000000000..ce097209506a
--- /dev/null
+++ b/textproc/goldendict/pkg-plist
@@ -0,0 +1,6 @@
+bin/goldendict
+share/applications/goldendict.desktop
+share/pixmaps/goldendict.png
+%%DATADIR%%/locale/ru.qm
+@dirrm %%DATADIR%%/locale
+@dirrm %%DATADIR%%