aboutsummaryrefslogtreecommitdiff
path: root/textproc/goldendict
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-11-22 11:51:21 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-11-22 11:51:21 +0000
commita2e1da67bcd59e65c5f24b5f909b861901445334 (patch)
tree86b39d036e52c745e091e9ddc0c376c2cb7a2b0c /textproc/goldendict
parent4651fa015423eb6d974b5930e852c822193032ac (diff)
downloadports-a2e1da67bcd59e65c5f24b5f909b861901445334.tar.gz
ports-a2e1da67bcd59e65c5f24b5f909b861901445334.zip
Notes
Diffstat (limited to 'textproc/goldendict')
-rw-r--r--textproc/goldendict/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
index 87d3af0ef651..bb293c8014bd 100644
--- a/textproc/goldendict/Makefile
+++ b/textproc/goldendict/Makefile
@@ -20,15 +20,16 @@ LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
USE_BZIP2= yes
NO_WRKSUBDIR= yes
HAS_CONFIGURE= yes
-USES= desktop-file-utils pkgconfig
-USE_DOS2UNIX= processwrapper.cc # is needed only to apply a patch to this file
+USES= dos2unix pkgconfig
+DOS2UNIX_FILES= processwrapper.cc
USE_XORG= xtst
USE_QT4= corelib gui webkit phonon \
qmake_build linguist_build moc_build rcc_build script_build uic_build
+MAKE_ENV+= INSTALL_ROOT=${STAGEDIR}
+INSTALLS_ICONS= yes
-NO_STAGE= yes
post-patch:
- @${SED} -I.bak -e "s:/usr:${PREFIX}:" ${WRKSRC}/redist/goldendict.desktop
+ @${REINPLACE_CMD} 's:/usr:${PREFIX}:' ${WRKSRC}/redist/goldendict.desktop
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
@@ -36,7 +37,8 @@ do-configure:
LIBS+=-L${LOCALBASE}/lib ${PORTNAME}.pro
post-install:
- @${MKDIR} ${DATADIR}/locale
- ${INSTALL_DATA} ${WRKSRC}/locale/*.qm ${DATADIR}/locale/
+ @${MKDIR} ${STAGEDIR}${DATADIR}/locale
+ ${INSTALL_DATA} ${WRKSRC}/locale/*.qm ${STAGEDIR}${DATADIR}/locale
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>