aboutsummaryrefslogtreecommitdiff
path: root/textproc/grap/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-09-03 19:22:00 +0000
committerChris Rees <crees@FreeBSD.org>2012-09-03 19:22:00 +0000
commitfba658a01077ac8ebe94535da2f9de2c9ae0d122 (patch)
treebeb77a5754cfbdcd5d28be9af5fae6ae8ba38573 /textproc/grap/Makefile
parentf5dc6d9a73e7f56e9bb9275c659ad00044235e22 (diff)
Fix plist issues by choosing which files to install, rather than trying to
delete them afterwards. Submitted by: pointyhat (beat)
Notes
Notes: svn path=/head/; revision=303613
Diffstat (limited to 'textproc/grap/Makefile')
-rw-r--r--textproc/grap/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/textproc/grap/Makefile b/textproc/grap/Makefile
index d3dd0d8944fe..3845af041c8a 100644
--- a/textproc/grap/Makefile
+++ b/textproc/grap/Makefile
@@ -19,12 +19,24 @@ CONFIGURE_ARGS=--with-freebsd-ports
CONFLICTS_INSTALL=heirloom-doctools-[0-9]*
MAN1= grap.1
+PORTDOCS= README CHANGES COPYRIGHT grap.man
.include <bsd.port.options.mk>
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.doc \
+ ${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/grap.defines ${WRKSRC}/grap.tex.defines \
+ ${DATADIR}
.if ${PORT_OPTIONS:MDOCS}
-post-install:
- ${RM} -rf ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+. for d in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$d ${DOCSDIR}
+. endfor
.endif
+ ${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.include <bsd.port.mk>