aboutsummaryrefslogtreecommitdiff
path: root/textproc/groonga
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-12-16 21:26:26 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-12-16 21:26:26 +0000
commit54b3bd8de4ae3a5a9c49127f26ac0f19cf526f45 (patch)
tree496461c27b29d69967ec3bd527616a1c66106276 /textproc/groonga
parentb0136a581cd13bff1624d03b960974f2e1029117 (diff)
downloadports-54b3bd8de4ae3a5a9c49127f26ac0f19cf526f45.tar.gz
ports-54b3bd8de4ae3a5a9c49127f26ac0f19cf526f45.zip
Notes
Diffstat (limited to 'textproc/groonga')
-rw-r--r--textproc/groonga/Makefile5
-rw-r--r--textproc/groonga/distinfo6
-rw-r--r--textproc/groonga/pkg-plist7
3 files changed, 12 insertions, 6 deletions
diff --git a/textproc/groonga/Makefile b/textproc/groonga/Makefile
index 33a186f61b67..1d76a606edea 100644
--- a/textproc/groonga/Makefile
+++ b/textproc/groonga/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= groonga
-PORTVERSION= 8.0.4
+PORTVERSION= 8.0.9
CATEGORIES= textproc
MASTER_SITES= http://packages.groonga.org/source/groonga/
@@ -13,6 +13,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libpcre.so:devel/pcre
USES= gmake libedit libtool pathfix pkgconfig
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-benchmark \
--disable-document \
@@ -57,7 +58,7 @@ post-patch:
'/NGX_PID_PATH/s|mkdir|${TRUE}| ; \
/NGX_HTTP_LOG_PATH/s|mkdir|${TRUE}| ; \
/NGX_ERROR_LOG_PATH/s|mkdir|${TRUE}|' \
- ${WRKSRC}/vendor/nginx-1.15.0/auto/install
+ ${WRKSRC}/vendor/nginx-1.15.7/auto/install
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/groonga-httpd
diff --git a/textproc/groonga/distinfo b/textproc/groonga/distinfo
index 57bf21e5b949..31ed29f2c0e8 100644
--- a/textproc/groonga/distinfo
+++ b/textproc/groonga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1532371816
-SHA256 (groonga-8.0.4.tar.gz) = 6be08aed5042ec637fb5e22add616e1168f4f18c933cd268f4849677cb677465
-SIZE (groonga-8.0.4.tar.gz) = 15198474
+TIMESTAMP = 1544958565
+SHA256 (groonga-8.0.9.tar.gz) = 086036bc85cc3c49b1fd4518fc480edcb98ff5077d486923d8d2428661d5a5b9
+SIZE (groonga-8.0.9.tar.gz) = 15267670
diff --git a/textproc/groonga/pkg-plist b/textproc/groonga/pkg-plist
index 98f483f46158..c88c9c1adba7 100644
--- a/textproc/groonga/pkg-plist
+++ b/textproc/groonga/pkg-plist
@@ -55,6 +55,7 @@ include/groonga/groonga/output.h
include/groonga/groonga/pat.h
include/groonga/groonga/plugin.h
include/groonga/groonga/portability.h
+include/groonga/groonga/raw_string.h
include/groonga/groonga/request_canceler.h
include/groonga/groonga/request_timer.h
include/groonga/groonga/scorer.h
@@ -63,16 +64,18 @@ include/groonga/groonga/table.h
include/groonga/groonga/thread.h
include/groonga/groonga/time.h
include/groonga/groonga/token.h
+include/groonga/groonga/token_cursor.h
include/groonga/groonga/token_filter.h
+include/groonga/groonga/token_metadata.h
include/groonga/groonga/tokenizer.h
include/groonga/groonga/tokenizer_query_deprecated.h
include/groonga/groonga/type.h
include/groonga/groonga/util.h
include/groonga/groonga/vector.h
+include/groonga/groonga/version.h
include/groonga/groonga/windows.h
include/groonga/groonga/windows_event_logger.h
include/groonga/groonga/window_function.h
-%%RUBY%%lib/groonga/plugins/expression_rewriters/optimizer.rb
lib/groonga/plugins/functions/index_column.a
lib/groonga/plugins/functions/index_column.so
lib/groonga/plugins/functions/math.a
@@ -114,6 +117,7 @@ lib/groonga/plugins/sharding/keys_parsable.rb
%%RUBY%%lib/groonga/scripts/ruby/eval_context.rb
%%RUBY%%lib/groonga/scripts/ruby/expression.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_rewriter.rb
+%%RUBY%%lib/groonga/scripts/ruby/expression_rewriters/optimizer.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_rewriters.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_size_estimator.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_tree.rb
@@ -125,6 +129,7 @@ lib/groonga/plugins/sharding/keys_parsable.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_tree/logical_operation.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_tree/options.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_tree/procedure.rb
+%%RUBY%%lib/groonga/scripts/ruby/expression_tree/unary_operation.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_tree/variable.rb
%%RUBY%%lib/groonga/scripts/ruby/expression_tree_builder.rb
%%RUBY%%lib/groonga/scripts/ruby/fixed_size_column.rb