aboutsummaryrefslogtreecommitdiff
path: root/textproc/gsed/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-04-20 05:51:54 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-04-20 05:51:54 +0000
commitca18a15452342f4ff104f37b3cf0c952583a4087 (patch)
treeafd28440d373e070637bb21677b952f264c81d92 /textproc/gsed/Makefile
parent7661f5c4e89774773bacab373e6dd7f9e635cc96 (diff)
downloadports-ca18a15452342f4ff104f37b3cf0c952583a4087.tar.gz
ports-ca18a15452342f4ff104f37b3cf0c952583a4087.zip
Notes
Diffstat (limited to 'textproc/gsed/Makefile')
-rw-r--r--textproc/gsed/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index 26646c5b50d2..73ee3b34bdf5 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -32,6 +32,14 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PKGBASE}
PORTDOCS= AUTHORS BUGS COPYING COPYING.DOC NEWS README THANKS
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
+.include <bsd.port.pre.mk>
+
+# Required for gcc 2.95 since it is pre-C99
+# and doesn't handle the 'bool' datatype properly.
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-lib-regexec.c
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,^\* sed:,* CNU sed:,' \
${WRKSRC}/doc/config.texi
@@ -59,4 +67,4 @@ post-install:
test:
@cd ${WRKSRC}/testsuite; ${MAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>