aboutsummaryrefslogtreecommitdiff
path: root/textproc/gsed/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-27 18:50:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-27 18:50:06 +0000
commit582abfaf935c21070c43bf5a7c34d0d6ff4f08d9 (patch)
tree2767bee03cc8064e82f31488c382f62c9d06f7f0 /textproc/gsed/Makefile
parentd425b925c3ff5b37726fc10fa46e143132fd8d7b (diff)
downloadports-582abfaf935c21070c43bf5a7c34d0d6ff4f08d9.tar.gz
ports-582abfaf935c21070c43bf5a7c34d0d6ff4f08d9.zip
Notes
Diffstat (limited to 'textproc/gsed/Makefile')
-rw-r--r--textproc/gsed/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index 7a986b326cac..a39078a6797b 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= sed
-PORTVERSION= 4.0.7
-PKGNAMEPREFIX= g
+PORTVERSION= 4.0.9
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= g
MAINTAINER= cyrille.lefevre@laposte.net
COMMENT= The GNU stream editor
@@ -25,15 +25,17 @@ CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --disable-nls
USE_GMAKE= yes
+INFO= sed
MAN1= gsed.1
# Local variables
#
PATCH_SUBDIRS= . doc lib sed
+DATADIR= ${PREFIX}/share/${PKGBASE}
-SAMP_FILES= dc.sed
-SAMP_DIR= ${PREFIX}/share/examples/${PKGBASE}
+SAMP_FILES= binary*.sed dc.sed
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGBASE}
DOC_FILES= AUTHORS BUGS COPYING COPYING.DOC NEWS README THANKS
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
@@ -54,9 +56,9 @@ patch-makefiles:
post-install: install-sample-files install-doc-files
install-sample-files:
- @${MKDIR} ${SAMP_DIR}
+ @${MKDIR} ${EXAMPLESDIR}
.for file in ${SAMP_FILES}
- @${INSTALL_DATA} ${WRKSRC}/testsuite/${file} ${SAMP_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/testsuite/${file} ${EXAMPLESDIR}
.endfor
install-doc-files: