aboutsummaryrefslogtreecommitdiff
path: root/textproc/gutenmark
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-07 15:35:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-07 15:35:06 +0000
commitbecc9b31a46a5ebdc19ec1f6a0797d99115385b2 (patch)
treeddca0bdb9b8da9242d03658d3bb14929c62c1f15 /textproc/gutenmark
parentf43d415226b1503a7e06417e6985832a9dd734d3 (diff)
downloadports-becc9b31a46a5ebdc19ec1f6a0797d99115385b2.tar.gz
ports-becc9b31a46a5ebdc19ec1f6a0797d99115385b2.zip
Notes
Diffstat (limited to 'textproc/gutenmark')
-rw-r--r--textproc/gutenmark/Makefile26
-rw-r--r--textproc/gutenmark/distinfo1
-rw-r--r--textproc/gutenmark/pkg-comment1
-rw-r--r--textproc/gutenmark/pkg-descr8
-rw-r--r--textproc/gutenmark/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/textproc/gutenmark/Makefile b/textproc/gutenmark/Makefile
new file mode 100644
index 000000000000..6b6a82db8c5a
--- /dev/null
+++ b/textproc/gutenmark/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: GutenMark
+# Date created: Jun 7, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+
+PORTNAME= gutenmark
+PORTVERSION= 20011228
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.sandroid.org/GutenMark/SoftwareSnapshots/
+DISTNAME= GutenMark_source_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/GutenMark-source
+USE_GMAKE= yes
+ALL_TARGET= # empty
+
+post-patch:
+ @${PERL} -pi -e "s,cc,${CC},g ; s,-O3 -Wall,${CFLAGS},g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/GutenMark ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/gutenmark/distinfo b/textproc/gutenmark/distinfo
new file mode 100644
index 000000000000..2548d94fa53b
--- /dev/null
+++ b/textproc/gutenmark/distinfo
@@ -0,0 +1 @@
+MD5 (GutenMark_source_20011228.tar.gz) = 5ebce8295d54ad845778f4a9c2773723
diff --git a/textproc/gutenmark/pkg-comment b/textproc/gutenmark/pkg-comment
new file mode 100644
index 000000000000..1127f7f1cb5a
--- /dev/null
+++ b/textproc/gutenmark/pkg-comment
@@ -0,0 +1 @@
+Attractively formatting Project Gutenberg texts
diff --git a/textproc/gutenmark/pkg-descr b/textproc/gutenmark/pkg-descr
new file mode 100644
index 000000000000..90b611f259f8
--- /dev/null
+++ b/textproc/gutenmark/pkg-descr
@@ -0,0 +1,8 @@
+GutenMark is a tool for automatically creating high-quality HTML (or LaTeX)
+markup from Project Gutenberg etexts. In combination with other freely-
+available conversion tools, GutenMark can convert Project Gutenberg etexts
+into publication-quality Postscript or PDF, for print-on-demand applications.
+
+This conversion is completely automatic, without manual markup or editing.
+
+WWW: http://www.sandroid.org/GutenMark/
diff --git a/textproc/gutenmark/pkg-plist b/textproc/gutenmark/pkg-plist
new file mode 100644
index 000000000000..6a07ad4cee60
--- /dev/null
+++ b/textproc/gutenmark/pkg-plist
@@ -0,0 +1 @@
+bin/GutenMark