aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-HaXml
diff options
context:
space:
mode:
authorMaxime Henrion <mux@FreeBSD.org>2006-06-01 19:26:51 +0000
committerMaxime Henrion <mux@FreeBSD.org>2006-06-01 19:26:51 +0000
commit5979290699dca9667dc19fda66d1204c8b9b91ef (patch)
tree47e80accf7d1718ba7b800d78821b83a864a9174 /textproc/hs-HaXml
parent3ab26333c59bfb5f7b95dc4244ea50c4027f596a (diff)
downloadports-5979290699dca9667dc19fda66d1204c8b9b91ef.tar.gz
ports-5979290699dca9667dc19fda66d1204c8b9b91ef.zip
Notes
Diffstat (limited to 'textproc/hs-HaXml')
-rw-r--r--textproc/hs-HaXml/Makefile2
-rw-r--r--textproc/hs-HaXml/files/patch-1.13-percent21
2 files changed, 22 insertions, 1 deletions
diff --git a/textproc/hs-HaXml/Makefile b/textproc/hs-HaXml/Makefile
index 7baddab76c44..9c0377c1ac8f 100644
--- a/textproc/hs-HaXml/Makefile
+++ b/textproc/hs-HaXml/Makefile
@@ -6,7 +6,7 @@
PORTNAME= haxml
PORTVERSION= 1.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc haskell
MASTER_SITES= http://www.haskell.org/HaXml/ \
ftp://ftp.cs.york.ac.uk/pub/haskell/HaXml/
diff --git a/textproc/hs-HaXml/files/patch-1.13-percent b/textproc/hs-HaXml/files/patch-1.13-percent
new file mode 100644
index 000000000000..75858eaa11e9
--- /dev/null
+++ b/textproc/hs-HaXml/files/patch-1.13-percent
@@ -0,0 +1,21 @@
+--- src/Text/XML/HaXml/Lex.hs.orig 2005-04-19 13:22:15.000000000 +0100
++++ src/Text/XML/HaXml/Lex.hs 2006-02-21 15:46:57.000000000 +0000
+@@ -194,12 +194,12 @@
+ | close `prefixes` (s:ss) = emit (TokFreeText (reverse acc)) pos:
+ emit tok p:
+ skip (length close-1) (addcol 1 p) ss k
+- | s=='&'||s=='%' = (if not (null acc)
+- then (emit (TokFreeText (reverse acc)) pos:)
+- else id)
+- (emit (if s=='&' then TokAmp else TokPercent) p:
+- textUntil ";" TokSemi "" p (addcol 1 p) ss
+- (\p' i-> textOrRefUntil close tok "" p p' i k))
++ | s=='&' = (if not (null acc)
++ then (emit (TokFreeText (reverse acc)) pos:)
++ else id)
++ (emit TokAmp p:
++ textUntil ";" TokSemi "" p (addcol 1 p) ss
++ (\p' i-> textOrRefUntil close tok "" p p' i k))
+ | isSpace s = textOrRefUntil close tok (s:acc) pos (white s p) ss k
+ | otherwise = textOrRefUntil close tok (s:acc) pos (addcol 1 p) ss k
+