aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-bytestring-csv/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:44:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:44:00 +0000
commit7fd3acb105b2b975e66885ca5beeab93c9669b2a (patch)
tree011774294cc6e178f63e4f1cd0cfb9d1b9809688 /textproc/hs-bytestring-csv/Makefile
parent0859e46a4397bc30a7a83882a72cfb092eced4a7 (diff)
downloadports-7fd3acb105b2b975e66885ca5beeab93c9669b2a.tar.gz
ports-7fd3acb105b2b975e66885ca5beeab93c9669b2a.zip
Notes
Diffstat (limited to 'textproc/hs-bytestring-csv/Makefile')
-rw-r--r--textproc/hs-bytestring-csv/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/hs-bytestring-csv/Makefile b/textproc/hs-bytestring-csv/Makefile
new file mode 100644
index 000000000000..64d21868c846
--- /dev/null
+++ b/textproc/hs-bytestring-csv/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: bytestring-csv
+# Date created: November 25, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= bytestring-csv
+PORTVERSION= 0.1.2
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Parse CSV formatted data efficiently with Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-dlist>=0.4.1:${PORTSDIR}/devel/hs-dlist
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>