aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-case-insensitive
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-07-10 21:26:42 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-07-10 21:26:42 +0000
commita4a5fe9869b370c0cd58f351df67cde9477cb12a (patch)
tree9c498f46883c34b507dd9247dd78557dcdca69de /textproc/hs-case-insensitive
parenta0650dc5ff2e760aef875a837b04b46c4dcb6b7e (diff)
downloadports-a4a5fe9869b370c0cd58f351df67cde9477cb12a.tar.gz
ports-a4a5fe9869b370c0cd58f351df67cde9477cb12a.zip
Notes
Diffstat (limited to 'textproc/hs-case-insensitive')
-rw-r--r--textproc/hs-case-insensitive/Makefile21
-rw-r--r--textproc/hs-case-insensitive/distinfo2
-rw-r--r--textproc/hs-case-insensitive/pkg-descr6
3 files changed, 29 insertions, 0 deletions
diff --git a/textproc/hs-case-insensitive/Makefile b/textproc/hs-case-insensitive/Makefile
new file mode 100644
index 000000000000..b6733a7ad1ab
--- /dev/null
+++ b/textproc/hs-case-insensitive/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-case-insensitive
+# Date created: May 24, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= case-insensitive
+PORTVERSION= 0.2.0.1
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Case insensitive string comparison
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= text>=0.3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-case-insensitive/distinfo b/textproc/hs-case-insensitive/distinfo
new file mode 100644
index 000000000000..f2bb542bf12f
--- /dev/null
+++ b/textproc/hs-case-insensitive/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/case-insensitive-0.2.0.1.tar.gz) = d9ec23a2b793e95558c6aa079933c0395b08976f1059a4078ffb28b3ce9e61e5
+SIZE (cabal/case-insensitive-0.2.0.1.tar.gz) = 2982
diff --git a/textproc/hs-case-insensitive/pkg-descr b/textproc/hs-case-insensitive/pkg-descr
new file mode 100644
index 000000000000..2c357a8e0fd5
--- /dev/null
+++ b/textproc/hs-case-insensitive/pkg-descr
@@ -0,0 +1,6 @@
+The module Data.CaseInsensitive provides the 'CI' type constructor which can
+be parameterised by a string-like type like: 'String', 'ByteString', 'Text',
+etc. Comparisons of values of the resulting type will be insensitive to
+cases.
+
+WWW: http://hackage.haskell.org/package/case-insensitive