aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-feed/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-01-12 22:17:55 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-01-12 22:17:55 +0000
commitbf227d90756e8fd07f52ed2d68b314f73c6aa60d (patch)
tree3a3f18846901cf32876161425ab502ade14ad066 /textproc/hs-feed/Makefile
parent710cd8e50beeb7a0eaaf3045af4ec3e17243af7c (diff)
downloadports-bf227d90756e8fd07f52ed2d68b314f73c6aa60d.tar.gz
ports-bf227d90756e8fd07f52ed2d68b314f73c6aa60d.zip
Notes
Diffstat (limited to 'textproc/hs-feed/Makefile')
-rw-r--r--textproc/hs-feed/Makefile79
1 files changed, 79 insertions, 0 deletions
diff --git a/textproc/hs-feed/Makefile b/textproc/hs-feed/Makefile
new file mode 100644
index 000000000000..faacd1946fbc
--- /dev/null
+++ b/textproc/hs-feed/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: hs-feed
+# Date created: January 10 2010
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= feed
+PORTVERSION= 0.3.7
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Interfacing with RSS (v 0.9x, 2.x, 1.0) + Atom feeds in Haskell
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-utf8-string-ghc>=0.3.6:${PORTSDIR}/devel/hs-utf8-string-ghc \
+ hs-xml>=1.2.6:${PORTSDIR}/textproc/hs-xml
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-utf8-string-ghc>=0.3.6:${PORTSDIR}/devel/hs-utf8-string-ghc \
+ hs-xml>=1.2.6:${PORTSDIR}/textproc/hs-xml
+
+GHC_VERSION= 6.10.4
+FEED_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+FEED_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ FEED_VERSION=${FEED_VERSION} \
+ FEED_LIBDIR_REL=${FEED_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${FEED_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>