aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-highlighting-kate-ghc/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2008-12-21 12:02:56 +0000
committerGabor Pali <pgj@FreeBSD.org>2008-12-21 12:02:56 +0000
commit7f81ee1e51bbff21768e6999ec79029f53e1ef2f (patch)
treef3876e073c6cc3597e95246f567bb84d2055bc05 /textproc/hs-highlighting-kate-ghc/Makefile
parent247cc9d9d156acbe366fc4822c18dd3944440eb4 (diff)
downloadports-7f81ee1e51bbff21768e6999ec79029f53e1ef2f.tar.gz
ports-7f81ee1e51bbff21768e6999ec79029f53e1ef2f.zip
Notes
Diffstat (limited to 'textproc/hs-highlighting-kate-ghc/Makefile')
-rw-r--r--textproc/hs-highlighting-kate-ghc/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/textproc/hs-highlighting-kate-ghc/Makefile b/textproc/hs-highlighting-kate-ghc/Makefile
new file mode 100644
index 000000000000..cda20a69a1b7
--- /dev/null
+++ b/textproc/hs-highlighting-kate-ghc/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: highlighting-kate
+# Date created: December 16, 2008
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= highlighting-kate
+PORTVERSION= 0.2.3
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+PKGNAMESUFFIX= -ghc
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A Haskell syntax highlighting library for 50+ languages
+
+BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc \
+ hs-pcre-light-ghc>=0.3:${PORTSDIR}/devel/hs-pcre-light-ghc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GHC_VERSION= 6.8.3
+CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
+CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${CABALDIR}
+DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+
+.ifndef (NOPORTDOCS)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+.ifndef (NOPORTDOCS)
+ cd ${WRKSRC} && ${CABALCMD} haddock
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${CABALCMD} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+
+.include <bsd.port.mk>