aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-lhs2tex
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-05-25 21:44:12 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-05-25 21:44:12 +0000
commitfff1aa535b4a18a05d872de7c9afb3dbf9f6013b (patch)
tree86e71c0056b8414191c8b421101694a177fec03e /textproc/hs-lhs2tex
parentb782168218ce43588149523e6d12003aa68ad324 (diff)
downloadports-fff1aa535b4a18a05d872de7c9afb3dbf9f6013b.tar.gz
ports-fff1aa535b4a18a05d872de7c9afb3dbf9f6013b.zip
Notes
Diffstat (limited to 'textproc/hs-lhs2tex')
-rw-r--r--textproc/hs-lhs2tex/Makefile3
-rw-r--r--textproc/hs-lhs2tex/distinfo6
-rw-r--r--textproc/hs-lhs2tex/files/patch-Setup.hs8
-rw-r--r--textproc/hs-lhs2tex/files/patch-src_Document.lhs10
-rw-r--r--textproc/hs-lhs2tex/files/patch-src_Main.lhs11
-rw-r--r--textproc/hs-lhs2tex/files/patch-src_Math.lhs11
-rw-r--r--textproc/hs-lhs2tex/files/patch-src_MathPoly.lhs11
-rw-r--r--textproc/hs-lhs2tex/files/patch-src_NewCode.lhs10
-rw-r--r--textproc/hs-lhs2tex/files/patch-src_Typewriter.lhs10
-rw-r--r--textproc/hs-lhs2tex/files/patch-src_Verbatim.lhs10
10 files changed, 81 insertions, 9 deletions
diff --git a/textproc/hs-lhs2tex/Makefile b/textproc/hs-lhs2tex/Makefile
index 7534d3fbfddb..e914e554a3ee 100644
--- a/textproc/hs-lhs2tex/Makefile
+++ b/textproc/hs-lhs2tex/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= lhs2tex
-PORTVERSION= 1.19
-PORTREVISION= 2
+PORTVERSION= 1.20
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/textproc/hs-lhs2tex/distinfo b/textproc/hs-lhs2tex/distinfo
index a9984180aefe..5a6272025550 100644
--- a/textproc/hs-lhs2tex/distinfo
+++ b/textproc/hs-lhs2tex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499624833
-SHA256 (cabal/lhs2tex-1.19.tar.gz) = 24ae0557d95673e0c6d9b0aca829181b734359880dd58802ac154b89f384b00e
-SIZE (cabal/lhs2tex-1.19.tar.gz) = 658353
+TIMESTAMP = 1524639224
+SHA256 (cabal/lhs2tex-1.20.tar.gz) = ae851e7f7d25ff822e1fec2f48aec7802d62e06458096de28069201562dfb03a
+SIZE (cabal/lhs2tex-1.20.tar.gz) = 674326
diff --git a/textproc/hs-lhs2tex/files/patch-Setup.hs b/textproc/hs-lhs2tex/files/patch-Setup.hs
index df80ba1420b5..09f425ff12ff 100644
--- a/textproc/hs-lhs2tex/files/patch-Setup.hs
+++ b/textproc/hs-lhs2tex/files/patch-Setup.hs
@@ -1,6 +1,6 @@
---- Setup.hs.orig 2012-09-08 22:29:52.000000000 +0100
-+++ Setup.hs 2013-12-08 15:55:17.403235103 +0000
-@@ -205,7 +205,7 @@
+--- Setup.hs.orig 2017-09-29 08:44:16 UTC
++++ Setup.hs
+@@ -210,7 +210,7 @@ lhs2texPostCopy a (CopyFlags { copyDest = cdf, copyVer
else docdir (absoluteInstallDirs pd lbi cd) `joinFileName` "doc"
let manDir = if isWindows
then dataPref `joinFileName` "Documentation"
@@ -9,7 +9,7 @@
createDirectoryIfMissing True docDir
installOrdinaryFile v (lhs2texDocDir `joinFileName` "Guide2.pdf") (docDir `joinFileName` "Guide2.pdf")
when (not isWindows) $
-@@ -213,7 +213,8 @@
+@@ -218,7 +218,8 @@ lhs2texPostCopy a (CopyFlags { copyDest = cdf, copyVer
installOrdinaryFile v ("lhs2TeX.1") (manDir `joinFileName` "lhs2TeX.1")
-- polytable
case (installPolyTable ebi) of
diff --git a/textproc/hs-lhs2tex/files/patch-src_Document.lhs b/textproc/hs-lhs2tex/files/patch-src_Document.lhs
new file mode 100644
index 000000000000..fdbeead0aa32
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-src_Document.lhs
@@ -0,0 +1,10 @@
+--- src/Document.lhs.orig 2018-04-25 07:05:53 UTC
++++ src/Document.lhs
+@@ -9,6 +9,7 @@
+
+ %endif
+
++> import Prelude hiding ((<>))
+ > infixr 5 {-"\enskip"-} <> -- same fixity as `|++|'
+
+ The pretty printer generate documents of type |Doc|.
diff --git a/textproc/hs-lhs2tex/files/patch-src_Main.lhs b/textproc/hs-lhs2tex/files/patch-src_Main.lhs
new file mode 100644
index 000000000000..dcc2df875b0f
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-src_Main.lhs
@@ -0,0 +1,11 @@
+--- src/Main.lhs.orig 2018-04-25 07:41:09 UTC
++++ src/Main.lhs
+@@ -21,7 +21,7 @@
+ > import Control.Monad.Error
+ > import Control.Monad.State ( MonadState(..), modify )
+ > import Control.Monad.Trans
+-> import Prelude hiding ( getContents )
++> import Prelude hiding ( getContents, (<>) )
+ >
+ > import Version
+ > import TeXCommands
diff --git a/textproc/hs-lhs2tex/files/patch-src_Math.lhs b/textproc/hs-lhs2tex/files/patch-src_Math.lhs
new file mode 100644
index 000000000000..942016c7ab32
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-src_Math.lhs
@@ -0,0 +1,11 @@
+--- src/Math.lhs.orig 2018-04-25 07:40:44 UTC
++++ src/Math.lhs
+@@ -7,7 +7,7 @@
+ > module Math ( module Math, substitute, number )
+ > where
+ >
+-> import Prelude hiding ( lines )
++> import Prelude hiding ( lines, (<>) )
+ > import Data.List ( partition )
+ > import Numeric ( showFFloat )
+ > import Control.Applicative ( many )
diff --git a/textproc/hs-lhs2tex/files/patch-src_MathPoly.lhs b/textproc/hs-lhs2tex/files/patch-src_MathPoly.lhs
new file mode 100644
index 000000000000..21728d3ffa0e
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-src_MathPoly.lhs
@@ -0,0 +1,11 @@
+--- src/MathPoly.lhs.orig 2018-04-25 07:08:26 UTC
++++ src/MathPoly.lhs
+@@ -13,7 +13,7 @@ are subtle differences, and they will grow over time \
+ > module MathPoly ( module MathPoly, substitute, number )
+ > where
+ >
+-> import Prelude hiding ( lines )
++> import Prelude hiding ( lines, (<>) )
+ > import Data.List ( partition, nub, insert, sort, transpose )
+ > import Numeric ( showFFloat )
+ > import Control.Applicative ( many )
diff --git a/textproc/hs-lhs2tex/files/patch-src_NewCode.lhs b/textproc/hs-lhs2tex/files/patch-src_NewCode.lhs
new file mode 100644
index 000000000000..f9f22a8c93a4
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-src_NewCode.lhs
@@ -0,0 +1,10 @@
+--- src/NewCode.lhs.orig 2018-04-25 07:08:55 UTC
++++ src/NewCode.lhs
+@@ -13,6 +13,7 @@ way that is compatible with the @poly@ or @math@ forma
+ > module NewCode ( module NewCode )
+ > where
+ >
++> import Prelude hiding ((<>))
+ > import Control.Monad ( (>=>) )
+ > import Data.List ( partition )
+ >
diff --git a/textproc/hs-lhs2tex/files/patch-src_Typewriter.lhs b/textproc/hs-lhs2tex/files/patch-src_Typewriter.lhs
new file mode 100644
index 000000000000..3b8ca4785939
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-src_Typewriter.lhs
@@ -0,0 +1,10 @@
+--- src/Typewriter.lhs.orig 2018-04-25 07:07:53 UTC
++++ src/Typewriter.lhs
+@@ -7,6 +7,7 @@
+ > module Typewriter ( module Typewriter )
+ > where
+ >
++> import Prelude hiding ((<>))
+ > import Control.Monad
+ >
+ > import Verbatim ( trim, expand )
diff --git a/textproc/hs-lhs2tex/files/patch-src_Verbatim.lhs b/textproc/hs-lhs2tex/files/patch-src_Verbatim.lhs
new file mode 100644
index 000000000000..c7130dd0541c
--- /dev/null
+++ b/textproc/hs-lhs2tex/files/patch-src_Verbatim.lhs
@@ -0,0 +1,10 @@
+--- src/Verbatim.lhs.orig 2018-04-25 07:07:15 UTC
++++ src/Verbatim.lhs
+@@ -7,6 +7,7 @@
+ > module Verbatim ( module Verbatim )
+ > where
+ >
++> import Prelude hiding ((<>))
+ > import Control.Arrow ( (>>>) )
+ > import Data.Char
+ > import Data.List ( intersperse )