aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-pandoc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
commit25bf018f0fa446ca38508d35b6b3474e88d758d3 (patch)
tree45b457da59382af32e809be042d2a1a7cad9e952 /textproc/hs-pandoc
parent1c8feb1a3fd41782660f5439357efe8a9519c625 (diff)
downloadports-25bf018f0fa446ca38508d35b6b3474e88d758d3.tar.gz
ports-25bf018f0fa446ca38508d35b6b3474e88d758d3.zip
Notes
Diffstat (limited to 'textproc/hs-pandoc')
-rw-r--r--textproc/hs-pandoc/Makefile23
-rw-r--r--textproc/hs-pandoc/distinfo5
-rw-r--r--textproc/hs-pandoc/files/patch-pandoc.cabal83
-rw-r--r--textproc/hs-pandoc/files/patch-src_Text_Pandoc_Writers_Custom.hs14
4 files changed, 111 insertions, 14 deletions
diff --git a/textproc/hs-pandoc/Makefile b/textproc/hs-pandoc/Makefile
index b9ba79d552d2..c70f46edcd98 100644
--- a/textproc/hs-pandoc/Makefile
+++ b/textproc/hs-pandoc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pandoc
-PORTVERSION= 1.15.0.6
-PORTREVISION= 1
+PORTVERSION= 1.19.2.1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,16 +10,16 @@ COMMENT= Conversion between markup formats
LICENSE= GPLv2
-USE_CABAL= aeson>=0.7.0.5 base64-bytestring>=0.1 blaze-html>=0.5 \
- blaze-markup>=0.5.1 cmark>=0.4.0.1 data-default>=0.4 \
- deepseq-generics>=0.1 extensible-exceptions>=0.1 \
- filemanip>=0.3 haddock-library>=1.1 highlighting-kate>=0.6 \
- hslua>=0.3 HTTP>=4000.0.5 JuicyPixels>=3.1.6.1 mtl>=1.1 \
- network>=2.6 network-uri>=2.6 pandoc-types>=1.12.4 parsec>=3.1 \
- random>=1 scientific>=0.2 SHA>=1.6 syb>=0.1 tagsoup>=0.13.1 \
- temporary>=1.1 texmath>=0.8.1 text>=0.11 \
- unordered-containers>=0.2 vector>=0.10 xml>=1.3.12 \
- yaml>=0.8.8.2 zip-archive>=0.2.3.4 zlib>=0.5
+USE_CABAL= aeson base64-bytestring blaze-html \
+ blaze-markup cmark data-default \
+ deepseq-generics doctemplates extensible-exceptions \
+ filemanip haddock-library highlighting-kate \
+ hslua HTTP JuicyPixels mtl \
+ network network-uri pandoc-types parsec \
+ random scientific SHA skylighting syb tagsoup\
+ temporary texmath text \
+ unordered-containers vector xml \
+ yaml zip-archive zlib
USE_ALEX= yes
USE_HAPPY= yes
diff --git a/textproc/hs-pandoc/distinfo b/textproc/hs-pandoc/distinfo
index d7c721bc1184..5f38ab8379a5 100644
--- a/textproc/hs-pandoc/distinfo
+++ b/textproc/hs-pandoc/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/pandoc-1.15.0.6.tar.gz) = d950968142526d5a765af7dfb26b47c3f60d4f883aa9d9eab668614179f1ed46
-SIZE (cabal/pandoc-1.15.0.6.tar.gz) = 2049870
+TIMESTAMP = 1499624835
+SHA256 (cabal/pandoc-1.19.2.1.tar.gz) = 08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801
+SIZE (cabal/pandoc-1.19.2.1.tar.gz) = 2755101
diff --git a/textproc/hs-pandoc/files/patch-pandoc.cabal b/textproc/hs-pandoc/files/patch-pandoc.cabal
new file mode 100644
index 000000000000..07d92a10932a
--- /dev/null
+++ b/textproc/hs-pandoc/files/patch-pandoc.cabal
@@ -0,0 +1,83 @@
+--- pandoc.cabal.orig 2017-01-31 15:02:20 UTC
++++ pandoc.cabal
+@@ -253,7 +253,7 @@ Flag old-locale
+
+ Library
+ Build-Depends: base >= 4.7 && <5,
+- syb >= 0.1 && < 0.7,
++ syb >= 0.1 && < 0.8,
+ containers >= 0.1 && < 0.6,
+ unordered-containers >= 0.2 && < 0.3,
+ array >= 0.3 && < 0.6,
+@@ -270,12 +270,12 @@ Library
+ xml >= 1.3.12 && < 1.4,
+ random >= 1 && < 1.2,
+ extensible-exceptions >= 0.1 && < 0.2,
+- pandoc-types >= 1.17 && < 1.18,
+- aeson >= 0.7 && < 1.2,
++ pandoc-types >= 1.17 && < 1.20,
++ aeson >= 0.7 && < 1.3,
+ tagsoup >= 0.13.7 && < 0.15,
+ base64-bytestring >= 0.1 && < 1.1,
+ zlib >= 0.5 && < 0.7,
+- skylighting >= 0.1.1.4 && < 0.2,
++ skylighting >= 0.1.1.4 && < 0.4,
+ data-default >= 0.4 && < 0.8,
+ temporary >= 1.1 && < 1.3,
+ blaze-html >= 0.5 && < 0.10,
+@@ -283,7 +283,7 @@ Library
+ yaml >= 0.8.8.2 && < 0.9,
+ scientific >= 0.2 && < 0.4,
+ vector >= 0.10 && < 0.13,
+- hslua >= 0.3 && < 0.5,
++ hslua >= 0.3 && < 0.6,
+ binary >= 0.5 && < 0.9,
+ SHA >= 1.6 && < 1.7,
+ haddock-library >= 1.1 && < 1.5,
+@@ -424,15 +424,15 @@ Library
+
+ Executable pandoc
+ Build-Depends: pandoc,
+- pandoc-types >= 1.17 && < 1.18,
++ pandoc-types >= 1.17 && < 1.20,
+ base >= 4.2 && <5,
+ directory >= 1.2 && < 1.4,
+ filepath >= 1.1 && < 1.5,
+ text >= 0.11 && < 1.3,
+ bytestring >= 0.9 && < 0.11,
+ extensible-exceptions >= 0.1 && < 0.2,
+- skylighting >= 0.1.1.3 && < 0.2,
+- aeson >= 0.7.0.5 && < 1.2,
++ skylighting >= 0.1.1.3 && < 0.4,
++ aeson >= 0.7.0.5 && < 1.3,
+ yaml >= 0.8.8.2 && < 0.9,
+ containers >= 0.1 && < 0.6,
+ HTTP >= 4000.0.5 && < 4000.4
+@@ -498,15 +498,15 @@ Test-Suite test-pandoc
+ Hs-Source-Dirs: prelude
+ Other-Modules: Prelude
+ Build-Depends: base >= 4.2 && < 5,
+- syb >= 0.1 && < 0.7,
++ syb >= 0.1 && < 0.8,
+ pandoc,
+- pandoc-types >= 1.17 && < 1.18,
++ pandoc-types >= 1.17 && < 1.20,
+ bytestring >= 0.9 && < 0.11,
+ text >= 0.11 && < 1.3,
+ directory >= 1 && < 1.4,
+ filepath >= 1.1 && < 1.5,
+ process >= 1 && < 1.5,
+- skylighting >= 0.1.1.3 && < 0.2,
++ skylighting >= 0.1.1.3 && < 0.4,
+ Diff >= 0.2 && < 0.4,
+ test-framework >= 0.3 && < 0.9,
+ test-framework-hunit >= 0.2 && < 0.4,
+@@ -553,7 +553,7 @@ benchmark benchmark-pandoc
+ Other-Modules: Prelude
+ Build-Depends: pandoc,
+ base >= 4.2 && < 5,
+- syb >= 0.1 && < 0.7,
++ syb >= 0.1 && < 0.8,
+ criterion >= 1.0 && < 1.2
+ Ghc-Options: -rtsopts -Wall -fno-warn-unused-do-bind
+ Default-Language: Haskell98
diff --git a/textproc/hs-pandoc/files/patch-src_Text_Pandoc_Writers_Custom.hs b/textproc/hs-pandoc/files/patch-src_Text_Pandoc_Writers_Custom.hs
new file mode 100644
index 000000000000..648d7ffa890d
--- /dev/null
+++ b/textproc/hs-pandoc/files/patch-src_Text_Pandoc_Writers_Custom.hs
@@ -0,0 +1,14 @@
+--- src/Text/Pandoc/Writers/Custom.hs.orig 2017-01-25 16:07:43 UTC
++++ src/Text/Pandoc/Writers/Custom.hs
+@@ -183,7 +183,11 @@ writeCustom luaFile opts doc@(Pandoc meta _) = do
+ setForeignEncoding utf8
+ lua <- Lua.newstate
+ Lua.openlibs lua
++#if MIN_VERSION_hslua(0,5,0)
++ status <- Lua.loadstring lua luaScript
++#else
+ status <- Lua.loadstring lua luaScript luaFile
++#endif
+ -- check for error in lua script (later we'll change the return type
+ -- to handle this more gracefully):
+ when (status /= 0) $