aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-pandoc
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 05:28:57 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 05:28:57 +0000
commit0c76a8384fc1de4958eb1228befbee727f00c596 (patch)
tree28680b3da252da7f45a2d25108e4e2a6e41a77e5 /textproc/hs-pandoc
parentf2febc81eeab0d296325ecc49e1825762e5cd5d7 (diff)
Notes
Diffstat (limited to 'textproc/hs-pandoc')
-rw-r--r--textproc/hs-pandoc/Makefile30
-rw-r--r--textproc/hs-pandoc/distinfo5
-rw-r--r--textproc/hs-pandoc/files/patch-Setup.hs10
-rw-r--r--textproc/hs-pandoc/pkg-plist51
4 files changed, 21 insertions, 75 deletions
diff --git a/textproc/hs-pandoc/Makefile b/textproc/hs-pandoc/Makefile
index b9eb5156155e..525467d1ef2c 100644
--- a/textproc/hs-pandoc/Makefile
+++ b/textproc/hs-pandoc/Makefile
@@ -6,16 +6,23 @@
#
PORTNAME= pandoc
-PORTVERSION= 1.6
+PORTVERSION= 1.8.1.1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= A general markup converter
+LICENSE= GPLv2
+FILE_LICENSE= COPYING
+
CABAL_SETUP= Setup.hs
-USE_HACKAGE= utf8-string>=0.3 zip-archive>=0.1.1.4 xml>=1.3.5 texmath HTTP>=4000.0.5
+USE_CABAL= citeproc-hs>=0.3.1 dlist>=0.4 HTTP>=4000.0.5 json>=0.4 \
+ mtl>=1.1 network>=2 pandoc-types>=1.8 parsec>=2.1 \
+ tagsoup>=0.12 texmath>=0.5 utf8-string>=0.3 \
+ xhtml>=3000.0 xml>=1.3.5 zip-archive>=0.1.1.7
MAN1= pandoc.1 markdown2pdf.1
+MAN5= pandoc_markdown.5
PORTDATA= *
@@ -23,14 +30,14 @@ OPTIONS= HIGHLIGHTING "Compile in support for syntax highlighting" off \
EXECUTABLE "Build the pandoc executable" on \
WRAPPERS "Build the wrappers (markdown2pdf)" on \
LIBRARY "Build the pandoc library" on \
- CITEPROC "Compile in support for citeproc-hs" off
+ THREADED "Compile markdown2pdf with -threaded option" on
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_HIGHLIGHTING)
CONFIGURE_ARGS+= --flags="highlighting"
-USE_HACKAGE+= highlighting-kate
+USE_CABAL+= highlighting-kate
.else
CONFIGURE_ARGS+= --flags="-highlighting"
.endif
@@ -38,16 +45,13 @@ CONFIGURE_ARGS+= --flags="-highlighting"
.if defined(WITH_EXECUTABLE)
CONFIGURE_ARGS+= --flags="exectuable"
EXECUTABLE+= pandoc
-PLIST_SUB+= MAYBE_EXECUTABLE=""
.else
CONFIGURE_ARGS+= --flags="-executable"
-PLIST_SUB+= MAYBE_EXECUTABLE="@comment "
.endif
.if defined(WITH_WRAPPERS)
CONFIGURE_ARGS+= --flags="wrappers"
EXECUTABLE+= markdown2pdf
-PLIST_SUB+= MAYBE_WRAPPERS=""
.if !defined(WITH_EXECUTABLE)
IGNORE= cannot be compiled since wrappers require an executable. Please (re)run 'make config' and choose EXECUTABLE
@@ -55,15 +59,12 @@ IGNORE= cannot be compiled since wrappers require an executable. Please (re)ru
.else
CONFIGURE_ARGS+= --flags="-wrappers"
-PLIST_SUB+= MAYBE_WRAPPERS="@comment "
.endif
.if defined(WITH_LIBRARY)
CONFIGURE_ARGS+= --flags="library"
-PLIST_SUB+= MAYBE_LIBRARY=""
.else
CONFIGURE_ARGS+= --flags="-library"
-PLIST_SUB+= MAYBE_LIBRARY="@comment "
STANDALONE= yes
.endif
@@ -71,13 +72,10 @@ STANDALONE= yes
IGNORE= cannot be compiled in this configuration. Please (re)run 'make config' and choose either EXECUTABLE or LIBRARY or both
.endif
-.if defined(WITH_CITEPROC)
-CONFIGURE_ARGS+= --flags="citeproc"
-USE_HACKAGE+= citeproc-hs
-PLIST_SUB+= MAYBE_CITEPROC=""
+.if defined(WITH_THREADED)
+CONFIGURE_ARGS+= --flags="threaded"
.else
-CONFIGURE_ARGS+= --flags="-citeproc"
-PLIST_SUB+= MAYBE_CITEPROC="@comment "
+CONFIGURE_ARGS+= --flags="-threaded"
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/textproc/hs-pandoc/distinfo b/textproc/hs-pandoc/distinfo
index 14c06345582f..663636dc5b08 100644
--- a/textproc/hs-pandoc/distinfo
+++ b/textproc/hs-pandoc/distinfo
@@ -1,3 +1,2 @@
-MD5 (cabal/pandoc-1.6.tar.gz) = c24014cd65471a056938cf0f08e1dfd4
-SHA256 (cabal/pandoc-1.6.tar.gz) = 9b825233293edf1ea414b0e7ea821d6a914711dc2c60546566ab5a97512b079b
-SIZE (cabal/pandoc-1.6.tar.gz) = 360842
+SHA256 (cabal/pandoc-1.8.1.1.tar.gz) = 526355ddcbff69c0df7757d30d37e08864995b7ebd899916e329ecd19104c83c
+SIZE (cabal/pandoc-1.8.1.1.tar.gz) = 459135
diff --git a/textproc/hs-pandoc/files/patch-Setup.hs b/textproc/hs-pandoc/files/patch-Setup.hs
index 1de649dd9d37..b666d2d2005c 100644
--- a/textproc/hs-pandoc/files/patch-Setup.hs
+++ b/textproc/hs-pandoc/files/patch-Setup.hs
@@ -1,5 +1,5 @@
---- ./Setup.hs.orig 2010-03-29 16:24:56.000000000 +0200
-+++ ./Setup.hs 2010-05-15 13:39:12.000000000 +0200
+--- ./Setup.hs.orig 2011-02-13 18:03:00.000000000 +0100
++++ ./Setup.hs 2011-03-13 01:14:26.580023488 +0100
@@ -6,7 +6,7 @@
import Distribution.Simple.LocalBuildInfo
(LocalBuildInfo(..), absoluteInstallDirs)
@@ -9,12 +9,12 @@
import Distribution.Simple.Utils (copyFiles)
import Control.Exception ( bracket_ )
import Control.Monad ( unless )
-@@ -86,7 +86,7 @@
+@@ -85,7 +85,7 @@
installManpages :: PackageDescription -> LocalBuildInfo
-> Verbosity -> CopyDest -> IO ()
installManpages pkg lbi verbosity copy =
-- copyFiles verbosity (mandir (absoluteInstallDirs pkg lbi copy) </> "man1")
-+ copyFiles verbosity (prefix (absoluteInstallDirs pkg lbi copy) </> "man/man1")
+- copyFiles verbosity (mandir (absoluteInstallDirs pkg lbi copy))
++ copyFiles verbosity (prefix (absoluteInstallDirs pkg lbi copy) </> "man")
(zip (repeat manDir) manpages)
-- | Returns a list of 'dependencies' that have been modified after 'file'.
diff --git a/textproc/hs-pandoc/pkg-plist b/textproc/hs-pandoc/pkg-plist
deleted file mode 100644
index 6a30dd84b8a8..000000000000
--- a/textproc/hs-pandoc/pkg-plist
+++ /dev/null
@@ -1,51 +0,0 @@
-@comment $FreeBSD$
-%%MAYBE_WRAPPERS%%bin/markdown2pdf
-%%MAYBE_EXECUTABLE%%bin/pandoc
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Paths_pandoc.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc.hi
-%%MAYBE_LIBRARY%%%%MAYBE_CITEPROC%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Biblio.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Blocks.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/CharacterReferences.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Definition.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Highlighting.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Parsing.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/S5.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/UTF8.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/UUID.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Readers/HTML.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Readers/LaTeX.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Readers/Markdown.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Readers/RST.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Readers/TeXMath.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Shared.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Templates.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/ConTeXt.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/Docbook.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/EPUB.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/HTML.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/LaTeX.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/Man.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/Markdown.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/MediaWiki.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/Native.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/OpenDocument.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/ODT.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/RST.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/RTF.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers/Texinfo.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/XML.hi
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%MAYBE_LIBRARY%%%%LIBDIR_REL%%/register.sh
-%%NOPORTDOCS%%%%DOCSDIR%%/COPYING
-%%NOPORTDOCS%%@dirrm %%DOCSDIR%%
-%%MAYBE_LIBRARY%%@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Writers
-%%MAYBE_LIBRARY%%@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc/Readers
-%%MAYBE_LIBRARY%%@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Pandoc
-%%MAYBE_LIBRARY%%@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text
-%%MAYBE_LIBRARY%%@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-%%MAYBE_LIBRARY%%@dirrm %%LIBDIR_REL%%
-%%MAYBE_LIBRARY%%@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
-%%MAYBE_LIBRARY%%@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-%%MAYBE_LIBRARY%%@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
-%%MAYBE_LIBRARY%%@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old