aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-polyparse
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-09-02 15:38:45 +0000
commit7d5781e5ab3aa2c4d9f46985acec697caae1c173 (patch)
treefb0e55efa60858746649977ee5813f549bfbad04 /textproc/hs-polyparse
parent9acc5ac910695e85c7d24401bfecd5d6e6da0d7f (diff)
downloadports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.tar.gz
ports-7d5781e5ab3aa2c4d9f46985acec697caae1c173.zip
Notes
Diffstat (limited to 'textproc/hs-polyparse')
-rw-r--r--textproc/hs-polyparse/Makefile65
-rw-r--r--textproc/hs-polyparse/distinfo6
-rw-r--r--textproc/hs-polyparse/pkg-plist53
3 files changed, 70 insertions, 54 deletions
diff --git a/textproc/hs-polyparse/Makefile b/textproc/hs-polyparse/Makefile
index 478d78867724..57cd7d5e8d36 100644
--- a/textproc/hs-polyparse/Makefile
+++ b/textproc/hs-polyparse/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= polyparse
-PORTVERSION= 1.1
+PORTVERSION= 1.3
CATEGORIES= textproc haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -15,41 +15,62 @@ PKGNAMESUFFIX= -ghc
MAINTAINER= haskell@FreeBSD.org
COMMENT= Alternative parser combinator libraries for Haskell
-BUILD_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
-RUN_DEPENDS= ghc>=6.8:${PORTSDIR}/lang/ghc
+BUILD_DEPENDS= ghc>=6.10:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc>=6.10:${PORTSDIR}/lang/ghc
-GHC_VERSION= 6.8.3
-CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
-CABALDIR= lib/ghc-${GHC_VERSION}/cabal
+GHC_VERSION= 6.10.4
+POLY_VERSION= ${PORTVERSION}
-SUBDIR= lib/${PORTNAME}-${PORTVERSION}
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- PORTNAME=${PORTNAME} \
- PORTVERSION=${PORTVERSION} \
- SUBDIR=${CABALDIR}
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-PORTDOCS= COPYRIGHT html
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
-CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${PREFIX}/${CABALDIR} --libsubdir='' --datasubdir=''
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+POLY_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ POLY_LIBDIR_REL=${POLY_LIBDIR_REL} \
+ POLY_VERSION=${POLY_VERSION}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-PLIST_SUB+= RMLIC="@comment "
-.else
-PLIST_SUB+= RMLIC=""
.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.13
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
do-configure:
- cd ${WRKSRC} && ${CABALCMD} configure ${CONFIGURE_ARGS}
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
do-build:
- cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} --gen-script register
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${CABALCMD} haddock
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
.endif
do-install:
- cd ${WRKSRC} && ${CABALCMD} install
- ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${CABALDIR}/${PORTNAME}-register.sh
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${POLY_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
.include <bsd.port.mk>
diff --git a/textproc/hs-polyparse/distinfo b/textproc/hs-polyparse/distinfo
index 4c297ba654df..b87d32203856 100644
--- a/textproc/hs-polyparse/distinfo
+++ b/textproc/hs-polyparse/distinfo
@@ -1,3 +1,3 @@
-MD5 (polyparse-1.1.tar.gz) = 3d01daae5ca692b24729093dc45aa94c
-SHA256 (polyparse-1.1.tar.gz) = 87eab9c8f2bee72d0c3a00d002e442405da016794e125f6c47c66607e1983957
-SIZE (polyparse-1.1.tar.gz) = 112884
+MD5 (polyparse-1.3.tar.gz) = f8c6f4f12ff2c7d29fed91b3189d785a
+SHA256 (polyparse-1.3.tar.gz) = 6d82f08634f0856c7919c9413199f4d5f91e753a6d796a0b61e46d7cd1ce4a24
+SIZE (polyparse-1.3.tar.gz) = 108981
diff --git a/textproc/hs-polyparse/pkg-plist b/textproc/hs-polyparse/pkg-plist
index 7c34f162e0cb..43efe58cd81e 100644
--- a/textproc/hs-polyparse/pkg-plist
+++ b/textproc/hs-polyparse/pkg-plist
@@ -1,29 +1,24 @@
-%%SUBDIR%%/Text/Parse.hi
-%%SUBDIR%%/Text/ParserCombinators/HuttonMeijer.hi
-%%SUBDIR%%/Text/ParserCombinators/HuttonMeijerWallace.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly.hi
-%%SUBDIR%%/Text/ParserCombinators/PolyLazy.hi
-%%SUBDIR%%/Text/ParserCombinators/PolyState.hi
-%%SUBDIR%%/Text/ParserCombinators/PolyStateLazy.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/Base.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/Lazy.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/Plain.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/State.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/StateLazy.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/Lazy.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/Plain.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/State.hi
-%%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak/StateLazy.hi
-%%SUBDIR%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%SUBDIR%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%SUBDIR%%/%%PORTNAME%%-register.sh
-%%RMLIC%%%%DOCSDIR%%/COPYRIGHT
-%%RMLIC%%@dirrm %%DOCSDIR%%
-@dirrmtry %%SUBDIR%%/Text/ParserCombinators/Poly/NoLeak
-@dirrmtry %%SUBDIR%%/Text/ParserCombinators/Poly
-@dirrmtry %%SUBDIR%%/Text/ParserCombinators
-@dirrmtry %%SUBDIR%%/Text
-@exec sh %D/%%SUBDIR%%/%%PORTNAME%%-register.sh
-@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec ghc-pkg unregister %%PORTNAME%%
-@unexec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@comment $FreeBSD$
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSpolyparse-%%POLY_VERSION%%.o
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Parse.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/HuttonMeijer.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/HuttonMeijerWallace.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/Poly.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/Poly/Base.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/Poly/Lazy.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/Poly/Plain.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/Poly/State.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/Poly/StateLazy.hi
+%%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSpolyparse-%%POLY_VERSION%%.a
+%%POLY_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators/Poly
+@dirrm %%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/ParserCombinators
+@dirrm %%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text
+@dirrm %%POLY_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%POLY_LIBDIR_REL%%
+@exec /bin/sh %D/%%POLY_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister polyparse
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old