aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-tagstream-conduit
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-24 10:18:43 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-24 10:18:43 +0000
commitfb914fae14c72b9aaa13846fa797f14d05b6ceec (patch)
treef92aa59d9ddcee4f2ae6cda49c999b6afe36bfa2 /textproc/hs-tagstream-conduit
parentd6d6d4fa762af290c2c06cb9f9c7d4105603974f (diff)
downloadports-fb914fae14c72b9aaa13846fa797f14d05b6ceec.tar.gz
ports-fb914fae14c72b9aaa13846fa797f14d05b6ceec.zip
Notes
Diffstat (limited to 'textproc/hs-tagstream-conduit')
-rw-r--r--textproc/hs-tagstream-conduit/Makefile23
-rw-r--r--textproc/hs-tagstream-conduit/distinfo2
-rw-r--r--textproc/hs-tagstream-conduit/pkg-descr6
3 files changed, 31 insertions, 0 deletions
diff --git a/textproc/hs-tagstream-conduit/Makefile b/textproc/hs-tagstream-conduit/Makefile
new file mode 100644
index 000000000000..77431a331154
--- /dev/null
+++ b/textproc/hs-tagstream-conduit/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hs-tagstream-conduit
+# Date created: June 10, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tagstream-conduit
+PORTVERSION= 0.3.2
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= streamlined html tag parser
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= attoparsec blaze-builder blaze-builder-conduit>=0.4 \
+ conduit>=0.4
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-tagstream-conduit/distinfo b/textproc/hs-tagstream-conduit/distinfo
new file mode 100644
index 000000000000..b7827564c630
--- /dev/null
+++ b/textproc/hs-tagstream-conduit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/tagstream-conduit-0.3.2.tar.gz) = ae66739ab4b7999f0f8476c68c21e31d780c5d7d2803f7e1ac17a17fb2b3c8cc
+SIZE (cabal/tagstream-conduit-0.3.2.tar.gz) = 6543
diff --git a/textproc/hs-tagstream-conduit/pkg-descr b/textproc/hs-tagstream-conduit/pkg-descr
new file mode 100644
index 000000000000..2c664793c988
--- /dev/null
+++ b/textproc/hs-tagstream-conduit/pkg-descr
@@ -0,0 +1,6 @@
+Tag-stream is a library for parsing HTML//XML to a token stream. It can
+parse unstructured and malformed HTML from the web. It also provides an
+Enumeratee which can parse streamline html, which means it consumes constant
+memory.
+
+WWW: http://github.com/yihuang/tagstream-conduit