aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-xml-conduit
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /textproc/hs-xml-conduit
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
downloadports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.tar.gz
ports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.zip
Notes
Diffstat (limited to 'textproc/hs-xml-conduit')
-rw-r--r--textproc/hs-xml-conduit/Makefile14
-rw-r--r--textproc/hs-xml-conduit/distinfo4
-rw-r--r--textproc/hs-xml-conduit/files/patch-xml-conduit.cabal11
3 files changed, 19 insertions, 10 deletions
diff --git a/textproc/hs-xml-conduit/Makefile b/textproc/hs-xml-conduit/Makefile
index 1c5b65e86bc6..cc22aeba871c 100644
--- a/textproc/hs-xml-conduit/Makefile
+++ b/textproc/hs-xml-conduit/Makefile
@@ -1,20 +1,18 @@
# $FreeBSD$
PORTNAME= xml-conduit
-PORTVERSION= 1.1.0.3
-PORTREVISION= 5
+PORTVERSION= 1.2.1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Pure-Haskell utilities for dealing with XML with the conduit package
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-USE_CABAL= attoparsec>=0.10 attoparsec-conduit>=1.0 blaze-builder>=0.2 \
- blaze-builder-conduit>=1.0 blaze-html>=0.5 blaze-markup>=0.5 \
- conduit>=1.0 data-default failure>=0.1 monad-control>=0.3 \
- resourcet>=0.3 system-filepath>=0.4 text>=0.7 \
- transformers>=0.2 xml-types>=0.3.3
+USE_CABAL= attoparsec>=0.10 blaze-builder>=0.2 blaze-html>=0.5 \
+ blaze-markup>=0.5 conduit>=1.0 conduit-extra data-default \
+ monad-control>=0.3 resourcet>=0.3 system-filepath>=0.4 \
+ text>=0.7 xml-types>=0.3.4
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/textproc/hs-xml-conduit/distinfo b/textproc/hs-xml-conduit/distinfo
index 14fe3cd4be87..b6e3aa28c4ff 100644
--- a/textproc/hs-xml-conduit/distinfo
+++ b/textproc/hs-xml-conduit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/xml-conduit-1.1.0.3.tar.gz) = 24aed3c6b2e30ab7f9f4fb2af6f83ab4d14cda62893e02b6da70ae95a4b1b612
-SIZE (cabal/xml-conduit-1.1.0.3.tar.gz) = 29449
+SHA256 (cabal/xml-conduit-1.2.1.tar.gz) = 20f00e72922eecbd6c0e1fa5e6d1ca74a5a2f971372e5f70137d35869d6800ae
+SIZE (cabal/xml-conduit-1.2.1.tar.gz) = 30847
diff --git a/textproc/hs-xml-conduit/files/patch-xml-conduit.cabal b/textproc/hs-xml-conduit/files/patch-xml-conduit.cabal
new file mode 100644
index 000000000000..1d5bac0f2448
--- /dev/null
+++ b/textproc/hs-xml-conduit/files/patch-xml-conduit.cabal
@@ -0,0 +1,11 @@
+--- ./xml-conduit.cabal.orig 2014-05-23 05:44:22.000000000 +0200
++++ ./xml-conduit.cabal 2014-07-12 23:46:45.000000000 +0200
+@@ -31,8 +31,6 @@
+ , conduit >= 1.0 && < 1.2
+ , conduit-extra
+ , resourcet >= 0.3 && < 1.2
+- , attoparsec-conduit >= 1.0
+- , blaze-builder-conduit >= 1.0
+ , bytestring >= 0.9
+ , text >= 0.7
+ , containers >= 0.2