aboutsummaryrefslogtreecommitdiff
path: root/textproc/htdig/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-01-28 15:32:05 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-01-28 15:32:05 +0000
commit4145687849c76cca0cb590c32f9964e1699c92cb (patch)
treed55c311d0b4ff57090cf754fef5101de06056da3 /textproc/htdig/Makefile
parentef086f0077416555ce7e6f104cd497750d35c17f (diff)
Notes
Diffstat (limited to 'textproc/htdig/Makefile')
-rw-r--r--textproc/htdig/Makefile36
1 files changed, 9 insertions, 27 deletions
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index d3d61add725f..a1df325a58cc 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -23,46 +23,28 @@ CONFIGURE_ARGS= --with-config-dir=${PREFIX}/etc/htdig \
--with-image-dir=${PREFIX}/www/icons/htdig \
--with-image-url-prefix=/icons/htdig \
--with-ssl
-
-MAN1= htdig.1 htdig-pdfparser.1 htdump.1 htfuzzy.1 htload.1 \
- htmerge.1 htnotify.1 htpurge.1 htsearch.1 htstat.1 rundig.1
-
-MAN8= htdigconfig.8
+USE_LDCONFIG= yes
OPTIONS_DEFINE= APACHE DOCS
OPTIONS_DEFAULT= APACHE
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+APACHE_USE= APACHE=22+
+APACHE_CONFIGURE_ON= --with-apache=${LOCALBASE}/sbin
+APACHE_PLIST_DIRSTRY= www/cgi-bin www/data www/icons
-.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE= 22+
-CONFIGURE_ARGS+= --with-apache=${LOCALBASE}/sbin
-.include "${PORTSDIR}/Mk/bsd.apache.mk"
-PLIST_DIRSTRY+= www/cgi-bin www/data www/icons
-.endif
+PORTDOCS= *
post-patch:
@${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
-pre-install:
-.if exists(${PREFIX}/etc/htdig/htdig.conf)
- ${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.old
-.endif
-
post-install:
- @${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.sample
-.if exists(${PREFIX}/etc/htdig/htdig.conf.old)
- ${MV} ${PREFIX}/etc/htdig/htdig.conf.old ${PREFIX}/etc/htdig/htdig.conf
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}/html
+ @${MV} ${STAGEDIR}${PREFIX}/etc/htdig/htdig.conf ${STAGEDIR}${PREFIX}/etc/htdig/htdig.conf.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
.for f in ChangeLog ChangeLog.0 README STATUS
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.for f in *.html *.gif
- @${INSTALL_DATA} ${WRKSRC}/htdoc/${f} ${DOCSDIR}/html
+ @${INSTALL_DATA} ${WRKSRC}/htdoc/${f} ${STAGEDIR}${DOCSDIR}/html
.endfor
-.endif
.include <bsd.port.mk>