aboutsummaryrefslogtreecommitdiff
path: root/textproc/htdig/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-02-04 07:22:00 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-02-04 07:22:00 +0000
commit246a59bb1a3a94febe71f94e2d58ff0e3e302fd8 (patch)
tree4d8d63113e72b85c2e62233b25e76d6bad654362 /textproc/htdig/Makefile
parent47ce65cfd83aeadfa9960abf03994f341a562719 (diff)
downloadports-246a59bb1a3a94febe71f94e2d58ff0e3e302fd8.tar.gz
ports-246a59bb1a3a94febe71f94e2d58ff0e3e302fd8.zip
Notes
Diffstat (limited to 'textproc/htdig/Makefile')
-rw-r--r--textproc/htdig/Makefile45
1 files changed, 22 insertions, 23 deletions
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index b481384c41d8..0d410ed1755b 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -6,42 +6,41 @@
#
PORTNAME= htdig
-PORTVERSION= 3.1.5
-PORTREVISION= 1
+PORTVERSION= 3.1.6
CATEGORIES= textproc www
MASTER_SITES= http://www.htdig.org/files/ \
- ${MASTER_SITE_SUNSITE} \
- ftp://ftp.ntua.gr/pub/www/htdig/ \
- ftp://ftp.max.irk.ru/unix/net/www/ \
- ftp://ftp.loxinfo.co.th/pub/unix/www/ \
- ftp://ftp.htdig.org/pub/htdig/
-MASTER_SITE_SUBDIR= apps/www/indexing
+ ftp://ftp.ntua.gr/pub/www/htdig/
MAINTAINER= DougB@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/share/doc/apache:${PORTSDIR}/www/apache13
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cgi-bin-dir=${PREFIX}/share/apache/cgi-bin \
- --with-image-dir=${PREFIX}/share/apache/icons \
- --with-search-dir=${PREFIX}/share/apache/htdocs
+CONFIGURE_ARGS= --with-cgi-bin-dir=${PREFIX}/share/apache/cgi-bin \
+ --with-image-dir=${PREFIX}/share/apache/icons/htdig \
+ --with-search-dir=${PREFIX}/share/apache/htdocs \
+ --with-common-dir=${PREFIX}/share/htdig/common \
+ --with-database-dir=${PREFIX}/share/htdig/database \
+ --with-config-dir=${PREFIX}/etc/htdig \
+ --with-default-config-file=${PREFIX}/etc/htdig/htdig.conf
+
BUILD_TARGET= depends all
post-patch:
- @ ${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
- @ ${SED} -e 's#(CONFIG_DIR)/htdig.conf#(CONFIG_DIR)/htdig.conf.sample#g' \
- ${WRKSRC}/Makefile.in.Dist > ${WRKSRC}/Makefile.in
-
- @ ${MV} ${WRKSRC}/CONFIG.in ${WRKSRC}/CONFIG.in.Dist
- @ ${SED} -e 's#/conf#/etc#' \
- -e 's#/common#/share/htdig#' \
- -e 's#/db#/share/htdig#' \
- ${WRKSRC}/CONFIG.in.Dist > ${WRKSRC}/CONFIG.in
-
- @ ${MV} ${WRKSRC}/CONFIG ${WRKSRC}/CONFIG.Dist
+.for file in CONFIG CONFIG.in
+ @ ${CP} ${WRKSRC}/${file} ${WRKSRC}/${file}.Dist
@ ${SED} -e 's#/conf#/etc#' \
-e 's#/common#/share/htdig#' \
-e 's#/db#/share/htdig#' \
- ${WRKSRC}/CONFIG.Dist > ${WRKSRC}/CONFIG
+ ${WRKSRC}/${file}.Dist > ${WRKSRC}/${file}
+.endfor
+.for file in dist/configure dist/configure.in docs/ref/program/thread.html
+ @ ${CP} ${WRKSRC}/db/${file} ${WRKSRC}/db/${file}.Dist
+ @ ${SED} -e 's#-lc_r#${PTHREAD_LIBS:S/"//g}#g' \
+ ${WRKSRC}/db/${file}.Dist > ${WRKSRC}/db/${file}
+.endfor
+
+post-install:
+ @ ${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.sample
.include <bsd.port.mk>