aboutsummaryrefslogtreecommitdiff
path: root/textproc/htdig/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2004-08-28 23:14:46 +0000
committerDoug Barton <dougb@FreeBSD.org>2004-08-28 23:14:46 +0000
commit9adf7fe998a5139199da019e109ece33cc1f7430 (patch)
tree93826e82cae0285df3ffd2a74465de162c500292 /textproc/htdig/Makefile
parent64e8cb66bb17161314fdd4cfff20fff88e9bf87f (diff)
downloadports-9adf7fe998a5139199da019e109ece33cc1f7430.tar.gz
ports-9adf7fe998a5139199da019e109ece33cc1f7430.zip
Notes
Diffstat (limited to 'textproc/htdig/Makefile')
-rw-r--r--textproc/htdig/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index f73284230dfe..836fa492ce41 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= htdig
-PORTVERSION= 3.2.0.b5
+PORTVERSION= 3.2.0.b6
CATEGORIES= textproc www
MASTER_SITES= http://htdig.sourceforge.net/files/ \
http://www.htdig.org/files/ \
http://www.opdenbrouw.nl/htdig/files/ \
ftp://ftp.ntua.gr/pub/www/htdig/
-DISTNAME= htdig-3.2.0b5
+DISTNAME= htdig-3.2.0b6
MAINTAINER= DougB@FreeBSD.org
COMMENT= A www indexing and searching system
RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${APACHE_PORT}
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-config-dir=${PREFIX}/etc/htdig \
@@ -33,14 +33,27 @@ CONFIGURE_ARGS= --with-config-dir=${PREFIX}/etc/htdig \
--with-ssl \
--with-apache=${LOCALBASE}/sbin
+MAN1= htdig.1 htdig-pdfparser.1 htdump.1 htfuzzy.1 htload.1 \
+ htmerge.1 htnotify.1 htpurge.1 htsearch.1 htstat.1 rundig.1
+
+MAN8= htdigconfig.8
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
EXTRA_PATCHES+= ${PATCHDIR}/RELENG_4-patch-htnet_SSLConnection.cc
.endif
+pre-install:
+.if exists(${PREFIX}/etc/htdig/htdig.conf)
+ ${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.old
+.endif
+
post-install:
@${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.sample
+.if exists(${PREFIX}/etc/htdig/htdig.conf.old)
+ ${MV} ${PREFIX}/etc/htdig/htdig.conf.old ${PREFIX}/etc/htdig/htdig.conf
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/html
.for f in ChangeLog ChangeLog.0 README STATUS