aboutsummaryrefslogtreecommitdiff
path: root/textproc/htdig
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-02-04 07:22:00 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-02-04 07:22:00 +0000
commit246a59bb1a3a94febe71f94e2d58ff0e3e302fd8 (patch)
tree4d8d63113e72b85c2e62233b25e76d6bad654362 /textproc/htdig
parent47ce65cfd83aeadfa9960abf03994f341a562719 (diff)
downloadports-246a59bb1a3a94febe71f94e2d58ff0e3e302fd8.tar.gz
ports-246a59bb1a3a94febe71f94e2d58ff0e3e302fd8.zip
Notes
Diffstat (limited to 'textproc/htdig')
-rw-r--r--textproc/htdig/Makefile45
-rw-r--r--textproc/htdig/distinfo2
-rw-r--r--textproc/htdig/files/patch-DB2_db.cc.new10
-rw-r--r--textproc/htdig/files/patch-ab22
-rw-r--r--textproc/htdig/files/patch-htsearch_cc24
-rw-r--r--textproc/htdig/pkg-descr2
-rw-r--r--textproc/htdig/pkg-plist90
7 files changed, 72 insertions, 123 deletions
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index b481384c41d8..0d410ed1755b 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -6,42 +6,41 @@
#
PORTNAME= htdig
-PORTVERSION= 3.1.5
-PORTREVISION= 1
+PORTVERSION= 3.1.6
CATEGORIES= textproc www
MASTER_SITES= http://www.htdig.org/files/ \
- ${MASTER_SITE_SUNSITE} \
- ftp://ftp.ntua.gr/pub/www/htdig/ \
- ftp://ftp.max.irk.ru/unix/net/www/ \
- ftp://ftp.loxinfo.co.th/pub/unix/www/ \
- ftp://ftp.htdig.org/pub/htdig/
-MASTER_SITE_SUBDIR= apps/www/indexing
+ ftp://ftp.ntua.gr/pub/www/htdig/
MAINTAINER= DougB@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/share/doc/apache:${PORTSDIR}/www/apache13
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cgi-bin-dir=${PREFIX}/share/apache/cgi-bin \
- --with-image-dir=${PREFIX}/share/apache/icons \
- --with-search-dir=${PREFIX}/share/apache/htdocs
+CONFIGURE_ARGS= --with-cgi-bin-dir=${PREFIX}/share/apache/cgi-bin \
+ --with-image-dir=${PREFIX}/share/apache/icons/htdig \
+ --with-search-dir=${PREFIX}/share/apache/htdocs \
+ --with-common-dir=${PREFIX}/share/htdig/common \
+ --with-database-dir=${PREFIX}/share/htdig/database \
+ --with-config-dir=${PREFIX}/etc/htdig \
+ --with-default-config-file=${PREFIX}/etc/htdig/htdig.conf
+
BUILD_TARGET= depends all
post-patch:
- @ ${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.Dist
- @ ${SED} -e 's#(CONFIG_DIR)/htdig.conf#(CONFIG_DIR)/htdig.conf.sample#g' \
- ${WRKSRC}/Makefile.in.Dist > ${WRKSRC}/Makefile.in
-
- @ ${MV} ${WRKSRC}/CONFIG.in ${WRKSRC}/CONFIG.in.Dist
- @ ${SED} -e 's#/conf#/etc#' \
- -e 's#/common#/share/htdig#' \
- -e 's#/db#/share/htdig#' \
- ${WRKSRC}/CONFIG.in.Dist > ${WRKSRC}/CONFIG.in
-
- @ ${MV} ${WRKSRC}/CONFIG ${WRKSRC}/CONFIG.Dist
+.for file in CONFIG CONFIG.in
+ @ ${CP} ${WRKSRC}/${file} ${WRKSRC}/${file}.Dist
@ ${SED} -e 's#/conf#/etc#' \
-e 's#/common#/share/htdig#' \
-e 's#/db#/share/htdig#' \
- ${WRKSRC}/CONFIG.Dist > ${WRKSRC}/CONFIG
+ ${WRKSRC}/${file}.Dist > ${WRKSRC}/${file}
+.endfor
+.for file in dist/configure dist/configure.in docs/ref/program/thread.html
+ @ ${CP} ${WRKSRC}/db/${file} ${WRKSRC}/db/${file}.Dist
+ @ ${SED} -e 's#-lc_r#${PTHREAD_LIBS:S/"//g}#g' \
+ ${WRKSRC}/db/${file}.Dist > ${WRKSRC}/db/${file}
+.endfor
+
+post-install:
+ @ ${MV} ${PREFIX}/etc/htdig/htdig.conf ${PREFIX}/etc/htdig/htdig.conf.sample
.include <bsd.port.mk>
diff --git a/textproc/htdig/distinfo b/textproc/htdig/distinfo
index 5096b867a3d9..52ea45c11a4e 100644
--- a/textproc/htdig/distinfo
+++ b/textproc/htdig/distinfo
@@ -1 +1 @@
-MD5 (htdig-3.1.5.tar.gz) = cbf4a0f2b703d9822db555a14dc96ed3
+MD5 (htdig-3.1.6.tar.gz) = 7a2f20d8d6149efd8d119bb2ebf55f23
diff --git a/textproc/htdig/files/patch-DB2_db.cc.new b/textproc/htdig/files/patch-DB2_db.cc.new
deleted file mode 100644
index b9751d79f8ce..000000000000
--- a/textproc/htdig/files/patch-DB2_db.cc.new
+++ /dev/null
@@ -1,10 +0,0 @@
---- htlib/DB2_db.cc Thu Feb 24 18:29:11 2000
-+++ htlib/DB2_db.cc.new Tue Dec 11 00:16:27 2001
-@@ -44,7 +44,6 @@
- #include <errno.h>
- #include <stdlib.h>
- #include <fstream.h>
--#include <malloc.h>
- #include <unistd.h>
-
- // Where do I need this for? I don't know.
diff --git a/textproc/htdig/files/patch-ab b/textproc/htdig/files/patch-ab
deleted file mode 100644
index 8cac20bc895f..000000000000
--- a/textproc/htdig/files/patch-ab
+++ /dev/null
@@ -1,22 +0,0 @@
---- db/dist/configure.orig Thu Feb 24 18:29:00 2000
-+++ db/dist/configure Sat Feb 26 13:25:13 2000
-@@ -3056,7 +3056,7 @@
-
- case "$host_os" in
- freebsd*) CPPFLAGS="-D_THREAD_SAFE $CPPFLAGS"
-- LIBS="-lc_r";;
-+ LIBS="-pthread";;
- irix*) CPPFLAGS="-D_SGI_MP_SOURCE $CPPFLAGS";;
- osf*) CPPFLAGS="-D_REENTRANT $CPPFLAGS";;
- solaris*) CPPFLAGS="-D_REENTRANT $CPPFLAGS"
---- db/dist/configure.in.orig Thu Feb 24 18:29:00 2000
-+++ db/dist/configure.in Sat Feb 26 13:25:13 2000
-@@ -405,7 +405,7 @@
- dnl libraries for threaded applications
- case "$host_os" in
- freebsd*) CPPFLAGS="-D_THREAD_SAFE $CPPFLAGS"
-- LIBS="-lc_r";;
-+ LIBS="-pthread";;
- irix*) CPPFLAGS="-D_SGI_MP_SOURCE $CPPFLAGS";;
- osf*) CPPFLAGS="-D_REENTRANT $CPPFLAGS";;
- solaris*) CPPFLAGS="-D_REENTRANT $CPPFLAGS"
diff --git a/textproc/htdig/files/patch-htsearch_cc b/textproc/htdig/files/patch-htsearch_cc
deleted file mode 100644
index 5a92dba57454..000000000000
--- a/textproc/htdig/files/patch-htsearch_cc
+++ /dev/null
@@ -1,24 +0,0 @@
---- htsearch/htsearch.cc.Dist Thu Feb 24 18:29:11 2000
-+++ htsearch/htsearch.cc Mon Sep 24 23:57:28 2001
-@@ -77,9 +77,18 @@
- switch (c)
- {
- case 'c':
-- configFile = optarg;
-- override_config=1;
-- break;
-+ // The default is obviously to do this securely
-+ // but if people want to shoot themselves in the foot...
-+#ifndef ALLOW_INSECURE_CGI_CONFIG
-+ if (!getenv("REQUEST_METHOD"))
-+ {
-+#endif
-+ configFile = optarg;
-+ override_config=1;
-+#ifndef ALLOW_INSECURE_CGI_CONFIG
-+ }
-+#endif
-+ break;
- case 'v':
- debug++;
- break;
diff --git a/textproc/htdig/pkg-descr b/textproc/htdig/pkg-descr
index 340f31b52a9b..27266dac46fb 100644
--- a/textproc/htdig/pkg-descr
+++ b/textproc/htdig/pkg-descr
@@ -12,4 +12,4 @@ HTTP 1.0 protocol.
WWW: http://www.htdig.org/
-Bill Fumerola <billf@FreeBSD.org>
+Doug Barton <DougB@FreeBSD.org>
diff --git a/textproc/htdig/pkg-plist b/textproc/htdig/pkg-plist
index 485ff4771e63..4a74211f153e 100644
--- a/textproc/htdig/pkg-plist
+++ b/textproc/htdig/pkg-plist
@@ -1,50 +1,56 @@
bin/htdig
+bin/htdump
bin/htfuzzy
+bin/htload
bin/htmerge
bin/htnotify
bin/rundig
-etc/htdig.conf.sample
-share/htdig/bad_words
-share/htdig/english.0
-share/htdig/english.aff
-share/htdig/footer.html
-share/htdig/header.html
-share/htdig/long.html
-share/htdig/nomatch.html
-share/htdig/short.html
-share/htdig/synonyms
-share/htdig/syntax.html
-share/htdig/wrapper.html
+etc/htdig/htdig.conf.sample
share/apache/cgi-bin/htsearch
share/apache/htdocs/search.html
-share/apache/icons/button1.gif
-share/apache/icons/button1.png
-share/apache/icons/button10.gif
-share/apache/icons/button10.png
-share/apache/icons/button2.gif
-share/apache/icons/button2.png
-share/apache/icons/button3.gif
-share/apache/icons/button3.png
-share/apache/icons/button4.gif
-share/apache/icons/button4.png
-share/apache/icons/button5.gif
-share/apache/icons/button5.png
-share/apache/icons/button6.gif
-share/apache/icons/button6.png
-share/apache/icons/button7.gif
-share/apache/icons/button7.png
-share/apache/icons/button8.gif
-share/apache/icons/button8.png
-share/apache/icons/button9.gif
-share/apache/icons/button9.png
-share/apache/icons/buttonl.gif
-share/apache/icons/buttonl.png
-share/apache/icons/buttonr.gif
-share/apache/icons/buttonr.png
-share/apache/icons/htdig.gif
-share/apache/icons/htdig.png
-share/apache/icons/star.gif
-share/apache/icons/star.png
-share/apache/icons/star_blank.gif
-share/apache/icons/star_blank.png
+share/apache/icons/htdig/button1.gif
+share/apache/icons/htdig/button1.png
+share/apache/icons/htdig/button10.gif
+share/apache/icons/htdig/button10.png
+share/apache/icons/htdig/button2.gif
+share/apache/icons/htdig/button2.png
+share/apache/icons/htdig/button3.gif
+share/apache/icons/htdig/button3.png
+share/apache/icons/htdig/button4.gif
+share/apache/icons/htdig/button4.png
+share/apache/icons/htdig/button5.gif
+share/apache/icons/htdig/button5.png
+share/apache/icons/htdig/button6.gif
+share/apache/icons/htdig/button6.png
+share/apache/icons/htdig/button7.gif
+share/apache/icons/htdig/button7.png
+share/apache/icons/htdig/button8.gif
+share/apache/icons/htdig/button8.png
+share/apache/icons/htdig/button9.gif
+share/apache/icons/htdig/button9.png
+share/apache/icons/htdig/buttonl.gif
+share/apache/icons/htdig/buttonl.png
+share/apache/icons/htdig/buttonr.gif
+share/apache/icons/htdig/buttonr.png
+share/apache/icons/htdig/htdig.gif
+share/apache/icons/htdig/htdig.png
+share/apache/icons/htdig/star.gif
+share/apache/icons/htdig/star.png
+share/apache/icons/htdig/star_blank.gif
+share/apache/icons/htdig/star_blank.png
+share/htdig/common/bad_words
+share/htdig/common/english.0
+share/htdig/common/english.aff
+share/htdig/common/footer.html
+share/htdig/common/header.html
+share/htdig/common/long.html
+share/htdig/common/nomatch.html
+share/htdig/common/short.html
+share/htdig/common/synonyms
+share/htdig/common/syntax.html
+share/htdig/common/wrapper.html
+@dirrm etc/htdig
+@dirrm share/apache/icons/htdig
+@dirrm share/htdig/common
+@dirrm share/htdig/database
@dirrm share/htdig