aboutsummaryrefslogtreecommitdiff
path: root/textproc/html-pretty/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-03-17 22:24:09 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-03-17 22:24:09 +0000
commit32a5036976134a2cbec4d3aa44fc959cced92a28 (patch)
treef267a45164e1221a53aa10e7f1ce4ec0c5b894f3 /textproc/html-pretty/Makefile
parent703df1c0c69572a3949720d8fef04043908594e3 (diff)
downloadports-32a5036976134a2cbec4d3aa44fc959cced92a28.tar.gz
ports-32a5036976134a2cbec4d3aa44fc959cced92a28.zip
Notes
Diffstat (limited to 'textproc/html-pretty/Makefile')
-rw-r--r--textproc/html-pretty/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/html-pretty/Makefile b/textproc/html-pretty/Makefile
new file mode 100644
index 000000000000..3f21dd3bb6b9
--- /dev/null
+++ b/textproc/html-pretty/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: html-pretty
+# Date created: 16 March 2004
+# Whom: Greg Lewis <glewis@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= html-pretty
+PORTVERSION= 1.01
+CATEGORIES= textproc www
+MASTER_SITES= http://www.math.utah.edu/pub/sgml/
+DISTNAME= htmlpty-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= HTML and SGML prettyprinter and text-to-HTML/SGML converter
+
+GNU_CONFIGURE= yes
+
+MAN1= html-pretty.1
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+
+DOCFILES= AUTHORS BUGS COPYING ChangeLog NEWS README THANKS
+
+post-install:
+ -${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_DATA} -o ${SHAREOWN} -g ${SHAREGRP} ${WRKSRC}/*.html \
+ ${DOCSDIR}/html/
+ ${INSTALL_DATA} -o ${SHAREOWN} -g ${SHAREGRP} ${WRKSRC}/Docs/*.html \
+ ${DOCSDIR}/html/
+ for docfile in ${DOCFILES}; do \
+ ${INSTALL_DATA} -o ${SHAREOWN} -g ${SHAREGRP} \
+ ${WRKSRC}/$$docfile ${DOCSDIR}/; \
+ done
+.endif
+
+.include <bsd.port.mk>