aboutsummaryrefslogtreecommitdiff
path: root/textproc/html2text/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-03-27 02:09:23 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-03-27 02:09:23 +0000
commitefaa98f4e377b26f1dc7d633e853eadd6feece70 (patch)
tree947cb97a35b248a898fd93205baf64a2acac65dd /textproc/html2text/Makefile
parent8d45ccc69bbc1102508dc2217e83c6d63118127c (diff)
Notes
Diffstat (limited to 'textproc/html2text/Makefile')
-rw-r--r--textproc/html2text/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
new file mode 100644
index 000000000000..6818d4292827
--- /dev/null
+++ b/textproc/html2text/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: html2text
+# Date created: 7 March 2003
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= html2text
+PORTVERSION= 1.3.1
+CATEGORIES= textproc
+MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/ \
+ ftp://ftp.ibiblio.org/pub/linux/apps/www/converters/
+
+MAINTAINER= corecode@corecode.ath.cx
+COMMENT= Converts HTML documents into plain text
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+MANCOMPRESSED= yes
+
+MAN1= html2text.1
+MAN5= html2textrc.5
+
+DOCS= CHANGES COPYING CREDITS KNOWN_BUGS README TODO
+
+post-patch:
+ @${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; /^CXXFLAGS/s/=/+=/' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/libstd/Makefile.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/html2text ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/html2text.1.gz ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/html2textrc.5.gz ${MANPREFIX}/man/man5
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:C#^#${WRKSRC}/#g} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>