aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmlc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-21 12:56:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-21 12:56:53 +0000
commit2dceff8e43514dee684eae0391d46d1b5fe35097 (patch)
tree94eefe8892228ae04c80b6b1379001c895fdf860 /textproc/htmlc
parent78ed03a1d2b6a7dc07c6e453f83c58ccba8a5892 (diff)
downloadports-2dceff8e43514dee684eae0391d46d1b5fe35097.tar.gz
ports-2dceff8e43514dee684eae0391d46d1b5fe35097.zip
Notes
Diffstat (limited to 'textproc/htmlc')
-rw-r--r--textproc/htmlc/Makefile59
-rw-r--r--textproc/htmlc/distinfo3
-rw-r--r--textproc/htmlc/pkg-descr15
3 files changed, 77 insertions, 0 deletions
diff --git a/textproc/htmlc/Makefile b/textproc/htmlc/Makefile
new file mode 100644
index 000000000000..36a407fb0564
--- /dev/null
+++ b/textproc/htmlc/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: htmlc
+# Date created: 14 Mar 2010
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlc
+PORTVERSION= 2.21.0
+CATEGORIES= textproc
+MASTER_SITES= http://htmlc.inria.fr/ \
+ http://caml.inria.fr/distrib/bazar-ocaml/htmlc/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= A text file generator
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+#MAN1= htmlc.1
+
+PLIST_FILES= bin/htmlc bin/htmlc.byt share/htmlc/env
+PLIST_DIRS= share/htmlc
+PORTDOCS= LICENSE INSTALL README JoeCaml.gif rocq.gif copyright-eng.htm \
+ copyright-fra.htm eng.htm fra.htm index.htm
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix ${LOCALBASE}
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${RM} -f ${WRKSRC}/doc/Makefile
+ ${TOUCH} ${WRKSRC}/doc/Makefile
+ ${ECHO} "all:" > ${WRKSRC}/doc/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/compiler/htmlc ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/compiler/htmlc.byt ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/config/env ${DATADIR}
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/LICENSE ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/INSTALL ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/README ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/JoeCaml.gif ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/rocq.gif ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/copyright-eng.htm ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/copyright-fra.htm ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/eng.htm ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/fra.htm ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/index.htm ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/htmlc/distinfo b/textproc/htmlc/distinfo
new file mode 100644
index 000000000000..d5ee584a197e
--- /dev/null
+++ b/textproc/htmlc/distinfo
@@ -0,0 +1,3 @@
+MD5 (htmlc-2.21.0.tgz) = bb1a1aa12e5958d1e3ffa04639968e00
+SHA256 (htmlc-2.21.0.tgz) = eb56d8fd4a47df1c7f915b31aff19f74f405e498012c663e64c6704cf5a4cf88
+SIZE (htmlc-2.21.0.tgz) = 118291
diff --git a/textproc/htmlc/pkg-descr b/textproc/htmlc/pkg-descr
new file mode 100644
index 000000000000..5c647b1d9855
--- /dev/null
+++ b/textproc/htmlc/pkg-descr
@@ -0,0 +1,15 @@
+Htmlc is an HTML template files expander that produces regular HTML pages from
+source files that contain text fragments that require some computation to be
+written. Those fragments can be the output of an arbitrary Unix command, for
+instance the last modification date of a page, or parts of HTML pages to be
+included in the page, or pieces of the page that are common to the entire WEB
+site (a presentation header or a footer section for each page). Providing the
+automatic inclusion of those text fragments into your HTML source pages, Htmlc
+offers a server independent way of defining templates to factorize out the
+repetitive parts of HTML pages. Htmlc also provides a variable expansion
+facility (using definitions in the template file or in simple environment files
+using a syntax a la objective Caml). In short, Htmlc ensures the static
+verification and the static expansion of the Server Side Includes directives of
+the Web pages in the efficient and friendly way of a command-line compiler.
+
+WWW: http://htmlc.inria.fr/eng.htm