aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmlise
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-04 14:49:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-04 14:49:17 +0000
commitd579cde9e1b865450e25930786a3825af3ae3743 (patch)
tree59846ef8c56ed4670604f0d7f68f468f26c20752 /textproc/htmlise
parent2ad823d6d84ec097e827a8bc6b9e4f3c56c8af82 (diff)
downloadports-d579cde9e1b865450e25930786a3825af3ae3743.tar.gz
ports-d579cde9e1b865450e25930786a3825af3ae3743.zip
Notes
Diffstat (limited to 'textproc/htmlise')
-rw-r--r--textproc/htmlise/Makefile36
-rw-r--r--textproc/htmlise/distinfo2
-rw-r--r--textproc/htmlise/pkg-descr6
3 files changed, 44 insertions, 0 deletions
diff --git a/textproc/htmlise/Makefile b/textproc/htmlise/Makefile
new file mode 100644
index 000000000000..db119bf02b05
--- /dev/null
+++ b/textproc/htmlise/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: htmlise
+# Date created: 2 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlise
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.ex-parrot.com/~chris/stuff/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Formats plain text as HTML
+
+USE_REINPLACE= yes
+
+TABSIZE?= 8
+
+SRC= htmlise tables markup inline
+PLIST_FILES= bin/htmlise
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(TABSIZE\ \)[0-9]*|\1${TABSIZE}|' \
+ ${WRKSRC}/${PORTNAME}.h
+
+do-build:
+.for f in ${SRC}
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}.o
+.endfor
+ ${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${SRC:C/(.*)/${WRKSRC}\/\1.o/}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/htmlise/distinfo b/textproc/htmlise/distinfo
new file mode 100644
index 000000000000..9b634f547292
--- /dev/null
+++ b/textproc/htmlise/distinfo
@@ -0,0 +1,2 @@
+MD5 (htmlise-0.2.tar.gz) = b3c3a1f22d7b3f8a7cb0638c28af0623
+SIZE (htmlise-0.2.tar.gz) = 11334
diff --git a/textproc/htmlise/pkg-descr b/textproc/htmlise/pkg-descr
new file mode 100644
index 000000000000..f6f552758217
--- /dev/null
+++ b/textproc/htmlise/pkg-descr
@@ -0,0 +1,6 @@
+A command line utility that formats plain text from standard input to HTML.
+
+WWW: http://www.ex-parrot.com/~chris/software.html
+
+- ehaupt
+ehaupt@critical.ch