aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmlize.el
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-18 10:29:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-18 10:29:30 +0000
commiteaf81e584fc2c8d1382855c3c86aa30d0b1ce004 (patch)
tree44b820749e22097d2b08892b5d30e93462bca906 /textproc/htmlize.el
parent9eda3197b701ab39ca5d02801e87ca6e26ef53d7 (diff)
downloadports-eaf81e584fc2c8d1382855c3c86aa30d0b1ce004.tar.gz
ports-eaf81e584fc2c8d1382855c3c86aa30d0b1ce004.zip
Notes
Diffstat (limited to 'textproc/htmlize.el')
-rw-r--r--textproc/htmlize.el/Makefile31
-rw-r--r--textproc/htmlize.el/distinfo1
-rw-r--r--textproc/htmlize.el/pkg-descr22
-rw-r--r--textproc/htmlize.el/pkg-message10
-rw-r--r--textproc/htmlize.el/pkg-plist1
5 files changed, 65 insertions, 0 deletions
diff --git a/textproc/htmlize.el/Makefile b/textproc/htmlize.el/Makefile
new file mode 100644
index 000000000000..3c4fd0083013
--- /dev/null
+++ b/textproc/htmlize.el/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: htmlize.el
+# Date created: 15 January 2004
+# Whom: Marc van Woerkom <marc.vanwoerkom@fernuni-hagen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlize.el
+PORTVERSION= 1.16
+CATEGORIES= textproc elisp
+MASTER_SITES= http://fly.srk.fer.hr/~hniksic/emacs/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= marc.vanwoerkom@fernuni-hagen.de
+COMMENT= Emacs major mode to create HTML files from Emacs buffers (in colour!)
+
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+
+NO_BUILD= yes
+
+LISPDIR= ${PREFIX}/share/emacs/site-lisp
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${LISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/htmlize.el/distinfo b/textproc/htmlize.el/distinfo
new file mode 100644
index 000000000000..3cc5a20cec3c
--- /dev/null
+++ b/textproc/htmlize.el/distinfo
@@ -0,0 +1 @@
+MD5 (htmlize.el) = 58ef49144157a446a131132c35dbf6fd
diff --git a/textproc/htmlize.el/pkg-descr b/textproc/htmlize.el/pkg-descr
new file mode 100644
index 000000000000..c8b515b28d3e
--- /dev/null
+++ b/textproc/htmlize.el/pkg-descr
@@ -0,0 +1,22 @@
+Emacs major mode to create HTML files from Emacs buffers (in colour!)
+
+This major mode will output the contents of an Emacs buffer as a
+HTML file, preserving the colour attributes of that buffer.
+
+This is a pretty elegant solution to produce nice listings of your
+code in Erlang, C++, SML, Ruby (or whatever esoteric language you can
+dig out a major mode for) to display on web sites.
+
+As an example watch the ELISP code of this major mode
+
+ http://fly.srk.fer.hr/~hniksic/emacs/htmlize.el.html
+
+Because the colouring depends only on your major mode and perhaps
+some individual settings (e.g. I prefer a dark background) you can
+turn any Emacs buffer into HTML.
+
+
+WWW: http://fly.srk.fer.hr/~hniksic/emacs/
+
+- Marc van Woerkom
+marc.vanwoerkom@fernuni-hagen.de
diff --git a/textproc/htmlize.el/pkg-message b/textproc/htmlize.el/pkg-message
new file mode 100644
index 000000000000..b9a3c8065311
--- /dev/null
+++ b/textproc/htmlize.el/pkg-message
@@ -0,0 +1,10 @@
+****************************************************************************
+To use htmlize mode, add to your ~/.emacs the following lines:
+
+;; Enable syntax colouring
+(global-font-lock-mode)
+
+;; General emacs to HTML converter
+(require 'htmlize)
+
+****************************************************************************
diff --git a/textproc/htmlize.el/pkg-plist b/textproc/htmlize.el/pkg-plist
new file mode 100644
index 000000000000..d2fe72ba16aa
--- /dev/null
+++ b/textproc/htmlize.el/pkg-plist
@@ -0,0 +1 @@
+share/emacs/site-lisp/htmlize.el