aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmlsection
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-10-05 00:00:52 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-10-05 00:00:52 +0000
commitdbf1723e3c0ecb752db494f772ae8cc5d80f3d56 (patch)
tree92091598316a5fc52a66a063b228c7158437feb3 /textproc/htmlsection
parentda7b4d9a195f1388d370a2347770e066f025d544 (diff)
downloadports-dbf1723e3c0ecb752db494f772ae8cc5d80f3d56.tar.gz
ports-dbf1723e3c0ecb752db494f772ae8cc5d80f3d56.zip
Notes
Diffstat (limited to 'textproc/htmlsection')
-rw-r--r--textproc/htmlsection/Makefile35
-rw-r--r--textproc/htmlsection/distinfo1
-rw-r--r--textproc/htmlsection/pkg-comment1
-rw-r--r--textproc/htmlsection/pkg-descr15
-rw-r--r--textproc/htmlsection/pkg-plist6
5 files changed, 58 insertions, 0 deletions
diff --git a/textproc/htmlsection/Makefile b/textproc/htmlsection/Makefile
new file mode 100644
index 000000000000..8ead56fc6d77
--- /dev/null
+++ b/textproc/htmlsection/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: htmlsection
+# Date created: 2 October 2001
+# Whom: SAKAI Hiroaki <sakai@seki.ee.kagu.sut.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlsection
+PORTVERSION= 1.0
+CATEGORIES= textproc www
+MASTER_SITES= http://www.seki.ee.kagu.sut.ac.jp/~sakai/myfreesoft/ \
+ http://hp.vector.co.jp/authors/VA014157/myfreesoft/ \
+ http://www.people.or.jp/~hsakai/myfreesoft/
+
+MAINTAINER= sakai@seki.ee.kagu.sut.ac.jp
+
+MAN1= htmlsection.1
+MANCOMPRESSED= yes
+
+pre-build:
+ @(echo perl is set ${PERL} in pre-build:)
+ @(cd ${WRKSRC}; ./findperl.sh ${PERL} > whereperl)
+ @(cd ${WRKSRC}; ${CAT} whereperl)
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/htmlsection ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/htmlsection.1.gz ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in INSTALL README htmlsection_orig.html htmlsection.html
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/htmlsection/distinfo b/textproc/htmlsection/distinfo
new file mode 100644
index 000000000000..dca10e5c9cad
--- /dev/null
+++ b/textproc/htmlsection/distinfo
@@ -0,0 +1 @@
+MD5 (htmlsection-1.0.tar.gz) = b01eebda5a73fdfa6f5fc03fed391426
diff --git a/textproc/htmlsection/pkg-comment b/textproc/htmlsection/pkg-comment
new file mode 100644
index 000000000000..d6f5dbe96a48
--- /dev/null
+++ b/textproc/htmlsection/pkg-comment
@@ -0,0 +1 @@
+Insert section numbers in HTML and make a table of contents
diff --git a/textproc/htmlsection/pkg-descr b/textproc/htmlsection/pkg-descr
new file mode 100644
index 000000000000..470aca7accfa
--- /dev/null
+++ b/textproc/htmlsection/pkg-descr
@@ -0,0 +1,15 @@
+htmlsection is a perl script to insert section numbers in HTML. When you use
+htmlsection, you don't have to manage section, table, figure, program-list,
+and reference numbers and you don't have to make the table of contents,
+table index, figure index, and program-list index.
+
+* Insert section number in HTML and make links to the section.
+* Make the table of contents.
+* Insert table, figure, and program-list number and make links.
+* Make the index of tables, figures, and program-lists.
+* Insert reference number and make links.
+
+WWW: http://www.seki.ee.kagu.sut.ac.jp/~sakai/myfreesoft/htmlsection.html
+
+--
+SAKAI Hiroaki <sakai@seki.ee.kagu.sut.ac.jp>
diff --git a/textproc/htmlsection/pkg-plist b/textproc/htmlsection/pkg-plist
new file mode 100644
index 000000000000..93359934bb8c
--- /dev/null
+++ b/textproc/htmlsection/pkg-plist
@@ -0,0 +1,6 @@
+bin/htmlsection
+%%PORTDOCS%%share/doc/htmlsection/INSTALL
+%%PORTDOCS%%share/doc/htmlsection/README
+%%PORTDOCS%%share/doc/htmlsection/htmlsection_orig.html
+%%PORTDOCS%%share/doc/htmlsection/htmlsection.html
+%%PORTDOCS%%@dirrm share/doc/htmlsection