aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmltolatex
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-27 09:04:29 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-27 09:04:29 +0000
commit22bbff4e59b8c730d2265f8ab606ee04e93dd5e7 (patch)
tree45461066bab74187a529a87d0c0d94c4a82b1b37 /textproc/htmltolatex
parenta43af0d3c9fc67954d5342228bec5c276a37290e (diff)
downloadports-22bbff4e59b8c730d2265f8ab606ee04e93dd5e7.tar.gz
ports-22bbff4e59b8c730d2265f8ab606ee04e93dd5e7.zip
Notes
Diffstat (limited to 'textproc/htmltolatex')
-rw-r--r--textproc/htmltolatex/Makefile4
-rw-r--r--textproc/htmltolatex/files/patch-CH2L.cpp17
-rw-r--r--textproc/htmltolatex/files/patch-util.cpp12
3 files changed, 19 insertions, 14 deletions
diff --git a/textproc/htmltolatex/Makefile b/textproc/htmltolatex/Makefile
index c6b3b78d74c7..eb90fdb1a498 100644
--- a/textproc/htmltolatex/Makefile
+++ b/textproc/htmltolatex/Makefile
@@ -16,9 +16,7 @@ LICENSE_FILE= ${WRKSRC}/copying.txt
LIB_DEPENDS= libGraphicsMagick++.so:graphics/GraphicsMagick
-BROKEN_powerpc64= fails to link: libGraphicsMagick++.so: undefined reference to std::__cxx11::basic_string
-
-USES= bison gmake
+USES= bison compiler:c++11-lang gmake
MAKEFILE= GNUmakefile
MAKE_JOBS_UNSAFE= yes
MAKE_ARGS= CXX="${CXX}" \
diff --git a/textproc/htmltolatex/files/patch-CH2L.cpp b/textproc/htmltolatex/files/patch-CH2L.cpp
index 4585cef9732d..8480ab2dd44e 100644
--- a/textproc/htmltolatex/files/patch-CH2L.cpp
+++ b/textproc/htmltolatex/files/patch-CH2L.cpp
@@ -1,5 +1,5 @@
---- CH2L.cpp.orig 2001-11-11 21:03:19.000000000 +0100
-+++ CH2L.cpp 2018-01-19 07:07:05.786197000 +0100
+--- CH2L.cpp.orig 2001-11-11 20:03:19 UTC
++++ CH2L.cpp
@@ -18,6 +18,9 @@
* Boston, MA 02111-1307, USA.
*
@@ -10,15 +10,18 @@
#include "CH2L.h"
#include "util.h"
#include "safe_ostrstream.h"
-@@ -28,7 +31,6 @@
+@@ -27,8 +30,9 @@
+ #include <stdlib.h>
#include <assert.h>
#include <fstream>
++#include <cstring>
++#include <strings.h>
-using namespace std;
using namespace Magick;
#define ATTRIBUTENESTLIMIT 1000
-@@ -2086,7 +2088,7 @@
+@@ -2086,7 +2090,7 @@ void CH2L::make_font_start()
}
@@ -27,7 +30,7 @@
{
dump_text();
int cnt = 0;
-@@ -2225,7 +2227,7 @@
+@@ -2225,7 +2229,7 @@ void CH2L::end_sup()
}
////////////////////////
@@ -36,7 +39,7 @@
{
dump_text();
-@@ -3594,7 +3596,7 @@
+@@ -3594,7 +3598,7 @@ void CH2L::_idle_tag_end(const string &htmltag)
}
@@ -45,7 +48,7 @@
{
bool did_something = false;
bool alignment_changed = false;
-@@ -3945,7 +3947,7 @@
+@@ -3945,7 +3949,7 @@ bool CH2L::openTableDimensionsFile()
mTableDimensionsFileName = tsp;
mTableDimensionsFile.open(tsp.c_str());
diff --git a/textproc/htmltolatex/files/patch-util.cpp b/textproc/htmltolatex/files/patch-util.cpp
index 2e942e4a33a4..caf73dbacd58 100644
--- a/textproc/htmltolatex/files/patch-util.cpp
+++ b/textproc/htmltolatex/files/patch-util.cpp
@@ -1,6 +1,6 @@
---- util.cpp.orig Fri Feb 21 03:47:33 2003
-+++ util.cpp Fri Feb 21 03:47:46 2003
-@@ -18,6 +18,9 @@
+--- util.cpp.orig 2001-10-10 12:24:27 UTC
++++ util.cpp
+@@ -18,9 +18,13 @@
* Boston, MA 02111-1307, USA.
*
*/
@@ -10,7 +10,11 @@
#include "util.h"
#include <map>
#include <ctype.h>
-@@ -35,7 +38,6 @@
++#include <cstring>
+ #include <sys/param.h>
+ #include <stdio.h>
+ #include <unistd.h>
+@@ -35,7 +39,6 @@ extern "C"{
#include "fetch.h"
}
#endif