aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmltolatex
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-20 18:37:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-20 18:37:32 +0000
commit1a9e1e1835f8fb6ea4fd146025244e0c82c52f98 (patch)
treeec2d01c51f262425020fb588df1a7d846eb8b59d /textproc/htmltolatex
parent57f48687c54f8871cb352f24198a8c0d88a95231 (diff)
Notes
Diffstat (limited to 'textproc/htmltolatex')
-rw-r--r--textproc/htmltolatex/Makefile33
-rw-r--r--textproc/htmltolatex/distinfo1
-rw-r--r--textproc/htmltolatex/files/patch-h2l.l11
-rw-r--r--textproc/htmltolatex/pkg-comment1
-rw-r--r--textproc/htmltolatex/pkg-descr4
-rw-r--r--textproc/htmltolatex/pkg-plist3
6 files changed, 53 insertions, 0 deletions
diff --git a/textproc/htmltolatex/Makefile b/textproc/htmltolatex/Makefile
new file mode 100644
index 000000000000..b6b9b52d9008
--- /dev/null
+++ b/textproc/htmltolatex/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: htmltolatex
+# Date created: Jan 19, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmltolatex
+PORTVERSION= 1
+CATEGORIES= textproc
+MASTER_SITES= http://66.108.152.41/~nradisch/docgen/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= Magick:${PORTSDIR}/graphics/ImageMagick
+
+USE_BISON= yes
+MAKEFILE= GNUmakefile
+CXXFLAGS+= -I${LOCALBASE}/include -DUNIX
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^CXXFLAGS,#CXXFLAGS,g ; \
+ s,^CXX,#CXX,g" ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/h2l ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/nmr.tex ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/htmltolatex/distinfo b/textproc/htmltolatex/distinfo
new file mode 100644
index 000000000000..c820cbb78834
--- /dev/null
+++ b/textproc/htmltolatex/distinfo
@@ -0,0 +1 @@
+MD5 (htmltolatex.tar.gz) = aec7a4682c97b42481af9b4321a8600e
diff --git a/textproc/htmltolatex/files/patch-h2l.l b/textproc/htmltolatex/files/patch-h2l.l
new file mode 100644
index 000000000000..c37e6e01c41a
--- /dev/null
+++ b/textproc/htmltolatex/files/patch-h2l.l
@@ -0,0 +1,11 @@
+--- h2l.l.orig Sun Jan 20 14:47:49 2002
++++ h2l.l Sun Jan 20 14:47:56 2002
+@@ -2,7 +2,7 @@
+ #include "CLexData.h"
+ #define YYSTYPE CLexDataPtr
+
+-#include "h2l.tab.cpp.h"
++#include "h2l.tab.hpp"
+ #include "CH2L.h"
+ #include "util.h"
+ #include <assert.h>
diff --git a/textproc/htmltolatex/pkg-comment b/textproc/htmltolatex/pkg-comment
new file mode 100644
index 000000000000..a9125ca2c00c
--- /dev/null
+++ b/textproc/htmltolatex/pkg-comment
@@ -0,0 +1 @@
+HTML to LaTeX to PDF Converter
diff --git a/textproc/htmltolatex/pkg-descr b/textproc/htmltolatex/pkg-descr
new file mode 100644
index 000000000000..851fdb9a6a5a
--- /dev/null
+++ b/textproc/htmltolatex/pkg-descr
@@ -0,0 +1,4 @@
+This HTML to LaTeX converter attempts to handle all aspects of HTML and
+style sheets. It works with images, tables, alignments, fonts, etc.
+
+WWW: http://66.108.152.41/~nradisch/docgen/
diff --git a/textproc/htmltolatex/pkg-plist b/textproc/htmltolatex/pkg-plist
new file mode 100644
index 000000000000..4ab29a6c4649
--- /dev/null
+++ b/textproc/htmltolatex/pkg-plist
@@ -0,0 +1,3 @@
+bin/h2l
+share/htmltolatex/nmr.tex
+@dirrm share/htmltolatex