aboutsummaryrefslogtreecommitdiff
path: root/textproc/humanzip/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-24 14:42:35 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-24 14:42:35 +0000
commitcaca19fd67640de8a0bfe9a744caf766bbc88bbe (patch)
tree87d38f83960c4015e82821e1c86614db54ab4115 /textproc/humanzip/Makefile
parent13168778aa32e55c1bb76e0502d18d928d2f0509 (diff)
downloadports-caca19fd67640de8a0bfe9a744caf766bbc88bbe.tar.gz
ports-caca19fd67640de8a0bfe9a744caf766bbc88bbe.zip
Notes
Diffstat (limited to 'textproc/humanzip/Makefile')
-rw-r--r--textproc/humanzip/Makefile31
1 files changed, 18 insertions, 13 deletions
diff --git a/textproc/humanzip/Makefile b/textproc/humanzip/Makefile
index 143d2b506060..4c0fa683075c 100644
--- a/textproc/humanzip/Makefile
+++ b/textproc/humanzip/Makefile
@@ -9,22 +9,27 @@ MASTER_SITES= SAVANNAH CENKES
MAINTAINER= ports@FreeBSD.org
COMMENT= Compresses text to human readable output
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|g++|${CXX}|;s|-O2|${CFLAGS}|' \
- ${WRKSRC}/${MAKEFILE}
+LICENSE= GPLv2 # (or later)
-MAN1= ${PORTNAME}.1
-MLINKS= ${PORTNAME}.1 humanunzip.1
-PLIST_FILES= bin/${PORTNAME} bin/humanunzip
PORTDOCS= CHANGELOG README TODO
+PLIST_FILES= bin/humanunzip bin/humanzip \
+ man/man1/humanunzip.1.gz man/man1/humanzip.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|g++|$${CXX}| ; \
+ s|-O2|$${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/human*zip ${PREFIX}/bin/
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
-.ifndef NOPORTDOCS
- @${INSTALL} -d ${DOCSDIR}/
- @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
-.endif
+.for i in humanzip humanunzip
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${i} ${STAGEDIR}${PREFIX}/bin)
+.endfor
+ (cd ${WRKSRC} && ${INSTALL_MAN} humanzip.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1)
+ ${LN} -sf humanzip.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/humanunzip.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${PORTDOCS}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
+.endfor
.include <bsd.port.mk>