aboutsummaryrefslogtreecommitdiff
path: root/textproc/hunspell/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-05-20 14:52:50 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-05-20 14:52:50 +0000
commit0e8d24bf420689751b8dc250b796756b88b6dcef (patch)
treef84f97599e5c94004c70a23136cab15020289b91 /textproc/hunspell/Makefile
parentd7c7a482a82f6a63381543ddd032857eb085195a (diff)
downloadports-0e8d24bf420689751b8dc250b796756b88b6dcef.tar.gz
ports-0e8d24bf420689751b8dc250b796756b88b6dcef.zip
Notes
Diffstat (limited to 'textproc/hunspell/Makefile')
-rw-r--r--textproc/hunspell/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
new file mode 100644
index 000000000000..2ed8495310e4
--- /dev/null
+++ b/textproc/hunspell/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: hunspell
+# Date created: 24.07.2004
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= hunspell
+PORTVERSION= 0.9.7
+CATEGORIES= hungarian textproc
+#MASTER_SITES= http://www.szofi.hu/gnu/magyarispell/
+MASTER_SITES= http://magyarispell.sourceforge.net/
+
+MAINTAINER= Janos.Mohacsi@bsd.hu
+COMMENT= Improved Hungarian spelling checker
+
+USE_GMAKE= yes
+USE_GCC= 3.3
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+
+MAN1= hunspell.1
+MAN4= hunspell.4
+
+PORTDOCS= OLVASS.EL README README.myspell
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD-4.x at this time"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/hunspell.cxx
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/man/hunspell.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/hunspell.4 ${PREFIX}/man/man4
+ ${INSTALL_PROGRAM} ${WRKSRC}/hunspell ${PREFIX}/bin
+ ${LN} -s ${PREFIX}/bin/hunspell ${PREFIX}/bin/hunstem
+ ${MKDIR} ${PREFIX}/share/myspell/ && \
+ ${INSTALL_DATA} ${WRKSRC}/hu_HU.dic \
+ ${PREFIX}/share/myspell/ && \
+ ${INSTALL_DATA} ${WRKSRC}/hu_HU.aff \
+ ${PREFIX}/share/myspell/
+ ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/magyar.dic
+ ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/hungarian.dic
+ ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/default.dic
+ ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/magyar.aff
+ ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/hungarian.aff
+ ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/default.aff
+ ${INSTALL_DATA} ${WRKSRC}/dictionary.lst \
+ ${PREFIX}/share/myspell/default.lst
+ ${LOCALBASE}/bin/msgfmt -o ${WRKSRC}/hunspell.mo ${WRKSRC}/hunspell.po
+ ${MKDIR} ${PREFIX}/share/locale/hu/LC_MESSAGES/ && \
+ ${INSTALL_DATA} ${WRKSRC}/hunspell.mo ${PREFIX}/share/locale/hu/LC_MESSAGES/
+
+.ifndef(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>