aboutsummaryrefslogtreecommitdiff
path: root/textproc/hyperestraier
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-12-08 13:16:35 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-12-08 13:16:35 +0000
commitb1d8083cbe96683f501c64f9b46d14bb38cb9e46 (patch)
tree0ff2fac0998a7923ff11c0bde4342d31fbb35459 /textproc/hyperestraier
parent7ba00ff677a6ceefc19347dc7343ed67b3344b86 (diff)
downloadports-b1d8083cbe96683f501c64f9b46d14bb38cb9e46.tar.gz
ports-b1d8083cbe96683f501c64f9b46d14bb38cb9e46.zip
Notes
Diffstat (limited to 'textproc/hyperestraier')
-rw-r--r--textproc/hyperestraier/Makefile26
1 files changed, 22 insertions, 4 deletions
diff --git a/textproc/hyperestraier/Makefile b/textproc/hyperestraier/Makefile
index 78802619bc72..8a3bcb3512e9 100644
--- a/textproc/hyperestraier/Makefile
+++ b/textproc/hyperestraier/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hyperestraier
PORTVERSION= 1.4.9
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,16 +22,33 @@ LIB_DEPENDS= qdbm.14:${PORTSDIR}/databases/qdbm
USE_ICONV= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-bzip2 --disable-zlib
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-MAN1= estcall.1 estcmd.1 estconfig.1 estmaster.1 estwaver.1
-MAN3= estnode.3 estraier.3
+OPTIONS= LZO "Enable lzo support" off \
+ MECAB "Enable mecab support" off
+
+MAN1= estcall.1 estcmd.1 estconfig.1 estmaster.1 estwaver.1
+MAN3= estnode.3 estraier.3
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LZO)
+CONFIGURE_ARGS+= --enable-lzo
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+.endif
+
+.if defined(WITH_MECAB)
+CONFIGURE_ARGS+= --enable-mecab
+LIB_DEPENDS+= mecab:${PORTSDIR}/japanese/mecab
+RUN_DEPENDS+= ${LOCALBASE}/lib/mecab/dic/ipadic/matrix.bin:${PORTSDIR}/japanese/mecab-ipadic
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
${RM} -f ${WRKSRC}/doc/intro-en.html~ ${WRKSRC}/doc/intro-ja.html~
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>