aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus-el
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2010-07-04 10:01:00 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2010-07-04 10:01:00 +0000
commit99fb43099090030ffe40081db7a266e837deb40e (patch)
tree33751d4557c54497331b5ab025b595c912c71b76 /textproc/ibus-el
parente7efe1f8518ca256b039e9fec0c6f1764767b428 (diff)
downloadports-99fb43099090030ffe40081db7a266e837deb40e.tar.gz
ports-99fb43099090030ffe40081db7a266e837deb40e.zip
Notes
Diffstat (limited to 'textproc/ibus-el')
-rw-r--r--textproc/ibus-el/Makefile50
-rw-r--r--textproc/ibus-el/distinfo3
-rw-r--r--textproc/ibus-el/pkg-descr7
3 files changed, 60 insertions, 0 deletions
diff --git a/textproc/ibus-el/Makefile b/textproc/ibus-el/Makefile
new file mode 100644
index 000000000000..29247f4f36c3
--- /dev/null
+++ b/textproc/ibus-el/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ibus-el
+# Date created: 4 July 2010
+# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibus-el
+PORTVERSION= 0.1.1
+#PORTREVISION= 0
+CATEGORIES= textproc elisp
+MASTER_SITES= http://www11.atwiki.jp/s-irie/pub/emacs/ibus/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= IBus client for GNU Emacs
+
+RUN_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus \
+ ${PYTHON_SITELIBDIR}/Xlib/X.py:${PORTSDIR}/x11-toolkits/py-xlib
+
+USE_EMACS= yes
+USE_PYTHON_RUN= yes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/doc/COPYING
+
+PLIST_DIRS= ${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME} share/${PORTNAME}
+PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}/ibus.el \
+ ${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}/ibus.elc \
+ share/${PORTNAME}/ibus-el-agent
+PORTDOCS= README
+
+do-build:
+ @cd ${WRKSRC} && ${EMACS_CMD} -batch -q -no-site-file -no-init-file \
+ -f batch-byte-compile ibus.el
+
+do-install:
+ @${MKDIR} ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/ibus.el \
+ ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/ibus.elc \
+ ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+ @${INSTALL_SCRIPT} ${WRKSRC}/ibus-el-agent ${PREFIX}/share/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ibus-el/distinfo b/textproc/ibus-el/distinfo
new file mode 100644
index 000000000000..3ec34d4c917e
--- /dev/null
+++ b/textproc/ibus-el/distinfo
@@ -0,0 +1,3 @@
+MD5 (ibus-el-0.1.1.tar.gz) = 09d8ebb97c9fa20a134b6c58e53af66e
+SHA256 (ibus-el-0.1.1.tar.gz) = de0762cce9e177db965dde1af6808e407c7b89094581999dc6878698551ee18a
+SIZE (ibus-el-0.1.1.tar.gz) = 46810
diff --git a/textproc/ibus-el/pkg-descr b/textproc/ibus-el/pkg-descr
new file mode 100644
index 000000000000..cc39e1a5559f
--- /dev/null
+++ b/textproc/ibus-el/pkg-descr
@@ -0,0 +1,7 @@
+ibus.el is IBus client for GNU Emacs. ibus.el provides ibus-mode
+minor mode, which allows users on-the-spot style input with IBus on
+Emacs. The input statuses are individually kept for each buffer, and
+prefix-keys such as C-x and C-c can be used even if IBus is active.
+So you can input various languages fast and comfortably.
+
+WWW: http://www.emacswiki.org/emacs/IBusMode