aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus-table/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-17 05:04:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-17 05:04:48 +0000
commit4bcac3c77f783062d7110034ed9d703870c55e5c (patch)
treec832ca73b0927287da13cd7558fad1882386a0b7 /textproc/ibus-table/Makefile
parent04b06643e4eea18b0a7b75f9d8e5824ce37013d9 (diff)
downloadports-4bcac3c77f783062d7110034ed9d703870c55e5c.tar.gz
ports-4bcac3c77f783062d7110034ed9d703870c55e5c.zip
Notes
Diffstat (limited to 'textproc/ibus-table/Makefile')
-rw-r--r--textproc/ibus-table/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/ibus-table/Makefile b/textproc/ibus-table/Makefile
new file mode 100644
index 000000000000..f8fcc28c4d52
--- /dev/null
+++ b/textproc/ibus-table/Makefile
@@ -0,0 +1,38 @@
+# Created by: Nikola Lecic <nikola.lecic@anthesphoria.net>
+# $FreeBSD$
+
+PORTNAME= ibus-table
+DISTVERSION= 1.9.18
+CATEGORIES= textproc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Table-based input method framework for IBus
+
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ docbook2man:textproc/docbook-utils \
+ docbook-sgml>0:textproc/docbook-sgml
+LIB_DEPENDS= libibus-1.0.so:textproc/ibus
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+
+USES= autoreconf gmake pkgconfig python:3.4+
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= kaio
+USE_GNOME= pygtk2
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/|${PREFIX}/|g" ${WRKSRC}/engine/*.py
+
+post-install:
+ @${RM} -r ${STAGEDIR}${DATADIR}/*/__pycache__
+
+.include <bsd.port.mk>