aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus/Makefile
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-03-09 06:07:50 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-03-09 06:07:50 +0000
commit55d57449d65b529bdd31302dc1a246822b951403 (patch)
tree84fc0caf7c5857f5a7155135ad8cf414540e4bb9 /textproc/ibus/Makefile
parent1cdf27a251475e3ac141b60b2636fb715fa164af (diff)
Notes
Diffstat (limited to 'textproc/ibus/Makefile')
-rw-r--r--textproc/ibus/Makefile101
1 files changed, 50 insertions, 51 deletions
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index 69e38a3b5c20..af11cb1e13dd 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ibus
-PORTVERSION= 1.5.23
-PORTREVISION= 2
+PORTVERSION= 1.5.24
CATEGORIES= textproc
MAINTAINER= henry.hu.sh@gmail.com
@@ -21,87 +20,87 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:devel/py-dbus@${PY_FLAVOR} \
${LOCALBASE}/share/xml/iso-codes/iso_639.xml:misc/iso-codes \
setxkbmap:x11/setxkbmap
-USES= autoreconf compiler cpe gmake gnome libtool localbase pathfix pkgconfig python:3.5+ shebangfix
+USES= autoreconf compiler cpe gmake gnome libtool localbase \
+ pathfix pkgconfig python:3.5+ shebangfix
+CPE_VENDOR= ibus_project
+USE_GITHUB= yes
USE_GNOME= glib20 intltool librsvg2 pygobject3
+INSTALLS_ICONS= yes
USE_LDCONFIG= yes
USE_PYTHON= py3kplist
-MAKE_JOBS_UNSAFE=yes
SHEBANG_GLOB= *.sh
-USE_GITHUB= yes
GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-OPTIONS_SUB= yes
-INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--with-ucd-dir=${LOCALBASE}/share/unicode/ucd \
- --disable-python2 --disable-python-library
+ --disable-python2 --disable-python-library \
+ --disable-gtk4
+
+MAKE_JOBS_UNSAFE=yes
+INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= NLS GTK2 GTK3 VALA GINTRO DOCS XIM ENGINE EMOJI
+OPTIONS_DEFINE= ENGINE VALA GTK2 GTK3 GINTRO XIM EMOJI DOCS NLS WAYLAND
+OPTIONS_DEFAULT= GTK2 GTK3 VALA GINTRO DCONF XIM ENGINE EMOJI
OPTIONS_RADIO= CONFIG
OPTIONS_RADIO_CONFIG= GCONF DCONF
-OPTIONS_DEFAULT= GTK2 GTK3 VALA GINTRO DCONF XIM ENGINE EMOJI
+NO_OPTIONS_SORT= yes
+OPTIONS_SUB= yes
+DCONF_DESC= Use dconf for configuration
+EMOJI_DESC= Install emoji dictionary
+ENGINE_DESC= Install ibus simple engine
+GCONF_DESC= Use GConf for configuration
+GINTRO_DESC= Install GObject Introspection data
GTK2_DESC= Install GTK2 client
GTK3_DESC= Install GTK3 client and panel
VALA_DESC= Install vala binding
-GINTRO_DESC= Install GObject Introspection data
-GCONF_DESC= Use GConf for configuration
-DCONF_DESC= Use dconf for configuration
+WAYLAND_DESC= Enable Wayland support
XIM_DESC= Install XIM server
-ENGINE_DESC= Install ibus simple engine
-EMOJI_DESC= Install emoji dictionary
-CPE_VENDOR= ibus_project
-NLS_USES= gettext
-NLS_USES_OFF= gettext-tools
-NLS_CONFIGURE_ENABLE= nls
-
-GTK2_USE= GNOME=cairo,gtk20
-GTK2_CONFIGURE_ENABLE= gtk2
+DCONF_USE= GNOME=dconf
+DCONF_CONFIGURE_ENABLE= dconf
+DCONF_VARS= GLIB_SCHEMAS=org.freedesktop.ibus.gschema.xml
+DOCS_CONFIGURE_ENABLE= gtk-doc-html
+EMOJI_BUILD_DEPENDS= json-glib>=0:devel/json-glib \
+ unicode-emoji>0:misc/unicode-emoji \
+ cldr-emoji-annotation>0:misc/cldr-emoji-annotation
+EMOJI_CONFIGURE_ON= --with-unicode-emoji-dir=${LOCALBASE}/share/unicode/emoji \
+ --with-emoji-annotation-dir=${LOCALBASE}/share/unicode/cldr/common/annotations
+EMOJI_CONFIGURE_ENABLE= emoji-dict
+ENGINE_CONFIGURE_ENABLE= engine
+GCONF_USE= GNOME=gconf2
+GCONF_CONFIGURE_ENABLE= gconf
+GCONF_VARS= GCONF_SCHEMAS=ibus.schemas
+GINTRO_BUILD_DEPENDS= gobject-introspection>=0.6.8:devel/gobject-introspection
+GINTRO_RUN_DEPENDS= gobject-introspection>=0.6.8:devel/gobject-introspection
+GINTRO_CONFIGURE_ENABLE= introspection
GTK2_LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-
+GTK2_USE= GNOME=cairo,gtk20
+GTK2_CONFIGURE_ENABLE= gtk2
+GTK3_LIB_DEPENDS= libdbus-1.so:devel/dbus \
+ libnotify.so:devel/libnotify
GTK3_USES= xorg
GTK3_USE= GNOME=cairo,gtk30 XORG=x11,xi
GTK3_CONFIGURE_ENABLE= gtk3 libnotify
-GTK3_LIB_DEPENDS= libdbus-1.so:devel/dbus \
- libnotify.so:devel/libnotify
GTK3_LIBS= -lX11
-
+NLS_USES= gettext
+NLS_USES_OFF= gettext-tools
+NLS_CONFIGURE_ENABLE= nls
+VALA_IMPLIES= GINTRO
VALA_BUILD_DEPENDS= vala>=0.20:lang/vala
VALA_CONFIGURE_ENABLE= vala
-VALA_IMPLIES= GINTRO
-
-GINTRO_BUILD_DEPENDS= gobject-introspection>=0.6.8:devel/gobject-introspection
-GINTRO_RUN_DEPENDS= gobject-introspection>=0.6.8:devel/gobject-introspection
-GINTRO_CONFIGURE_ENABLE= introspection
-
-GCONF_USE= GNOME=gconf2
-GCONF_CONFIGURE_ENABLE= gconf
-GCONF_VARS= GCONF_SCHEMAS=ibus.schemas
-
-DCONF_USE= GNOME=dconf
-DCONF_CONFIGURE_ENABLE= dconf
-DCONF_VARS= GLIB_SCHEMAS=org.freedesktop.ibus.gschema.xml
-
-DOCS_CONFIGURE_ENABLE= gtk-doc-html
-
+WAYLAND_BUILD_DEPENDS= wayland>1.14:graphics/wayland
+WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+WAYLAND_CONFIGURE_ENABLE= wayland
XIM_CONFIGURE_ENABLE= xim
-ENGINE_CONFIGURE_ENABLE= engine
-
EMOJIONE_TAG= ba845a7e24aac26cf3cf22abc19bea215d94fbf3 # 2.2.7
-EMOJI_CONFIGURE_ON= --with-unicode-emoji-dir=${LOCALBASE}/share/unicode/emoji \
- --with-emoji-annotation-dir=${LOCALBASE}/share/unicode/cldr/common/annotations
-EMOJI_CONFIGURE_ENABLE= emoji-dict
-EMOJI_BUILD_DEPENDS= json-glib>=0:devel/json-glib \
- unicode-emoji>0:misc/unicode-emoji \
- cldr-emoji-annotation>0:misc/cldr-emoji-annotation
.include <bsd.port.pre.mk>