aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-08 08:03:15 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-08 08:03:15 +0000
commit8f3ed402289aff90928ba7bba6f6266d692e2c29 (patch)
tree2c020addd65252b0a8bdf0349827dffa333bc951 /textproc/ibus
parentf560dc283a7e97dc2f9933eafa4d651ea6cc2a29 (diff)
downloadports-8f3ed402289aff90928ba7bba6f6266d692e2c29.tar.gz
ports-8f3ed402289aff90928ba7bba6f6266d692e2c29.zip
Notes
Diffstat (limited to 'textproc/ibus')
-rw-r--r--textproc/ibus/Makefile21
-rw-r--r--textproc/ibus/distinfo4
-rw-r--r--textproc/ibus/pkg-message1
-rw-r--r--textproc/ibus/pkg-plist294
4 files changed, 167 insertions, 153 deletions
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index 070c35cac50b..bdb32727fb75 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ibus
-PORTVERSION= 1.3.9
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -20,10 +19,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify \
${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
librsvg2>=2.0:${PORTSDIR}/graphics/librsvg2
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
USE_PYTHON= yes
USE_GNOME= pygtk2 gconf2
-USE_QT_VER= 4
USE_LDCONFIG= yes
USE_GMAKE= yes
@@ -32,6 +31,7 @@ INSTALLS_ICONS= yes
GCONF_SCHEMAS= ibus.schemas
OPTIONS= ISOCODES "Use isocodecs" on \
+ GTK3 "Install GTK3 client" on \
VALA "Install vala binding" on \
GINTRO "Install GObject Introspection data" on
@@ -53,6 +53,14 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if defined(WITHOUT_GTK3)
+CONFIGURE_ARGS+= --disable-gtk3
+PLIST_SUB+= GTK3="@comment "
+.else
+USE_GNOME+= gtk30
+PLIST_SUB+= GTK3=""
+.endif
+
.if defined(WITH_VALA)
CONFIGURE_ARGS+= --enable-vala
PLIST_SUB+= VALA=""
@@ -78,13 +86,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|locale.bind_textdomain_codeset|gettext.bind_textdomain_codeset|g' ${WRKSRC}/ui/gtk/main.py
@${REINPLACE_CMD} -e 's|import locale|import gettext|g' ${WRKSRC}/ui/gtk/main.py
@${REINPLACE_CMD} -e 's|setpgrp ()|setpgrp (0,0)|g' ${WRKSRC}/bus/main.c
+ @${REINPLACE_CMD} -e 's|/var/lib/dbus|/var/db/dbus|g' ${WRKSRC}/src/ibusshare.c #devel/dbus/files/dbus.in
post-install:
+. if defined(WITH_GTK3)
+ @gtk-query-immodules-3.0 --update-cache
+. endif
@gtk-query-immodules-2.0 > ${LOCALBASE}/etc/gtk-2.0/gtk.immodules
@${CAT} ${PKGMESSAGE}
@${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
-post-deinstall:
- @gtk-query-immodules-2.0 > ${LOCALBASE}/etc/gtk-2.0/gtk.immodules
-
.include <bsd.port.post.mk>
diff --git a/textproc/ibus/distinfo b/textproc/ibus/distinfo
index 8ee42ef5802a..0ac021113e87 100644
--- a/textproc/ibus/distinfo
+++ b/textproc/ibus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ibus-1.3.9.tar.gz) = b2784a668666efa8ae04e6f1cff5749917cd18add0a39a1d020ecc9f3df5285d
-SIZE (ibus-1.3.9.tar.gz) = 1380081
+SHA256 (ibus-1.4.0.tar.gz) = 9e5a17d910eae932dd0cd185d0a102b56ad4a2bf79d54b1e53f70174cd2c2a3f
+SIZE (ibus-1.4.0.tar.gz) = 1452055
diff --git a/textproc/ibus/pkg-message b/textproc/ibus/pkg-message
index 30c1bbe3213f..8d17fe5690cb 100644
--- a/textproc/ibus/pkg-message
+++ b/textproc/ibus/pkg-message
@@ -35,6 +35,7 @@ Following input methods/engines are available in ports:
chinese/ibus-chewing Chewing engine for IBus
chinese/ibus-pinyin The PinYin input method
japanese/ibus-anthy Anthy engine for IBus
+japanese/ibus-mozc Mozc engine for IBus
japanese/ibus-skk SKK engine for IBus
textproc/ibus-kmfl KMFL IMEngine for IBus framework
textproc/ibus-m17n The m17n IMEngine for IBus framework
diff --git a/textproc/ibus/pkg-plist b/textproc/ibus/pkg-plist
index f8c572c554ff..bddfd6204af8 100644
--- a/textproc/ibus/pkg-plist
+++ b/textproc/ibus/pkg-plist
@@ -1,92 +1,47 @@
-%%DATADIR%%/component/gconf.xml
-%%DATADIR%%/component/gtkpanel.xml
-%%DATADIR%%/keymaps/common
-%%DATADIR%%/keymaps/jp
-%%DATADIR%%/keymaps/kr
-%%DATADIR%%/keymaps/modifiers
-%%DATADIR%%/keymaps/us
-%%DATADIR%%/setup/engineabout.py
-%%DATADIR%%/setup/engineabout.pyc
-%%DATADIR%%/setup/engineabout.pyo
-%%DATADIR%%/setup/enginecombobox.py
-%%DATADIR%%/setup/enginecombobox.pyc
-%%DATADIR%%/setup/enginecombobox.pyo
-%%DATADIR%%/setup/enginetreeview.py
-%%DATADIR%%/setup/enginetreeview.pyc
-%%DATADIR%%/setup/enginetreeview.pyo
-%%DATADIR%%/setup/icon.py
-%%DATADIR%%/setup/icon.pyc
-%%DATADIR%%/setup/icon.pyo
-%%DATADIR%%/setup/keyboardshortcut.py
-%%DATADIR%%/setup/keyboardshortcut.pyc
-%%DATADIR%%/setup/keyboardshortcut.pyo
-%%DATADIR%%/setup/main.py
-%%DATADIR%%/setup/main.pyc
-%%DATADIR%%/setup/main.pyo
-%%DATADIR%%/setup/setup.ui
-%%DATADIR%%/ui/gtk/candidatepanel.py
-%%DATADIR%%/ui/gtk/candidatepanel.pyc
-%%DATADIR%%/ui/gtk/candidatepanel.pyo
-%%DATADIR%%/ui/gtk/engineabout.py
-%%DATADIR%%/ui/gtk/engineabout.pyc
-%%DATADIR%%/ui/gtk/engineabout.pyo
-%%DATADIR%%/ui/gtk/handle.py
-%%DATADIR%%/ui/gtk/handle.pyc
-%%DATADIR%%/ui/gtk/handle.pyo
-%%DATADIR%%/ui/gtk/icon.py
-%%DATADIR%%/ui/gtk/icon.pyc
-%%DATADIR%%/ui/gtk/icon.pyo
-%%DATADIR%%/ui/gtk/languagebar.py
-%%DATADIR%%/ui/gtk/languagebar.pyc
-%%DATADIR%%/ui/gtk/languagebar.pyo
-%%DATADIR%%/ui/gtk/main.py
-%%DATADIR%%/ui/gtk/main.pyc
-%%DATADIR%%/ui/gtk/main.pyo
-%%DATADIR%%/ui/gtk/menu.py
-%%DATADIR%%/ui/gtk/menu.pyc
-%%DATADIR%%/ui/gtk/menu.pyo
-%%DATADIR%%/ui/gtk/notifications.py
-%%DATADIR%%/ui/gtk/notifications.pyc
-%%DATADIR%%/ui/gtk/notifications.pyo
-%%DATADIR%%/ui/gtk/panel.py
-%%DATADIR%%/ui/gtk/panel.pyc
-%%DATADIR%%/ui/gtk/panel.pyo
-%%DATADIR%%/ui/gtk/propitem.py
-%%DATADIR%%/ui/gtk/propitem.pyc
-%%DATADIR%%/ui/gtk/propitem.pyo
-%%DATADIR%%/ui/gtk/toolitem.py
-%%DATADIR%%/ui/gtk/toolitem.pyc
-%%DATADIR%%/ui/gtk/toolitem.pyo
-%%NLS%%share/locale/ar/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/as/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/bn_IN/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/da/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/de/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/es/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/gu/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/hi/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/it/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/kn/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/ml/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/mr/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/or/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/pa/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/sr@latin/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/ta/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/te/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus.mo
+bin/ibus-daemon
+bin/ibus-setup
+include/ibus-1.0/ibus.h
+include/ibus-1.0/ibusattribute.h
+include/ibus-1.0/ibusattrlist.h
+include/ibus-1.0/ibusbus.h
+include/ibus-1.0/ibuscomponent.h
+include/ibus-1.0/ibusconfig.h
+include/ibus-1.0/ibusconfigservice.h
+include/ibus-1.0/ibusdebug.h
+include/ibus-1.0/ibusengine.h
+include/ibus-1.0/ibusenginedesc.h
+include/ibus-1.0/ibusenumtypes.h
+include/ibus-1.0/ibuserror.h
+include/ibus-1.0/ibusfactory.h
+include/ibus-1.0/ibushotkey.h
+include/ibus-1.0/ibusinputcontext.h
+include/ibus-1.0/ibuskeymap.h
+include/ibus-1.0/ibuskeys.h
+include/ibus-1.0/ibuskeysyms.h
+include/ibus-1.0/ibuslookuptable.h
+include/ibus-1.0/ibusobject.h
+include/ibus-1.0/ibusobservedpath.h
+include/ibus-1.0/ibuspanelservice.h
+include/ibus-1.0/ibusproperty.h
+include/ibus-1.0/ibusproplist.h
+include/ibus-1.0/ibusproxy.h
+include/ibus-1.0/ibusserializable.h
+include/ibus-1.0/ibusservice.h
+include/ibus-1.0/ibusshare.h
+include/ibus-1.0/ibustext.h
+include/ibus-1.0/ibustypes.h
+include/ibus-1.0/ibusutil.h
+include/ibus-1.0/ibusversion.h
+include/ibus-1.0/ibusxml.h
+lib/gtk-2.0/2.10.0/immodules/im-ibus.la
+lib/gtk-2.0/2.10.0/immodules/im-ibus.so
+%%GINTRO%%lib/girepository-1.0/IBus-1.0.typelib
+%%GINTRO%%share/gir-1.0/IBus-1.0.gir
+%%GTK3%%lib/gtk-3.0/3.0.0/immodules/im-ibus.la
+%%GTK3%%lib/gtk-3.0/3.0.0/immodules/im-ibus.so
+lib/libibus-1.0.la
+lib/libibus-1.0.so
+lib/libibus-1.0.so.400
%%PYTHON_SITELIBDIR%%/ibus/__init__.py
%%PYTHON_SITELIBDIR%%/ibus/__init__.pyc
%%PYTHON_SITELIBDIR%%/ibus/__init__.pyo
@@ -192,54 +147,6 @@
%%PYTHON_SITELIBDIR%%/ibus/utility.py
%%PYTHON_SITELIBDIR%%/ibus/utility.pyc
%%PYTHON_SITELIBDIR%%/ibus/utility.pyo
-bin/ibus-daemon
-bin/ibus-setup
-etc/xdg/autostart/ibus.desktop
-include/ibus-1.0/ibus.h
-include/ibus-1.0/ibusattribute.h
-include/ibus-1.0/ibusattrlist.h
-include/ibus-1.0/ibusbus.h
-include/ibus-1.0/ibuscomponent.h
-include/ibus-1.0/ibusconfig.h
-include/ibus-1.0/ibusconfigservice.h
-include/ibus-1.0/ibusconnection.h
-include/ibus-1.0/ibusdebug.h
-include/ibus-1.0/ibusdbus.h
-include/ibus-1.0/ibusengine.h
-include/ibus-1.0/ibusenginedesc.h
-include/ibus-1.0/ibusenumtypes.h
-include/ibus-1.0/ibuserror.h
-include/ibus-1.0/ibusfactory.h
-include/ibus-1.0/ibushotkey.h
-include/ibus-1.0/ibusinputcontext.h
-include/ibus-1.0/ibuskeymap.h
-include/ibus-1.0/ibuskeysyms.h
-include/ibus-1.0/ibuslookuptable.h
-include/ibus-1.0/ibusmainloop.h
-include/ibus-1.0/ibusmarshalers.h
-include/ibus-1.0/ibusmessage.h
-include/ibus-1.0/ibusobject.h
-include/ibus-1.0/ibusobservedpath.h
-include/ibus-1.0/ibuspanelservice.h
-include/ibus-1.0/ibuspendingcall.h
-include/ibus-1.0/ibusproperty.h
-include/ibus-1.0/ibusproplist.h
-include/ibus-1.0/ibusproxy.h
-include/ibus-1.0/ibusserializable.h
-include/ibus-1.0/ibusserver.h
-include/ibus-1.0/ibusservice.h
-include/ibus-1.0/ibusshare.h
-include/ibus-1.0/ibustext.h
-include/ibus-1.0/ibustypes.h
-include/ibus-1.0/ibusversion.h
-include/ibus-1.0/ibusxml.h
-lib/gtk-2.0/2.10.0/immodules/im-ibus.la
-lib/gtk-2.0/2.10.0/immodules/im-ibus.so
-lib/libibus.la
-lib/libibus.so
-lib/libibus.so.2
-%%GINTRO%%lib/girepository-1.0/IBus-1.0.typelib
-%%GINTRO%%share/gir-1.0/IBus-1.0.gir
libdata/pkgconfig/ibus-1.0.pc
libexec/ibus-gconf
libexec/ibus-ui-gtk
@@ -252,7 +159,6 @@ share/gtk-doc/html/ibus/IBusBus.html
share/gtk-doc/html/ibus/IBusComponent.html
share/gtk-doc/html/ibus/IBusConfig.html
share/gtk-doc/html/ibus/IBusConfigService.html
-share/gtk-doc/html/ibus/IBusConnection.html
share/gtk-doc/html/ibus/IBusEngine.html
share/gtk-doc/html/ibus/IBusEngineDesc.html
share/gtk-doc/html/ibus/IBusFactory.html
@@ -267,7 +173,6 @@ share/gtk-doc/html/ibus/IBusPropList.html
share/gtk-doc/html/ibus/IBusProperty.html
share/gtk-doc/html/ibus/IBusProxy.html
share/gtk-doc/html/ibus/IBusSerializable.html
-share/gtk-doc/html/ibus/IBusServer.html
share/gtk-doc/html/ibus/IBusService.html
share/gtk-doc/html/ibus/IBusText.html
share/gtk-doc/html/ibus/ch01.html
@@ -278,11 +183,8 @@ share/gtk-doc/html/ibus/ch05.html
share/gtk-doc/html/ibus/ch06.html
share/gtk-doc/html/ibus/home.png
share/gtk-doc/html/ibus/ibus-IBusKeysyms.html
-share/gtk-doc/html/ibus/ibus-IBusMessage.html
-share/gtk-doc/html/ibus/ibus-IBusPendingCall.html
share/gtk-doc/html/ibus/ibus-ibusdebug.html
share/gtk-doc/html/ibus/ibus-ibuserror.html
-share/gtk-doc/html/ibus/ibus-ibusmainloop.html
share/gtk-doc/html/ibus/ibus-ibusshare.html
share/gtk-doc/html/ibus/ibus-ibustypes.html
share/gtk-doc/html/ibus/ibus-ibusversion.html
@@ -295,6 +197,72 @@ share/gtk-doc/html/ibus/left.png
share/gtk-doc/html/ibus/right.png
share/gtk-doc/html/ibus/style.css
share/gtk-doc/html/ibus/up.png
+%%DATADIR%%/component/gconf.xml
+%%DATADIR%%/component/gtkpanel.xml
+%%DATADIR%%/keymaps/common
+%%DATADIR%%/keymaps/in
+%%DATADIR%%/keymaps/jp
+%%DATADIR%%/keymaps/kr
+%%DATADIR%%/keymaps/modifiers
+%%DATADIR%%/keymaps/us
+%%DATADIR%%/setup/engineabout.py
+%%DATADIR%%/setup/engineabout.pyc
+%%DATADIR%%/setup/engineabout.pyo
+%%DATADIR%%/setup/enginecombobox.py
+%%DATADIR%%/setup/enginecombobox.pyc
+%%DATADIR%%/setup/enginecombobox.pyo
+%%DATADIR%%/setup/enginetreeview.py
+%%DATADIR%%/setup/enginetreeview.pyc
+%%DATADIR%%/setup/enginetreeview.pyo
+%%DATADIR%%/setup/i18n.py
+%%DATADIR%%/setup/i18n.pyc
+%%DATADIR%%/setup/i18n.pyo
+%%DATADIR%%/setup/icon.py
+%%DATADIR%%/setup/icon.pyc
+%%DATADIR%%/setup/icon.pyo
+%%DATADIR%%/setup/keyboardshortcut.py
+%%DATADIR%%/setup/keyboardshortcut.pyc
+%%DATADIR%%/setup/keyboardshortcut.pyo
+%%DATADIR%%/setup/main.py
+%%DATADIR%%/setup/main.pyc
+%%DATADIR%%/setup/main.pyo
+%%DATADIR%%/setup/setup.ui
+%%DATADIR%%/ui/gtk/candidatepanel.py
+%%DATADIR%%/ui/gtk/candidatepanel.pyc
+%%DATADIR%%/ui/gtk/candidatepanel.pyo
+%%DATADIR%%/ui/gtk/engineabout.py
+%%DATADIR%%/ui/gtk/engineabout.pyc
+%%DATADIR%%/ui/gtk/engineabout.pyo
+%%DATADIR%%/ui/gtk/handle.py
+%%DATADIR%%/ui/gtk/handle.pyc
+%%DATADIR%%/ui/gtk/handle.pyo
+%%DATADIR%%/ui/gtk/i18n.py
+%%DATADIR%%/ui/gtk/i18n.pyc
+%%DATADIR%%/ui/gtk/i18n.pyo
+%%DATADIR%%/ui/gtk/icon.py
+%%DATADIR%%/ui/gtk/icon.pyc
+%%DATADIR%%/ui/gtk/icon.pyo
+%%DATADIR%%/ui/gtk/languagebar.py
+%%DATADIR%%/ui/gtk/languagebar.pyc
+%%DATADIR%%/ui/gtk/languagebar.pyo
+%%DATADIR%%/ui/gtk/main.py
+%%DATADIR%%/ui/gtk/main.pyc
+%%DATADIR%%/ui/gtk/main.pyo
+%%DATADIR%%/ui/gtk/menu.py
+%%DATADIR%%/ui/gtk/menu.pyc
+%%DATADIR%%/ui/gtk/menu.pyo
+%%DATADIR%%/ui/gtk/notifications.py
+%%DATADIR%%/ui/gtk/notifications.pyc
+%%DATADIR%%/ui/gtk/notifications.pyo
+%%DATADIR%%/ui/gtk/panel.py
+%%DATADIR%%/ui/gtk/panel.pyc
+%%DATADIR%%/ui/gtk/panel.pyo
+%%DATADIR%%/ui/gtk/propitem.py
+%%DATADIR%%/ui/gtk/propitem.pyc
+%%DATADIR%%/ui/gtk/propitem.pyo
+%%DATADIR%%/ui/gtk/toolitem.py
+%%DATADIR%%/ui/gtk/toolitem.pyc
+%%DATADIR%%/ui/gtk/toolitem.pyo
share/icons/hicolor/16x16/apps/ibus-keyboard.png
share/icons/hicolor/22x22/apps/ibus-keyboard.png
share/icons/hicolor/24x24/apps/ibus-keyboard.png
@@ -304,20 +272,56 @@ share/icons/hicolor/scalable/apps/ibus-engine.svg
share/icons/hicolor/scalable/apps/ibus-keyboard.svg
share/icons/hicolor/scalable/apps/ibus-setup.svg
share/icons/hicolor/scalable/apps/ibus.svg
+%%NLS%%share/locale/ar/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/as/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/da/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/de/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/es/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/gu/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/it/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/kn/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/mr/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/or/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/ta/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/te/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus10.mo
+%%VALA%%share/vala/vapi/ibus-1.0.deps
%%VALA%%share/vala/vapi/ibus-1.0.vapi
-@dirrmtry share/gir-1.0
@dirrm %%DATADIR%%/ui/gtk
@dirrm %%DATADIR%%/ui
-@dirrmtry %%DATADIR%%/icons
+@dirrm %%DATADIR%%/setup
@dirrmtry %%DATADIR%%/keymaps
+@dirrmtry %%DATADIR%%/icons
@dirrmtry %%DATADIR%%/engine
@dirrmtry %%DATADIR%%/component
-@dirrm %%DATADIR%%/setup
@dirrmtry %%DATADIR%%
@dirrm share/gtk-doc/html/ibus
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc
+@dirrmtry share/gir-1.0
@dirrmtry share/applications
@dirrm %%PYTHON_SITELIBDIR%%/ibus/interface
@dirrm %%PYTHON_SITELIBDIR%%/ibus
@dirrm include/ibus-1.0
+%%GTK3%%@unexec gtk-query-immodules-3.0 --update-cache
+@unexec gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules