aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-client-lib
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 11:30:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 11:30:39 +0000
commit27f509effda18c393dcebc087e011b71f922ccee (patch)
tree18d8a4b65d7b2adcdc1cdeb22bf4ee72fa787bca /textproc/iiimf-client-lib
parent6a5159fe047b80ae3f3813e7ee39553bc8d713fc (diff)
downloadports-27f509effda18c393dcebc087e011b71f922ccee.tar.gz
ports-27f509effda18c393dcebc087e011b71f922ccee.zip
Notes
Diffstat (limited to 'textproc/iiimf-client-lib')
-rw-r--r--textproc/iiimf-client-lib/Makefile52
-rw-r--r--textproc/iiimf-client-lib/distinfo1
-rw-r--r--textproc/iiimf-client-lib/files/patch-lib_iiimcf_Makefile.in11
-rw-r--r--textproc/iiimf-client-lib/files/patch-lib_iiimcf_test_check_Makefile.in11
-rw-r--r--textproc/iiimf-client-lib/pkg-descr21
-rw-r--r--textproc/iiimf-client-lib/pkg-plist5
6 files changed, 101 insertions, 0 deletions
diff --git a/textproc/iiimf-client-lib/Makefile b/textproc/iiimf-client-lib/Makefile
new file mode 100644
index 000000000000..4306a098fb70
--- /dev/null
+++ b/textproc/iiimf-client-lib/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: iiimf-client-lib
+# Date created: 6 Dec 2003
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iiimf-client-lib
+PORTVERSION= ${IIIMF_VER:S/_/./:C/-.*//}
+CATEGORIES= textproc
+MASTER_SITES= http://www.openi18n.org/download/docs/im-sdk/
+DISTNAME= im-sdk
+DISTFILES= ${DISTNAME}.${IIIMF_VER:S/-/./}${EXTRACT_SUFX}
+
+MAINTAINER= kcwu@csie.org
+COMMENT= Internet/Intranet Input Method Client Framework
+
+LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib
+
+IIIMF_VER= r11_4-1467
+WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
+INSTALL_WRKSRC= ${WRKSRC}/lib/iiimcf
+USE_BZIP2= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --includedir=${PREFIX}/include/iiimf
+DIRS= lib/EIMIL lib/iiimcf
+
+post-patch:
+.for DIR in ${DIRS}
+ ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
+ -e "s,-D_POSIX_C_SOURCE=199506L,,g" \
+ -e "s,has_xiccallback=no,has_xiccallback=yes,g" \
+ -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ -e "s,-I\$${IM_INCLUDEDIR},-I${LOCALBASE}/include/iiimf,g" \
+ ${WRKSRC}/${DIR}/configure
+.endfor
+
+do-configure:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${SH} configure ${CONFIGURE_ARGS}
+.endfor
+
+do-build:
+.for DIR in ${DIRS}
+ cd ${WRKSRC}/${DIR} && ${GMAKE} all
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/iiimf-client-lib/distinfo b/textproc/iiimf-client-lib/distinfo
new file mode 100644
index 000000000000..4ec913af341f
--- /dev/null
+++ b/textproc/iiimf-client-lib/distinfo
@@ -0,0 +1 @@
+MD5 (im-sdk.r11_4.1467.tar.bz2) = ca6b6ac7c41641db6eaa0fa395748f90
diff --git a/textproc/iiimf-client-lib/files/patch-lib_iiimcf_Makefile.in b/textproc/iiimf-client-lib/files/patch-lib_iiimcf_Makefile.in
new file mode 100644
index 000000000000..3a0036103396
--- /dev/null
+++ b/textproc/iiimf-client-lib/files/patch-lib_iiimcf_Makefile.in
@@ -0,0 +1,11 @@
+--- lib/iiimcf/Makefile.in.orig Sun Dec 7 17:37:15 2003
++++ lib/iiimcf/Makefile.in Sun Dec 7 17:37:41 2003
+@@ -124,7 +124,7 @@
+ SUBDIRS = . test
+ #libdir = /usr/local/lib
+ libiiimcf_la_LDFLAGS = -module -version-info $(LIBIIIMCF_MAJOR_VERSION):$(LIBIIIMCF_MINOR_VERSION) \
+- -export-dynamic -export-symbols libiiimcf.sym -L../iiimp -liiimp
++ -export-dynamic -export-symbols libiiimcf.sym -L$(prefix)/lib -liiimp
+
+ libiiimcf_la_CFLAGS = -DDEBUG
+ libiiimcf_la_SOURCES = iiimcf.c attr.c commit.c context.c event.c \
diff --git a/textproc/iiimf-client-lib/files/patch-lib_iiimcf_test_check_Makefile.in b/textproc/iiimf-client-lib/files/patch-lib_iiimcf_test_check_Makefile.in
new file mode 100644
index 000000000000..943a775c7a3b
--- /dev/null
+++ b/textproc/iiimf-client-lib/files/patch-lib_iiimcf_test_check_Makefile.in
@@ -0,0 +1,11 @@
+--- lib/iiimcf/test/check/Makefile.in.orig Sat Dec 6 05:07:37 2003
++++ lib/iiimcf/test/check/Makefile.in Sat Dec 6 05:08:00 2003
+@@ -96,7 +96,7 @@
+ IM_LOCALEDIR = @IM_LOCALEDIR@
+ IM_TOPDIR = @IM_TOPDIR@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-LDFLAGS = @LDFLAGS@
++LDFLAGS = @LDFLAGS@ $(THREAD_LDFLAGS)
+ LIBIIIMCF_MAJOR_VERSION = @LIBIIIMCF_MAJOR_VERSION@
+ LIBIIIMCF_MINOR_VERSION = @LIBIIIMCF_MINOR_VERSION@
+ LIBIIIMCF_VERSION = @LIBIIIMCF_VERSION@
diff --git a/textproc/iiimf-client-lib/pkg-descr b/textproc/iiimf-client-lib/pkg-descr
new file mode 100644
index 000000000000..ac72b20e8941
--- /dev/null
+++ b/textproc/iiimf-client-lib/pkg-descr
@@ -0,0 +1,21 @@
+IIIMF stands for Internet/Intranet Input Method Framework.
+IIIMF is designed to be the next generation of input method framework
+which provides the following capabilities;
+
+* Multiplatform, platform independent.
+* Multlingual and Full UNICODE support, but satisfactory for native speakers.
+* Windowing System Independent.
+* Multiple language engines concurrently run.
+* Multiuser.
+* Distributed, lightweight clients and scalable server.
+* Extensible in multiple means.
+* Input method protocol efficient enough to be used over low-speed modem
+ connection.
+* Easy input method engine development with plugin API.
+* Easy input method enabling with libiiimcf, even on console apps.
+* Small core part to start from.
+
+WWW: http://www.openi18n.org/subgroups/im/IIIMF/
+
+- Kuang-che Wu
+ kcwu@csie.org
diff --git a/textproc/iiimf-client-lib/pkg-plist b/textproc/iiimf-client-lib/pkg-plist
new file mode 100644
index 000000000000..4924a717d833
--- /dev/null
+++ b/textproc/iiimf-client-lib/pkg-plist
@@ -0,0 +1,5 @@
+include/iiimf/iiimcf.h
+lib/libiiimcf.so.2
+lib/libiiimcf.so
+lib/libiiimcf.la
+lib/libiiimcf.a