aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-protocol-lib
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 11:00:27 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 11:00:27 +0000
commite4e750a6e6beba791a11340c75797b43bfe21191 (patch)
tree5cf00b8364027c5d6b211c3b1e4b0dd6054bbc84 /textproc/iiimf-protocol-lib
parent69011721561043e87653565d46d627acca7a06e8 (diff)
Notes
Diffstat (limited to 'textproc/iiimf-protocol-lib')
-rw-r--r--textproc/iiimf-protocol-lib/Makefile37
-rw-r--r--textproc/iiimf-protocol-lib/distinfo1
-rw-r--r--textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h11
-rw-r--r--textproc/iiimf-protocol-lib/pkg-descr21
-rw-r--r--textproc/iiimf-protocol-lib/pkg-plist11
5 files changed, 81 insertions, 0 deletions
diff --git a/textproc/iiimf-protocol-lib/Makefile b/textproc/iiimf-protocol-lib/Makefile
new file mode 100644
index 000000000000..a2aa015396dd
--- /dev/null
+++ b/textproc/iiimf-protocol-lib/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: iiimf-protocol-lib
+# Date created: 6 Dec 2003
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iiimf-protocol-lib
+PORTVERSION= ${IIIMF_VER:S/_/./:C/-.*//}
+CATEGORIES= textproc
+MASTER_SITES= http://www.openi18n.org/download/docs/im-sdk/
+DISTNAME= im-sdk
+DISTFILES= ${DISTNAME}.${IIIMF_VER:S/-/./}${EXTRACT_SUFX}
+
+MAINTAINER= kcwu@csie.org
+COMMENT= Internet/Intranet Input Method Framework protocol library
+
+IIIMF_VER= r11_4-1467
+WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}/lib/iiimp
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --includedir=${PREFIX}/include/iiimf/iiimp
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
+ -e "s,-D_POSIX_C_SOURCE=199506L,,g" \
+ -e "s,has_xiccallback=no,has_xiccallback=yes,g" \
+ -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/textproc/iiimf-protocol-lib/distinfo b/textproc/iiimf-protocol-lib/distinfo
new file mode 100644
index 000000000000..4ec913af341f
--- /dev/null
+++ b/textproc/iiimf-protocol-lib/distinfo
@@ -0,0 +1 @@
+MD5 (im-sdk.r11_4.1467.tar.bz2) = ca6b6ac7c41641db6eaa0fa395748f90
diff --git a/textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h b/textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h
new file mode 100644
index 000000000000..b3a187bf353c
--- /dev/null
+++ b/textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h
@@ -0,0 +1,11 @@
+--- include/iiimp/iiimp-data.h.orig Sat Dec 6 02:19:44 2003
++++ include/iiimp/iiimp-data.h Sat Dec 6 02:18:15 2003
+@@ -7,7 +7,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+
+-#if defined(linux)
++#if defined(linux) || defined(__FreeBSD__)
+ #include <stdint.h>
+ typedef unsigned char uchar_t;
+ typedef unsigned int uint_t;
diff --git a/textproc/iiimf-protocol-lib/pkg-descr b/textproc/iiimf-protocol-lib/pkg-descr
new file mode 100644
index 000000000000..ac72b20e8941
--- /dev/null
+++ b/textproc/iiimf-protocol-lib/pkg-descr
@@ -0,0 +1,21 @@
+IIIMF stands for Internet/Intranet Input Method Framework.
+IIIMF is designed to be the next generation of input method framework
+which provides the following capabilities;
+
+* Multiplatform, platform independent.
+* Multlingual and Full UNICODE support, but satisfactory for native speakers.
+* Windowing System Independent.
+* Multiple language engines concurrently run.
+* Multiuser.
+* Distributed, lightweight clients and scalable server.
+* Extensible in multiple means.
+* Input method protocol efficient enough to be used over low-speed modem
+ connection.
+* Easy input method engine development with plugin API.
+* Easy input method enabling with libiiimcf, even on console apps.
+* Small core part to start from.
+
+WWW: http://www.openi18n.org/subgroups/im/IIIMF/
+
+- Kuang-che Wu
+ kcwu@csie.org
diff --git a/textproc/iiimf-protocol-lib/pkg-plist b/textproc/iiimf-protocol-lib/pkg-plist
new file mode 100644
index 000000000000..183e7e775e5c
--- /dev/null
+++ b/textproc/iiimf-protocol-lib/pkg-plist
@@ -0,0 +1,11 @@
+include/iiimf/iiimp/iiimp.h
+include/iiimf/iiimp/iiimp-opcode.h
+include/iiimf/iiimp/iiimp-keycode.h
+include/iiimf/iiimp/iiimp-data.h
+include/iiimf/iiimp/iiimp-character-subsets.h
+@dirrm include/iiimf/iiimp
+@dirrm include/iiimf
+lib/libiiimp.so.0
+lib/libiiimp.so
+lib/libiiimp.la
+lib/libiiimp.a