aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-x-lib
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-13 19:35:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-13 19:35:34 +0000
commit183bd15c0ec113c0015b05c0da0a613d015b1250 (patch)
tree25f2f28498df28b57749f60c6363454b1fa5fa3e /textproc/iiimf-x-lib
parentbd9b2225347aec0a9f522243052fc6e925afa79a (diff)
downloadports-183bd15c0ec113c0015b05c0da0a613d015b1250.tar.gz
ports-183bd15c0ec113c0015b05c0da0a613d015b1250.zip
Notes
Diffstat (limited to 'textproc/iiimf-x-lib')
-rw-r--r--textproc/iiimf-x-lib/Makefile59
-rw-r--r--textproc/iiimf-x-lib/distinfo2
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am12
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c16
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c11
-rw-r--r--textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c22
-rw-r--r--textproc/iiimf-x-lib/pkg-descr21
-rw-r--r--textproc/iiimf-x-lib/pkg-plist3
8 files changed, 146 insertions, 0 deletions
diff --git a/textproc/iiimf-x-lib/Makefile b/textproc/iiimf-x-lib/Makefile
new file mode 100644
index 000000000000..24ba3371977a
--- /dev/null
+++ b/textproc/iiimf-x-lib/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: iiimf-x-lib
+# Date created: 8 Sep 2004
+# Whom: Kuang-che Wu <kcwu@csie.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x-lib
+PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
+CATEGORIES= textproc
+MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
+PKGNAMEPREFIX= iiimf-
+DISTNAME= im-sdk
+DISTFILES= ${DISTNAME}-src-${IIIMF_VER}.tgz
+
+MAINTAINER= kcwu@csie.org
+COMMENT= Internet/Intranet Input Method X Client Framework
+
+LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib \
+ iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
+RUN_DEPENDS= ${LOCALBASE}/csconv/csconv.so:${PORTSDIR}/textproc/iiimf-csconv
+
+IIIMF_VER= r12_0_1-svn1891
+WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}/iiimxcf/xiiimp.so
+INSTALLS_SHLIB= yes
+USE_MOTIF= yes
+USE_REINPLACE= yes
+USE_OPENSSL= yes
+USE_AUTOCONF_VER= 259
+USE_AUTOHEADER_VER= 259
+USE_AUTOMAKE_VER= 19
+USE_LIBTOOL_VER= 15
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ ${WRKSRC}/../../acfiles/im_common.m4 \
+ ${WRKSRC}/configure.ac \
+ ${WRKSRC}/iiimp/iiimpAux.c \
+ ${WRKSRC}/iiimp/iiimpDL.c \
+ ${WRKSRC}/iiimp/iiimpIM.c \
+ ${WRKSRC}/iiimp/iiimpConv.c \
+ ${WRKSRC}/iiimp/csconv.h
+.if ${OSVERSION} == 502010
+ ${REINPLACE_CMD} -e "s,-DARCH=[^ ]*,," \
+ ${WRKSRC}/../../acfiles/check_sys.m4
+.endif
+
+pre-configure:
+ cd ${WRKSRC} && ${ACLOCAL} -I ${LOCALBASE}/share/aclocal -I ../../acfiles
+ ${TOUCH} ${WRKSRC}/config.h.in
+
+.include <bsd.port.post.mk>
diff --git a/textproc/iiimf-x-lib/distinfo b/textproc/iiimf-x-lib/distinfo
new file mode 100644
index 000000000000..29d049a782bc
--- /dev/null
+++ b/textproc/iiimf-x-lib/distinfo
@@ -0,0 +1,2 @@
+MD5 (im-sdk-src-r12_0_1-svn1891.tgz) = 4e51e4fd07391bd957622db0e89aeefe
+SIZE (im-sdk-src-r12_0_1-svn1891.tgz) = 18206118
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am
new file mode 100644
index 000000000000..0f410643b08e
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_Makefile.am
@@ -0,0 +1,12 @@
+--- iiimp/Makefile.am.orig Sun Sep 5 05:33:03 2004
++++ iiimp/Makefile.am Sun Sep 5 05:33:26 2004
+@@ -9,7 +9,7 @@
+ # -Wl,-z -Wl,defs
+ xiiimp_la_LIBADD = $(X_LIBS) \
+- $(IM_LIBDIR)/iiimcf/libiiimcf.la \
+- $(IM_LIBDIR)/iiimp/libiiimp.la \
++ -L$(LOCALBASE)/lib -liiimcf \
++ -L$(LOCALBASE)/lib -liiimp \
+ $(DLOPEN_LIBS) $(THREAD_LIBS)
+ xiiimp_la_SOURCES = \
+ genutil.c \
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
new file mode 100644
index 000000000000..706ace9314bb
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpAux.c
@@ -0,0 +1,16 @@
+--- iiimp/iiimpAux.c.orig Wed Oct 13 21:13:37 2004
++++ iiimp/iiimpAux.c Wed Oct 13 21:14:40 2004
+@@ -1997,11 +1997,12 @@
+ static void
+ service_set_conversion_mode(aux_t * aux, int conversion_mode)
+ {
++ XVaNestedList preedit_attr;
+ XIC xic = (XIC)aux->ic;
+ XIMPreeditState preedit_state;
+
+ preedit_state = (conversion_mode == 1 ? XIMPreeditEnable : XIMPreeditDisable);
+- XVaNestedList preedit_attr = XVaCreateNestedList(0,
++ preedit_attr = XVaCreateNestedList(0,
+ XNPreeditState, preedit_state,
+ 0);
+ XSetICValues((XIC)xic,
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c
new file mode 100644
index 000000000000..cb4570473b80
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpConv.c
@@ -0,0 +1,11 @@
+--- iiimp/iiimpConv.c.orig Tue Sep 7 20:42:04 2004
++++ iiimp/iiimpConv.c Tue Sep 7 20:42:22 2004
+@@ -44,7 +44,7 @@
+ #if defined(sun)
+ #define USE_ICONV
+ #else
+-#define USE_ICONV
++#define USE_CSCONV
+ #endif
+ #endif
+
diff --git a/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c
new file mode 100644
index 000000000000..26dc0f2441b0
--- /dev/null
+++ b/textproc/iiimf-x-lib/files/patch-iiimxcf_xiiimp.so_iiimp_iiimpSwitcher.c
@@ -0,0 +1,22 @@
+--- iiimp/iiimpSwitcher.c.orig Thu Apr 29 23:04:48 2004
++++ iiimp/iiimpSwitcher.c Wed Oct 13 21:25:32 2004
+@@ -108,14 +108,16 @@
+ char *
+ my_stpcpy (char *dest, const char *src)
+ {
++#ifndef HAVE_STPCPY
++ register char *d = dest;
++ register const char *s = src;
++#endif
++
+ if (dest == NULL || src == NULL)
+ return NULL;
+ #ifdef HAVE_STPCPY
+ return stpcpy (dest, src);
+ #else
+- register char *d = dest;
+- register const char *s = src;
+-
+ do
+ *d++ = *s;
+ while (*s++ != '\0');
diff --git a/textproc/iiimf-x-lib/pkg-descr b/textproc/iiimf-x-lib/pkg-descr
new file mode 100644
index 000000000000..ac72b20e8941
--- /dev/null
+++ b/textproc/iiimf-x-lib/pkg-descr
@@ -0,0 +1,21 @@
+IIIMF stands for Internet/Intranet Input Method Framework.
+IIIMF is designed to be the next generation of input method framework
+which provides the following capabilities;
+
+* Multiplatform, platform independent.
+* Multlingual and Full UNICODE support, but satisfactory for native speakers.
+* Windowing System Independent.
+* Multiple language engines concurrently run.
+* Multiuser.
+* Distributed, lightweight clients and scalable server.
+* Extensible in multiple means.
+* Input method protocol efficient enough to be used over low-speed modem
+ connection.
+* Easy input method engine development with plugin API.
+* Easy input method enabling with libiiimcf, even on console apps.
+* Small core part to start from.
+
+WWW: http://www.openi18n.org/subgroups/im/IIIMF/
+
+- Kuang-che Wu
+ kcwu@csie.org
diff --git a/textproc/iiimf-x-lib/pkg-plist b/textproc/iiimf-x-lib/pkg-plist
new file mode 100644
index 000000000000..df789b5b13a4
--- /dev/null
+++ b/textproc/iiimf-x-lib/pkg-plist
@@ -0,0 +1,3 @@
+lib/im/xiiimp.so.2
+lib/im/xiiimp.so
+@unexec rmdir %D/lib/im 2>/dev/null || true