aboutsummaryrefslogtreecommitdiff
path: root/textproc/iiimf-x
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2005-05-24 12:37:50 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2005-05-24 12:37:50 +0000
commit40a684ff1e8608bde986585a735e66d9a456e675 (patch)
tree21680bac7d4436c9b33d17b1753f63e511708512 /textproc/iiimf-x
parentcf0ac5bd5cf5b77385239923b8c09f789a94513d (diff)
downloadports-40a684ff1e8608bde986585a735e66d9a456e675.tar.gz
ports-40a684ff1e8608bde986585a735e66d9a456e675.zip
Notes
Diffstat (limited to 'textproc/iiimf-x')
-rw-r--r--textproc/iiimf-x/Makefile63
-rw-r--r--textproc/iiimf-x/distinfo4
-rw-r--r--textproc/iiimf-x/files/patch-Makefile60
-rw-r--r--textproc/iiimf-x/files/patch-acfiles_check_sys.m412
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_Makefile.am7
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac21
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_Makefile.in21
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp11
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c13
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_Makefile.am11
-rw-r--r--textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c26
-rw-r--r--textproc/iiimf-x/pkg-plist4
12 files changed, 105 insertions, 148 deletions
diff --git a/textproc/iiimf-x/Makefile b/textproc/iiimf-x/Makefile
index 7a82a8f54d8f..163a818ae3b6 100644
--- a/textproc/iiimf-x/Makefile
+++ b/textproc/iiimf-x/Makefile
@@ -6,67 +6,54 @@
#
PORTNAME= x
-PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
-PORTREVISION= 1
+PORTVERSION= 12.2
CATEGORIES= textproc
MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
PKGNAMEPREFIX= iiimf-
-DISTNAME= im-sdk-src-${IIIMF_VER}
+DISTNAME= iiimf-src-${PORTVERSION}
EXTRACT_SUFX= .tar.bz2
-MAINTAINER= kcwu@csie.org
+MAINTAINER= ozawa@ongs.co.jp
COMMENT= Internet/Intranet Input Method X Client Framework
-LIB_DEPENDS= iiimp.0:${PORTSDIR}/textproc/iiimf-protocol-lib \
- iiimcf.2:${PORTSDIR}/textproc/iiimf-client-lib
-RUN_DEPENDS= ${LOCALBASE}/lib/im/xiiimp.so:${PORTSDIR}/textproc/iiimf-x-lib
+LIB_DEPENDS= iiimp.1:${PORTSDIR}/textproc/iiimf-protocol-lib \
+ iiimcf.3:${PORTSDIR}/textproc/iiimf-client-lib
+RUN_DEPENDS= ${LOCALBASE}/lib/iiim/xiiimp.so:${PORTSDIR}/textproc/iiimf-x-lib
+
+ONLY_FOR_ARCHS= i386
-IIIMF_VER= r12_1-svn2002
USE_BZIP2= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_XLIB= yes
-USE_AUTOCONF_VER= 259
-USE_AUTOHEADER_VER= 259
-USE_AUTOMAKE_VER= 19
+WANT_AUTOCONF_VER= 259
+WANT_AUTOHEADER_VER= 259
+WANT_AUTOMAKE_VER= 19
WANT_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}/iiimxcf/htt_xbe
-PATCH_WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
+WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
+BUILDDIR= ${WRKSRC}/iiimxcf/htt_xbe
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 503000
-IGNORE= "It is supported on FreeBSD 5.3 and later"
-.endif
-
-.if ${ARCH} != "i386"
-IGNORE= "${ARCH} is not support."
+IGNORE= It is supported on FreeBSD 5.3 and later.
.endif
CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+CXXFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
-UPDATE_ARGS+= ACLOCAL=${ACLOCAL} AUTOMAKE=${AUTOMAKE} \
- AUTOHEADER=${AUTOHEADER} AUTOCONF=${AUTOCONF} \
- LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
- ACLOCAL_DIR="-I ${LOCALBASE}/share/aclocal -I ${ACLOCAL_DIR}"
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
post-patch:
- ${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
- ${WRKSRC}/../../acfiles/im_common.m4
-
-pre-configure:
- @cd ${WRKSRC}/../.. && ${GMAKE} ${UPDATE_ARGS} update-acfiles
- @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
- -I ../../acfiles -I ${LOCALBASE}/share/aclocal -I ${ACLOCAL_DIR}
- @cd ${WRKSRC} && ${REINPLACE_CMD} \
- -e "s^\$$ac_aux_dir/ltconfig^${LTCONFIG}^g" \
- -e "/^ltmain=/!s^\$$ac_aux_dir/ltmain.sh^${LIBTOOLFLAGS} ${LTMAIN}^g" \
- -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
- ${LIBTOOLFILES}
- @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER}
+ ${REINPLACE_CMD} \
+ -e "s,%%LOCALBASE%%,${LOCALBASE},g" \
+ -e "s,%%PREFIX%%,${PREFIX},g" \
+ ${WRKSRC}/Makefile ${BUILDDIR}/Makefile.am \
+ ${BUILDDIR}/src/watchdog.c
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${GMAKE} reconfig
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${GMAKE} config
.include <bsd.port.post.mk>
diff --git a/textproc/iiimf-x/distinfo b/textproc/iiimf-x/distinfo
index 440e49d16220..4416cce728d0 100644
--- a/textproc/iiimf-x/distinfo
+++ b/textproc/iiimf-x/distinfo
@@ -1,2 +1,2 @@
-MD5 (im-sdk-src-r12_1-svn2002.tar.bz2) = 51f3f10b11f8d4a206e2b190ec36a32a
-SIZE (im-sdk-src-r12_1-svn2002.tar.bz2) = 18141292
+MD5 (iiimf-src-12.2.tar.bz2) = 70dbf257fe64ddf8611dfa6449da537c
+SIZE (iiimf-src-12.2.tar.bz2) = 11452670
diff --git a/textproc/iiimf-x/files/patch-Makefile b/textproc/iiimf-x/files/patch-Makefile
index bcc2cb24a1c8..84f3d2261920 100644
--- a/textproc/iiimf-x/files/patch-Makefile
+++ b/textproc/iiimf-x/files/patch-Makefile
@@ -1,19 +1,47 @@
---- Makefile Thu Apr 8 03:28:00 2004
-+++ Makefile Wed Feb 16 14:09:34 2005
-@@ -2,6 +2,7 @@
- AUTOMAKE = automake
- AUTOHEADER = autoheader
- AUTOCONF = autoconf
-+LIBTOOLIZE = libtoolize
+--- Makefile.orig Mon May 9 15:32:45 2005
++++ Makefile Mon May 9 15:35:03 2005
+@@ -1,29 +1,31 @@
+ ## deprecated in favour of AUTORECONF
+-#ACLOCAL = aclocal
+-#AUTOMAKE = automake --add-missing --copy
+-#LIBTOOLIZE = libtoolize --force --copy
+-#AUTOHEADER = autoheader
+-#AUTOCONF = autoconf
++ACLOCAL = aclocal19
++AUTOMAKE = automake19 --add-missing --copy
++LIBTOOLIZE = libtoolize15 --force --copy
++AUTOHEADER = autoheader259
++AUTOCONF = autoconf259
+ #CONFIG_CMD = $(ACLOCAL) -I $${acfilesdir} && \
+ # $(LIBTOOLIZE) && \
+ # $(AUTOHEADER) && \
+ # $(AUTOMAKE) && \
+ # $(AUTOCONF)
- CONFIG_CMD = $(ACLOCAL) -I $${acfilesdir} && \
- $(AUTOHEADER) && \
-@@ -21,7 +22,7 @@
+-AUTORECONF = autoreconf
++AUTORECONF = autoreconf259
+ BOOTSTRAP = $(AUTORECONF) --install --force
+ INTL_CMD = glib-gettextize -f && intltoolize --copy --force --automake
- update-acfiles:
- cd acfiles && \
-- $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && libtoolize --force --copy && \
-+ $(ACLOCAL) $(ACLOCAL_DIR) && $(AUTOMAKE) --add-missing --copy && $(LIBTOOLIZE) --force --copy && \
- rm -f Makefile.in aclocal.m4
+-CONFIG_FLAGS = --prefix=/usr --sysconfdir=/etc --localstatedir=/var
++CONFIG_FLAGS = --prefix=%%PREFIX%% --sysconfdir=%%LOCALBASE%%/etc --localstatedir=/var
+
+-INTLDIRS = iiimgcf gnome-im-switcher
++#INTLDIRS = iiimgcf gnome-im-switcher
+
+-BUILDDIRS = lib/CSConv lib/EIMIL lib/iiimp lib/iiimcf \
+- iiimsf leif leif/sun_le_korea leif/sch_le_sun leif/tch_le_sun \
+- iiimxcf/xiiimp.so iiimxcf/htt_xbe \
+- iiimgcf gnome-im-switcher doc
++BUILDDIRS = iiimxcf/htt_xbe
++#BUILDDIRS = lib/CSConv lib/EIMIL lib/iiimp lib/iiimcf \
++# iiimsf leif leif/sun_le_korea leif/sch_le_sun leif/tch_le_sun \
++# iiimxcf/xiiimp.so iiimxcf/htt_xbe \
++# iiimgcf gnome-im-switcher doc
+
+-CONFIGDIRS = $(BUILDDIRS) leif/m17n_le leif/thai_le_sun
++CONFIGDIRS = $(BUILDDIRS)
++#CONFIGDIRS = $(BUILDDIRS) leif/m17n_le leif/thai_le_sun
+
+ all: compile
- config:
diff --git a/textproc/iiimf-x/files/patch-acfiles_check_sys.m4 b/textproc/iiimf-x/files/patch-acfiles_check_sys.m4
index 8626eeae1fd1..44ee86c035bc 100644
--- a/textproc/iiimf-x/files/patch-acfiles_check_sys.m4
+++ b/textproc/iiimf-x/files/patch-acfiles_check_sys.m4
@@ -1,10 +1,12 @@
---- acfiles/check_sys.m4.orig Tue Sep 14 13:31:27 2004
-+++ acfiles/check_sys.m4 Wed Mar 2 08:39:25 2005
-@@ -203,6 +203,11 @@
+--- acfiles/check_sys.m4.orig Mon May 9 15:28:20 2005
++++ acfiles/check_sys.m4 Mon May 9 15:32:07 2005
+@@ -203,6 +203,13 @@
CXX=${CC}
fi
;;
+ cc*:*)
++ DEBUG_CFLAGS="${DEBUG_CFLAGS} -ggdb"
++ DEBUG_CXXFLAGS="${DEBUG_CXXFLAGS} -g"
+ COMMON_CFLAGS="${COMMON_CFLAGS} -Wall"
+ SHLIBCFLAGS='-fpic'
+ SHLIBLDFLAGS='-shared'
@@ -12,7 +14,7 @@
*)
DEBUG_CXX_CFLAGS="${DEBUG_CXX_CFLAGS} -g"
;;
-@@ -249,8 +254,8 @@
+@@ -249,8 +256,8 @@
COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} -DLinux"
;;
*freebsd*)
@@ -23,7 +25,7 @@
;;
esac
-@@ -288,9 +293,9 @@
+@@ -288,9 +295,9 @@
THREAD_CXX_CFLAGS="-mt"
HAVE_THREAD="uithread"
;;
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_Makefile.am b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_Makefile.am
new file mode 100644
index 000000000000..9c67f6753abc
--- /dev/null
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_Makefile.am
@@ -0,0 +1,7 @@
+--- iiimxcf/htt_xbe/Makefile.am.orig Fri May 13 15:44:05 2005
++++ iiimxcf/htt_xbe/Makefile.am Fri May 13 15:44:22 2005
+@@ -1,3 +1,3 @@
+ AUTOMAKE_OPTIONS = foreign
+-ACLOCAL_AMFLAGS = -I ../../acfiles
++ACLOCAL_AMFLAGS = -I %%LOCALBASE%%/share/aclocal -I ../../acfiles
+ SUBDIRS = lib src
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac
deleted file mode 100644
index 61e6d3e830bc..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_configure.ac
+++ /dev/null
@@ -1,21 +0,0 @@
---- iiimxcf/htt_xbe/configure.ac Wed Mar 24 04:54:26 2004
-+++ iiimxcf/htt_xbe/configure.ac Wed Feb 16 19:38:26 2005
-@@ -140,15 +140,15 @@
- COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} ${DLOPEN_CXX_CFLAGS} -DSUPPORT_R6IM"
- LIBS="${LIBS} ${DLOPEN_LIBS}"
-
- CFLAGS="${COMMON_INCLUDE} ${COMMON_CXX_CFLAGS} ${COMMON_CFLAGS} \
- ${DEBUG_CXX_CFLAGS} ${DEBUG_CFLAGS} \
-- ${THREAD_COMMON_CXX_CFLAGS}"
-+ ${THREAD_COMMON_CXX_CFLAGS} ${CFLAGS}"
-
- CXXFLAGS="${COMMON_INCLUDE} ${COMMON_CXX_CFLAGS} ${COMMON_CXXFLAGS} \
- ${DEBUG_CXX_CFLAGS} ${DEBUG_CXXFLAGS} \
-- ${THREAD_COMMON_CXX_CFLAGS}"
-+ ${THREAD_COMMON_CXX_CFLAGS} ${CFLAGS}"
-
--LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS}"
-+LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS} ${LDFLAGS}"
-
- dnl --------------------------------------------------------------------------------
- dnl Section 6: compilation test
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_Makefile.in b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_Makefile.in
deleted file mode 100644
index a3a3771ab9d4..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- iiimxcf/htt_xbe/lib/IMdkit/Makefile.in.orig Wed May 7 12:25:24 2003
-+++ iiimxcf/htt_xbe/lib/IMdkit/Makefile.in Thu Mar 3 16:25:30 2005
-@@ -57,6 +57,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-
-+IMDIR = @IMDIR@
- IM_TOPDIR = @IM_TOPDIR@
- IM_INCLUDEDIR = @IM_INCLUDEDIR@
- CSCONV_DIR = @CSCONV_DIR@
-@@ -74,8 +75,8 @@
- LINKER = @LINKER@
- RANLIB = @RANLIB@
-
--CFLAGS = @CFLAGS@
--CXXFLAGS = @CXXFLAGS@
-+CFLAGS = -DIMDIR="\"${IMDIR}\"" @CFLAGS@
-+CXXFLAGS = -DIMDIR="\"${IMDIR}\"" @CXXFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
-
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp
deleted file mode 100644
index 3e6552ed63fc..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_common_XIMPublic.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- iiimxcf/htt_xbe/lib/IMdkit/common/XIMPublic.cpp Wed Mar 24 04:54:26 2004
-+++ iiimxcf/htt_xbe/lib/IMdkit/common/XIMPublic.cpp Wed Feb 16 21:31:00 2005
-@@ -68,7 +68,7 @@
- #ifdef sun
- #define XIIIMP_PATH "/usr/openwin/lib/locale/common/xiiimp.so.2"
- #else /* Linux */
--#define XIIIMP_PATH "/usr/lib/im/xiiimp.so.2"
-+#define XIIIMP_PATH (IMDIR "/xiiimp.so.2")
- #endif /* Linux */
-
- #include <stdio.h>
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c
deleted file mode 100644
index 586641366c0b..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_lib_IM_r6im_i18nX.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- iiimxcf/htt_xbe/lib/IMdkit/r6im/i18nX.c Fri Nov 1 09:15:38 2002
-+++ iiimxcf/htt_xbe/lib/IMdkit/r6im/i18nX.c Wed Feb 16 19:33:10 2005
-@@ -389,8 +389,8 @@
- extern void _Xi18nMessageHandler(XIMS, CARD16,
- unsigned char*, Bool*);
- Bool delete = True;
-- unsigned char *packet;
-- int connect_id;
-+ unsigned char *packet = NULL;
-+ int connect_id = 0;
-
- if (((XClientMessageEvent *)ev)->message_type ==
- spec->xim_request) {
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_Makefile.am b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_Makefile.am
deleted file mode 100644
index 9d24150b59be..000000000000
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- iiimxcf/htt_xbe/src/Makefile.am.orig Thu Mar 3 00:29:58 2005
-+++ iiimxcf/htt_xbe/src/Makefile.am Thu Mar 3 00:30:30 2005
-@@ -4,7 +4,7 @@
- htt_xbe_LDADD = -L../lib/IMdkit -lIMd_ximp -lIMd_r6im $(X_LIBS) -lXt $(THREAD_LIBS)
- htt_xbe_SOURCES = ResourceDB.cpp main.cpp
-
--httx_CFLAGS = $(X_CFLAGS)
-+httx_CFLAGS = $(X_CFLAGS) -DIMDIR="\"${IMDIR}\""
- httx_LDADD = $(X_LIBS) -lXt
- httx_SOURCES = watchdog.c
-
diff --git a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
index 1136ab8d847e..31dc36352b89 100644
--- a/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
+++ b/textproc/iiimf-x/files/patch-iiimxcf_htt_xbe_src_watchdog.c
@@ -1,14 +1,15 @@
---- iiimxcf/htt_xbe/src/watchdog.c Tue Jul 13 08:25:40 2004
-+++ iiimxcf/htt_xbe/src/watchdog.c Wed Feb 16 19:12:34 2005
-@@ -81,7 +81,6 @@
+--- iiimxcf/htt_xbe/src/watchdog.c.orig Thu Apr 28 15:09:27 2005
++++ iiimxcf/htt_xbe/src/watchdog.c Mon May 16 23:39:28 2005
+@@ -79,7 +79,7 @@
+ #ifndef OPENWINHOME
+ #define OPENWINHOME "/usr/openwin"
#endif
- #define OPENWIN_MOTIF_PRELOAD_ENV "LD_PRELOAD=/usr/dt/lib/libXm.so.3"
+-#define OPENWIN_MOTIF_PRELOAD_ENV "LD_PRELOAD=/usr/dt/lib/libXm.so.3"
++#define OPENWIN_MOTIF_PRELOAD_ENV "LD_PRELOAD=/usr/X11R6/lib/libXm.so.3"
--#define IMDIR "/usr/lib/im"
+ #define IMDIR IIIMLIBDIR
- static void start_htt_server(int *, char *argv[]);
- static void start_htt_props(int *, char *argv[]);
-@@ -744,7 +743,11 @@
+@@ -811,7 +811,11 @@
perror("watchdog:fork\n");
exit(errno);
case 0:
@@ -20,3 +21,12 @@
if (!my_rdb.respond_to_sm)
sleep(10);
execv(pathname, argv);
+@@ -828,7 +832,7 @@
+ extern int errno;
+ int pid;
+
+- pathname = "/usr/bin/iiimd";
++ pathname = "%%PREFIX%%" "/bin/iiimd";
+
+ pid = (*iiimd_pid) = fork();
+ switch (*iiimd_pid) {
diff --git a/textproc/iiimf-x/pkg-plist b/textproc/iiimf-x/pkg-plist
index 2f8604c6a8e4..cb790e777d40 100644
--- a/textproc/iiimf-x/pkg-plist
+++ b/textproc/iiimf-x/pkg-plist
@@ -1,2 +1,2 @@
-lib/im/httx
-lib/im/htt_xbe
+bin/iiimx
+lib/iiim/iiim-xbe